security/heimdal update to v7.5.0 - See TODO file.

This commit is contained in:
Sevan Janiyan 2018-12-26 21:18:35 +00:00
parent f5b395baad
commit 78bba0bdba
15 changed files with 1975 additions and 0 deletions

11
heimdal/DESCR Normal file
View File

@ -0,0 +1,11 @@
Heimdal is a free implementation of Kerberos 5.
Kerberos is a system for authenticating users and services on a network.
It is built upon the assumption that the network is "unsafe". Kerberos
is a trusted third-party service. That means that there is a third
party (the Kerberos server) that is trusted by all the entities on the
network (users and services, usually called "principals"). All
principals share a secret password (or key) with the Kerberos server and
this enables principals to verify that the messages from the Kerberos
server are authentic. Thus trusting the Kerberos server, users and
services can authenticate each other.

136
heimdal/Makefile Normal file
View File

@ -0,0 +1,136 @@
# $NetBSD: Makefile,v 1.129 2018/12/09 18:52:07 adam Exp $
DISTNAME= heimdal-7.5.0
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GITHUB:=heimdal/}
GITHUB_PROJECT= heimdal
GITHUB_RELEASE= ${DISTNAME}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.h5l.org/
COMMENT= Kerberos 5 implementation
LICENSE= modified-bsd
CONFLICTS+= arla-[0-9]*
CONFLICTS+= mit-krb5-[0-9]*
CONFLICTS+= openafs-[0-9]*
CONFLICTS+= gss-[0-9]*
CONFLICTS+= kth-krb4-[0-9]*
MAKE_JOBS_SAFE= no
USE_LIBTOOL= yes
USE_TOOLS+= bison flex:run
PKGCONFIG_OVERRIDE+= tools/heimdal-gssapi.pc.in
MAKE_ENV+= INSTALL_CATPAGES=no
.include "../../mk/bsd.prefs.mk"
.include "options.mk"
HEIMDAL_HDB_DIR= ${VARBASE}/heimdal
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-kcm
CONFIGURE_ARGS+= --enable-pthread-support
CONFIGURE_ARGS+= --includedir=${PREFIX}/include/krb5
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS+= --with-hdbdir=${HEIMDAL_HDB_DIR}
CONFIGURE_ARGS+= --with-openssl=${SSLBASE:Q}
CONFIGURE_ARGS+= --with-sqlite3=${BUILDLINK_PREFIX.sqlite3}
CONFIGURE_ARGS+= --without-x
CONFIGURE_ARGS+= ${ABI:D--with-mips-abi=${ABI}}
CONFIGURE_ENV+= COMPILE_ET=no # build Heimdal's compile_et(1)
# XXX Grand Central Dispatch is broken in 1.4
CONFIGURE_ENV+= ac_cv_funclib_dispatch_async_f=no
.include "../../mk/bdb.buildlink3.mk"
# XXX Don't detect db1 when a newer version is available; otherwise build fails
.if ${BDB_TYPE} != "db1"
CONFIGURE_ENV+= ac_cv_funclib_dbopen=no
.endif
CFLAGS.Darwin+= -DBIND_8_COMPAT
# Newer illumos has extended functions in glob(3C) but it's easier to
# say it doesn't for simpler PLIST.glob handling.
CONFIGURE_ENV.SunOS+= ac_cv_func_glob_working=no
# Though Solaris has a <vis.h> header, it does something very unrelated
# to the BSD <vis.h> header.
CONFIGURE_ENV.SunOS+= ac_cv_header_vis_h=no
.include "../../mk/readline.buildlink3.mk"
.if ${READLINE_TYPE} == "readline"
CONFIGURE_ARGS+= --with-readline=${BUILDLINK_PREFIX.editlinereadline}
.elif ${READLINE_TYPE} == "editline"
CONFIGURE_ARGS+= --with-libedit=${BUILDLINK_PREFIX.editlinereadline}
.endif
PLIST_VARS+= glob vis
.if ${OPSYS} == "SunOS"
PLIST.vis= yes
PLIST.glob= yes
.endif
# Linux does not have include/vis.h and expected include/glob.h.
.if ${OPSYS} == "Linux"
PLIST.vis= yes
PLIST.glob= yes
# Without this I get undefined references to pthread_getspecific
PTHREAD_AUTO_VARS= yes
.endif
PLIST_VARS+= afskauth hcrypto
.if ${OPSYS} == "IRIX"
PLIST.afskauth= yes
.endif
OWN_DIRS_PERMS= ${HEIMDAL_HDB_DIR} ${REAL_ROOT_USER} ${REAL_ROOT_GROUP} 0700
SPECIAL_PERMS+= ${PREFIX}/bin/otp ${SETUID_ROOT_PERMS}
SPECIAL_PERMS= ${PREFIX}/bin/${KRB5_PREFIX}su ${SETUID_ROOT_PERMS}
RCD_SCRIPTS= kadmind kcm kdc kpasswdd
INFO_FILES= yes
TEST_TARGET= check
# remove manpages conficting with OpenSSL keeping only the important ones
pre-configure:
cd ${WRKSRC}/doc/doxyout/hcrypto && \
${GREP} -e /hcrypto_ -e /page_ manpages > manpages.new && \
mv manpages.new manpages
# Avoid 'cat: cannot open ./localefiles: No such file or directory'
pre-build:
${TOUCH} ${WRKSRC}/po/localefiles
.include "../../databases/sqlite3/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
CHECK_BUILTIN.openssl:= yes
.include "../../security/openssl/builtin.mk"
CHECK_BUILTIN.openssl:=no
.if ${MACHINE_PLATFORM:MNetBSD-[1-3]*} != "" || \
(${OPSYS} == "SunOS" && !empty(USE_BUILTIN.openssl:Myes) && \
!empty(BUILTIN_LIB_FOUND.crypto:M[Nn][Oo]))
PLIST.hcrypto= yes
.endif
.if ${OPSYS} == "MirBSD"
.if !empty(USE_BUILTIN.openssl:Myes)
PLIST.hcrypto= yes
.endif
PLIST.vis= yes
# all of the tools need to link against pthread, force it.
PTHREAD_AUTO_VARS= yes
.endif
.if ${OPSYS} == "Minix"
# all of the tools need to link against pthread, force it.
PTHREAD_AUTO_VARS= yes
.endif
.include "../../mk/termcap.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/readline.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

1213
heimdal/PLIST Normal file

File diff suppressed because it is too large Load Diff

2
heimdal/PLIST.OpenBSD Normal file
View File

@ -0,0 +1,2 @@
@comment $NetBSD: PLIST.OpenBSD,v 1.2 2014/09/22 11:55:37 joerg Exp $
lib/libheimedit.la

4
heimdal/TODO Normal file
View File

@ -0,0 +1,4 @@
In NetBSD-HEAD, hcrypto components are installed and the PLIST check fails.
Are glob, vis and afskauth redundant now?
Handle su which comes with Heimdal.
Port remaining patches if applicable.

32
heimdal/buildlink3.mk Normal file
View File

@ -0,0 +1,32 @@
# $NetBSD: buildlink3.mk,v 1.57 2018/12/09 18:52:07 adam Exp $
.include "../../mk/bsd.fast.prefs.mk"
BUILDLINK_TREE+= heimdal
.if !defined(HEIMDAL_BUILDLINK3_MK)
HEIMDAL_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.heimdal+= heimdal>=0.4e
BUILDLINK_ABI_DEPENDS.heimdal+= heimdal>=1.5.3nb19
BUILDLINK_PKGSRCDIR.heimdal?= ../../security/heimdal
BUILDLINK_INCDIRS.heimdal?= include/krb5
pkgbase := heimdal
.include "../../mk/pkg-build-options.mk"
.if !empty(PKG_BUILD_OPTIONS.heimdal:Mldap)
. include "../../databases/openldap-client/buildlink3.mk"
.endif
.include "../../security/openssl/buildlink3.mk"
CHECK_BUILTIN.heimdal:= yes
.include "../../security/heimdal/builtin.mk"
CHECK_BUILTIN.heimdal:= no
.if !empty(USE_BUILTIN.heimdal:M[nN][oO])
.include "../../databases/sqlite3/buildlink3.mk"
.include "../../mk/bdb.buildlink3.mk"
.endif
.endif # HEIMDAL_BUILDLINK3_MK
BUILDLINK_TREE+= -heimdal

136
heimdal/builtin.mk Normal file
View File

@ -0,0 +1,136 @@
# $NetBSD: builtin.mk,v 1.15 2014/02/22 09:50:47 obache Exp $
BUILTIN_PKG:= heimdal
BUILTIN_FIND_HEADERS_VAR:= H_HEIMDAL
BUILTIN_FIND_HEADERS.H_HEIMDAL= krb5/krb5.h krb5.h
BUILTIN_FIND_GREP.H_HEIMDAL= heimdal_version
BUILTIN_FIND_FILES_VAR:= SH_KRB5_CONFIG
BUILTIN_FIND_FILES.SH_KRB5_CONFIG= /usr/bin/krb5-config
BUILTIN_FIND_GREP.SH_KRB5_CONFIG= ^[ ]*--version)
.include "../../mk/buildlink3/bsd.builtin.mk"
###
### Determine if there is a built-in implementation of the package and
### set IS_BUILTIN.<pkg> appropriately ("yes" or "no").
###
.if !defined(IS_BUILTIN.heimdal)
IS_BUILTIN.heimdal= no
. if empty(H_HEIMDAL:M__nonexistent__) && empty(H_HEIMDAL:M${LOCALBASE}/*)
IS_BUILTIN.heimdal= yes
. endif
.endif
MAKEVARS+= IS_BUILTIN.heimdal
###
### If there is a built-in implementation, then set BUILTIN_PKG.<pkg> to
### a package name to represent the built-in package.
###
.if !defined(BUILTIN_PKG.heimdal) && \
!empty(IS_BUILTIN.heimdal:M[yY][eE][sS])
. if empty(SH_KRB5_CONFIG:M__nonexistent__)
BUILTIN_VERSION.heimdal!= ${SH_KRB5_CONFIG} --version | \
${AWK} '{ print $$2; exit }'
. else
#
# heimdal<=0.6.x doesn't have a method of checking files to discover
# the version number of the software. Match up heimdal versions with
# OS versions for an approximate determination of the heimdal version.
#
_BLTN_HEIMDAL_VERSIONS= 0.6.3 0.6.2 0.6.1 0.6 0.5 0.4e 0.3f 0.3e
_BLTN_HEIMDAL_0.6.3= NetBSD-2.* NetBSD-[3-9]*-*
_BLTN_HEIMDAL_0.6.2= # empty
_BLTN_HEIMDAL_0.6.1= NetBSD-1.6[U-Z]-* NetBSD-1.6Z*-*
_BLTN_HEIMDAL_0.6= NetBSD-1.6[U-Z]-* NetBSD-1.6Z*-*
_BLTN_HEIMDAL_0.5= NetBSD-1.6[I-T]-*
_BLTN_HEIMDAL_0.4e= NetBSD-1.6[A-H]-* \
NetBSD-1.6-* NetBSD-1.6_*-* NetBSD-1.6.*-* \
NetBSD-1.5[YZ]-* NetBSD-1.5Z*-*
_BLTN_HEIMDAL_0.3f= NetBSD-1.5X-*
_BLTN_HEIMDAL_0.3e= NetBSD-1.5[UVW]-* \
NetBSD-1.5.*-*
. for _heimdal_version_ in ${_BLTN_HEIMDAL_VERSIONS}
. for _pattern_ in ${_BLTN_HEIMDAL_${_heimdal_version_}}
. if !empty(MACHINE_PLATFORM:M${_pattern_})
BUILTIN_VERSION.heimdal?= ${_heimdal_version_}
. endif
. endfor
. endfor
BUILTIN_VERSION.heimdal?= 0.2t
. endif
BUILTIN_PKG.heimdal= heimdal-${BUILTIN_VERSION.heimdal}
.endif
MAKEVARS+= BUILTIN_PKG.heimdal
###
### Determine whether we should use the built-in implementation if it
### exists, and set USE_BUILTIN.<pkg> appropriate ("yes" or "no").
###
.if !defined(USE_BUILTIN.heimdal)
. if ${PREFER.heimdal} == "pkgsrc"
USE_BUILTIN.heimdal= no
. else
USE_BUILTIN.heimdal= ${IS_BUILTIN.heimdal}
. if !empty(USE_BUILTIN.heimdal:M[yY][eE][sS])
CHECK_BUILTIN.openssl:= yes
. include "../../security/openssl/builtin.mk"
CHECK_BUILTIN.openssl:= no
. if !empty(USE_BUILTIN.openssl:M[Nn][Oo])
USE_BUILTIN.heimdal= no
. endif
. endif
. if defined(BUILTIN_PKG.heimdal) && \
!empty(IS_BUILTIN.heimdal:M[yY][eE][sS])
USE_BUILTIN.heimdal?= yes
. for _dep_ in ${BUILDLINK_API_DEPENDS.heimdal}
. if !empty(USE_BUILTIN.heimdal:M[yY][eE][sS])
USE_BUILTIN.heimdal!= \
if ${PKG_ADMIN} pmatch ${_dep_:Q} ${BUILTIN_PKG.heimdal:Q}; then \
${ECHO} yes; \
else \
${ECHO} no; \
fi
. endif
. endfor
. endif
. endif # PREFER.heimdal
.endif
MAKEVARS+= USE_BUILTIN.heimdal
###
### The section below only applies if we are not including this file
### solely to determine whether a built-in implementation exists.
###
CHECK_BUILTIN.heimdal?= no
.if !empty(CHECK_BUILTIN.heimdal:M[nN][oO])
. if !empty(USE_BUILTIN.heimdal:M[nN][oO])
BUILDLINK_API_DEPENDS.heimdal+= heimdal>=0.6
KRB5_CONFIG?= ${BUILDLINK_PREFIX.heimdal}/bin/krb5-config
CONFIGURE_ENV+= KRB5_CONFIG=${KRB5_CONFIG:Q}
MAKE_ENV+= KRB5_CONFIG=${KRB5_CONFIG:Q}
. endif
. if !empty(USE_BUILTIN.heimdal:M[yY][eE][sS])
. if !empty(SH_KRB5_CONFIG:M__nonexistent__)
BUILDLINK_TARGETS+= fake-krb5-config
fake-krb5-config:
${_PKG_SILENT}${_PKG_DEBUG} \
src=../../security/heimdal/files/krb5-config \
dst=${BUILDLINK_DIR}/bin/krb5-config; \
${SED} -e s/@HEIMDAL_VERSION@/${BUILTIN_VERSION.heimdal}/ \
$${src} >$${dst}; \
${CHMOD} a+x $${dst}
KRB5_CONFIG?= ${BUILDLINK_DIR}/bin/krb5-config
. else
KRB5_CONFIG?= ${SH_KRB5_CONFIG}
. endif
CONFIGURE_ENV+= KRB5_CONFIG=${KRB5_CONFIG:Q}
MAKE_ENV+= KRB5_CONFIG=${KRB5_CONFIG:Q}
. endif
.endif # CHECK_BUILTIN.heimdal

7
heimdal/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.46 2018/11/27 23:36:00 sevan Exp $
SHA1 (heimdal-7.5.0.tar.gz) = 6c891e7ac0c39de10f894a1680a52fb219453e2f
RMD160 (heimdal-7.5.0.tar.gz) = e056d1ce93d783fdc321ad02f373e363bce47d9e
SHA512 (heimdal-7.5.0.tar.gz) = 6d1ad77e795df786680b5e68e2bfefee27bd0207eab507295d7af7053135de9c9ebb517d2c0235bc3a7d50945e18044515f0d76c0899b6b74aa839f1f3e5b131
Size (heimdal-7.5.0.tar.gz) = 10071281 bytes
SHA1 (patch-lib_libedit_configure) = c16317b2a05f1ce22121f4ada8696e3721861a5e

33
heimdal/files/kadmind.sh Normal file
View File

@ -0,0 +1,33 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: kadmind.sh,v 1.2 2005/12/21 04:17:49 jlam Exp $
#
# PROVIDE: kadmind
# REQUIRE: NETWORKING
# BEFORE: SERVERS
. /etc/rc.subr
name="kadmind"
rcvar=$name
command="@PREFIX@/libexec/${name}"
command_args="& sleep 2"
required_files="@PKG_SYSCONFDIR@/krb5.conf"
required_vars="kdc"
# load_rc_config_var() from /etc/rc.subr on the netbsd-3 branch, for
# the benefit of platforms with older versions of /etc/rc.subr.
#
load_rc_config_var()
{
eval $(eval '(
load_rc_config '$1' >/dev/null;
if [ -n "${'$2'}" -o "${'$2'-UNSET}" != "UNSET" ]; then
echo '$2'=\'\''${'$2'}\'\'';
fi
)' )
}
load_rc_config $name
load_rc_config_var kdc kdc
run_rc_command "$1"

18
heimdal/files/kcm.sh Normal file
View File

@ -0,0 +1,18 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: kcm.sh,v 1.1 2005/10/26 15:12:45 jlam Exp $
#
# PROVIDE: kcm
# REQUIRE: NETWORKING
# BEFORE: SERVERS
. /etc/rc.subr
name="kcm"
rcvar=$name
command="@PREFIX@/libexec/${name}"
command_args="--detach"
required_files="@PKG_SYSCONFDIR@/krb5.conf"
load_rc_config $name
run_rc_command "$1"

18
heimdal/files/kdc.sh Normal file
View File

@ -0,0 +1,18 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: kdc.sh,v 1.3 2005/10/26 15:12:45 jlam Exp $
#
# PROVIDE: kdc
# REQUIRE: NETWORKING
# BEFORE: SERVERS
. /etc/rc.subr
name="kdc"
rcvar=$name
command="@PREFIX@/libexec/${name}"
command_args="--detach"
required_files="@PKG_SYSCONFDIR@/krb5.conf"
load_rc_config $name
run_rc_command "$1"

33
heimdal/files/kpasswdd.sh Normal file
View File

@ -0,0 +1,33 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: kpasswdd.sh,v 1.2 2005/12/21 04:17:49 jlam Exp $
#
# PROVIDE: kpasswdd
# REQUIRE: NETWORKING
# BEFORE: SERVERS
. /etc/rc.subr
name="kpasswdd"
rcvar=$name
command="@PREFIX@/libexec/${name}"
command_args="& sleep 2"
required_files="@PKG_SYSCONFDIR@/krb5.conf"
required_vars="kdc"
# load_rc_config_var() from /etc/rc.subr on the netbsd-3 branch, for
# the benefit of platforms with older versions of /etc/rc.subr.
#
load_rc_config_var()
{
eval $(eval '(
load_rc_config '$1' >/dev/null;
if [ -n "${'$2'}" -o "${'$2'-UNSET}" != "UNSET" ]; then
echo '$2'=\'\''${'$2'}\'\'';
fi
)' )
}
load_rc_config $name
load_rc_config_var kdc kdc
run_rc_command "$1"

107
heimdal/files/krb5-config Executable file
View File

@ -0,0 +1,107 @@
#!/bin/sh
# Heimdal: krb5-config.in,v 1.9 2002/09/09 22:29:06 joda Exp
# $NetBSD: krb5-config,v 1.2 2007/06/15 19:03:16 joerg Exp $
do_libs=no
do_cflags=no
do_usage=no
print_prefix=no
print_exec_prefix=no
library=krb5
if test $# -eq 0; then
do_usage=yes
usage_exit=1
fi
for i in $*; do
case $i in
--help)
do_usage=yes
usage_exit=0
;;
--version)
echo "heimdal @HEIMDAL_VERSION@"
exit 0
;;
--prefix=*)
prefix=`echo $i | sed 's/^--prefix=//'`
;;
--prefix)
print_prefix=yes
;;
--exec-prefix=*)
exec_prefix=`echo $i | sed 's/^--exec-prefix=//'`
;;
--exec-prefix)
print_exec_prefix=yes
;;
--libs)
do_libs=yes
;;
--cflags)
do_cflags=yes
;;
krb5)
library=krb5
;;
gssapi)
library=gssapi
;;
kadm-client)
library=kadm-client
;;
kadm-server)
library=kadm-server
;;
*)
echo "unknown option: $i"
exit 1
;;
esac
done
if test "$do_usage" = "yes"; then
echo "usage: $0 [options] [libraries]"
echo "options: [--prefix[=dir]] [--exec-prefix[=dir]] [--libs] [--cflags]"
echo "libraries: krb5 gssapi kadm-client kadm-server"
exit $usage_exit
fi
if test "$prefix" = ""; then
prefix=/usr
fi
if test "$exec_prefix" = ""; then
exec_prefix=/usr
fi
if test "$print_prefix" = "yes"; then
echo $prefix
fi
if test "$print_exec_prefix" = "yes"; then
echo $exec_prefix
fi
if test "$do_libs" = "yes"; then
lib_flags="-L/usr/lib"
case $library in
gssapi)
lib_flags="$lib_flags -lgssapi"
;;
kadm-client)
lib_flags="$lib_flags -lkadm5clnt"
;;
kadm-server)
lib_flags="$lib_flags -lkadm5srv"
;;
esac
lib_flags="$lib_flags -lkrb5 -lasn1 -ldes -lroken"
lib_flags="$lib_flags -lcrypto -lcom_err"
echo $lib_flags
fi
if test "$do_cflags" = "yes"; then
echo "-I/usr/include/gssapi -I/usr/include/krb5"
fi
exit 0

66
heimdal/options.mk Normal file
View File

@ -0,0 +1,66 @@
# $NetBSD: options.mk,v 1.3 2011/07/08 09:49:21 adam Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.heimdal
PKG_SUPPORTED_OPTIONS= inet6 kerberos-prefix-cmds ldap
PKG_SUGGESTED_OPTIONS= inet6
.include "../../mk/bsd.options.mk"
###
### IPv6 support.
###
.if !empty(PKG_OPTIONS:Minet6)
CONFIGURE_ARGS+= --with-ipv6
.else
CONFIGURE_ARGS+= --without-ipv6
.endif
###
### Support using LDAP as a KDC backend.
###
PLIST_VARS+= ldap
.if !empty(PKG_OPTIONS:Mldap)
. include "../../databases/openldap-client/buildlink3.mk"
CONFIGURE_ARGS+= --with-openldap=${BUILDLINK_PREFIX.openldap-client}
PLIST.ldap= yes
INSTALLATION_DIRS+= share/examples/heimdal
post-install: heimdal-ldap-schema
heimdal-ldap-schema:
${INSTALL_DATA} ${WRKSRC}/lib/hdb/hdb.schema \
${DESTDIR}${PREFIX}/share/examples/heimdal
.endif
###
### Rename some of Heimdal's applications so they won't conflict with
### other packages.
###
.if !empty(PKG_OPTIONS:Mkerberos-prefix-cmds)
KRB5_PREFIX= k
HEIMDAL_TRANSFORM= s/^ftp/${KRB5_PREFIX}&/; \
s/^login/${KRB5_PREFIX}&/; \
s/^${KRB5_PREFIX}login.access/login.access/; \
s/^rcp/${KRB5_PREFIX}&/; \
s/^rsh/${KRB5_PREFIX}&/; \
s/^su/${KRB5_PREFIX}&/; \
s/^telnet/${KRB5_PREFIX}&/
.else
KRB5_PREFIX= # empty
HEIMDAL_TRANSFORM= s/^ftp/k&/
.endif
PLIST_SUBST+= KRB5_PREFIX=${KRB5_PREFIX:Q}
CONFIGURE_ARGS+= --program-transform-name=${HEIMDAL_TRANSFORM:Q}
#
# Fix some places in the Heimdal sources that don't point to the correct
# Kerberized binaries when exec'ing programs.
#
SUBST_CLASSES+= heimdal
SUBST_STAGE.heimdal= pre-configure
SUBST_FILES.heimdal= appl/rcp/rcp.c appl/rcp/rcp_locl.h
SUBST_FILES.heimdal+= appl/rsh/rsh_locl.h
SUBST_FILES.heimdal+= appl/telnet/telnetd/telnetd.h
SUBST_SED.heimdal= -e "/RSH_PROGRAM/s,rsh,${KRB5_PREFIX}rsh,g"
SUBST_SED.heimdal+= -e "/PATH_RSH/s,\"/usr/bin/rsh\",BINDIR \"${KRB5_PREFIX}rsh\",g"
SUBST_SED.heimdal+= -e "/PATH_RSH/s,/rsh,/${KRB5_PREFIX}rsh,g"
SUBST_SED.heimdal+= -e "/PATH_LOGIN/s,/login,/${KRB5_PREFIX}login,g"

View File

@ -0,0 +1,159 @@
$NetBSD$
Include termcap in the termcap test
Support Minix
--- lib/libedit/configure.orig 2018-12-26 19:14:51.625069299 +0000
+++ lib/libedit/configure
@@ -5140,7 +5140,7 @@ else
lt_cv_sys_max_cmd_len=8192;
;;
- bitrig* | darwin* | dragonfly* | freebsd* | netbsd* | openbsd*)
+ bitrig* | darwin* | dragonfly* | freebsd* | minix* | netbsd* | openbsd*)
# This has been around since 386BSD, at least. Likely further.
if test -x /sbin/sysctl; then
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
@@ -5609,12 +5609,8 @@ linux* | k*bsd*-gnu | kopensolaris*-gnu
lt_cv_deplibs_check_method=pass_all
;;
-netbsd*)
- if echo __ELF__ | $CC -E - | $GREP __ELF__ > /dev/null; then
- lt_cv_deplibs_check_method='match_pattern /lib[^/]+(\.so\.[0-9]+\.[0-9]+|_pic\.a)$'
- else
- lt_cv_deplibs_check_method='match_pattern /lib[^/]+(\.so|_pic\.a)$'
- fi
+netbsd* | minix*)
+ lt_cv_deplibs_check_method='match_pattern /lib[^/]+(\.so|_pic\.a)$'
;;
newos6*)
@@ -9284,14 +9280,13 @@ _LT_EOF
fi
;;
- netbsd*)
- if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
- archive_cmds='$LD -Bshareable $libobjs $deplibs $linker_flags -o $lib'
- wlarc=
- else
- archive_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags $wl-soname $wl$soname -o $lib'
- archive_expsym_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags $wl-soname $wl$soname $wl-retain-symbols-file $wl$export_symbols -o $lib'
- fi
+ netbsd* | minix*)
+ archive_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
+ archive_expsym_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
+ hardcode_libdir_flag_spec='${wl}-rpath,$libdir'
+ hardcode_direct=yes
+ hardcode_shlibpath_var=no
+ output_verbose_link_cmd=func_echo_all
;;
solaris*)
@@ -9975,15 +9970,13 @@ $as_echo "$lt_cv_irix_exported_symbol" >
esac
;;
- netbsd*)
- if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
- archive_cmds='$LD -Bshareable -o $lib $libobjs $deplibs $linker_flags' # a.out
- else
- archive_cmds='$LD -shared -o $lib $libobjs $deplibs $linker_flags' # ELF
- fi
- hardcode_libdir_flag_spec='-R$libdir'
+ netbsd* | minix*)
+ archive_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
+ archive_expsym_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
+ hardcode_libdir_flag_spec='${wl}-rpath,$libdir'
hardcode_direct=yes
hardcode_shlibpath_var=no
+ output_verbose_link_cmd=func_echo_all
;;
newsos6)
@@ -11090,6 +11083,18 @@ fi
dynamic_linker='GNU/Linux ld.so'
;;
+minix*)
+ version_type=linux
+ need_lib_prefix=no
+ need_version=no
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
+ soname_spec='${libname}${release}${shared_ext}$major'
+ dynamic_linker='Minix ld.elf_so'
+ shlibpath_var=LD_LIBRARY_PATH
+ shlibpath_overrides_runpath=yes
+ hardcode_into_libs=yes
+ ;;
+
netbsd*)
version_type=sunos
need_lib_prefix=no
@@ -12429,7 +12434,50 @@ test -n "$NROFF" || NROFF="/bin/false"
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for tgetent in -ltermcap" >&5
+$as_echo_n "checking for tgetent in -ltermcap... " >&6; }
+if test "${ac_cv_lib_curses_termcap+set}" = set; then :
+ $as_echo_n "(cached) " >&6
+else
+ ac_check_lib_save_LIBS=$LIBS
+LIBS="-ltermcap $LIBS"
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+/* Override any GCC internal prototype to avoid an error.
+ Use char because int might match the return type of a GCC
+ builtin and then its argument prototype would still apply. */
+#ifdef __cplusplus
+extern "C"
+#endif
+char tgetent ();
+int
+main ()
+{
+return tgetent ();
+ ;
+ return 0;
+}
+_ACEOF
+if ac_fn_c_try_link "$LINENO"; then :
+ ac_cv_lib_termcap_tgetent=yes
+else
+ ac_cv_lib_termcap_tgetent=no
+fi
+rm -f core conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+LIBS=$ac_check_lib_save_LIBS
+fi
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_termcap_tgetent" >&5
+$as_echo "$ac_cv_lib_termcap_tgetent" >&6; }
+if test "x$ac_cv_lib_termcap_tgetent" = x""yes; then :
+ cat >>confdefs.h <<_ACEOF
+#define HAVE_LIBTERMCAP 1
+_ACEOF
+
+ LIBS="-ltermcap $LIBS"
+
+else
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for tgetent in -lcurses" >&5
$as_echo_n "checking for tgetent in -lcurses... " >&6; }
if ${ac_cv_lib_curses_tgetent+:} false; then :
@@ -12518,12 +12566,12 @@ _ACEOF
LIBS="-lncurses $LIBS"
else
- as_fn_error $? "libcurses or libncurses are required!" "$LINENO" 5
+ as_fn_error $? "libtermcap, libcurses or libncurses are required!" "$LINENO" 5
fi
fi
-
+fi
# Checks for header files.
ac_header_dirent=no