vte: update to 0.48.3

Has the benefit of being fetchable. Only tested with one
new package.
This commit is contained in:
Maya Rashish 2019-10-20 10:26:39 +03:00
parent d85f149f5e
commit 7a75f06f25
6 changed files with 33 additions and 22 deletions

View File

@ -19,10 +19,7 @@ USE_TOOLS+= gmake intltool msgfmt pkg-config autoreconf autoconf automake gette
USE_LANGUAGES+= c c++
CONFIGURE_ARGS+= --enable-Bsymbolic=auto
# XXX: option
CONFIGURE_ARGS+= --enable-introspection
# XXX: option
CONFIGURE_ARGS+= --enable-python
pre-configure:
${RUN} cd ${WRKSRC} && \
@ -47,5 +44,6 @@ BUILDLINK_API_DEPENDS.fontconfig+= fontconfig>=2.1.93
.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXft/buildlink3.mk"
.include "../../x11/libXt/buildlink3.mk"
.include "../../devel/pcre2/buildlink3.mk"
.include "../../mk/termcap.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -2,7 +2,7 @@
#
# used by x11/py-vte/Makefile
DISTNAME= vte-0.42.1
DISTNAME= vte-0.48.3
MASTER_SITES= ${MASTER_SITE_GITHUB:=GNOME/}
HOMEPAGE= https://www.gnome.org/

View File

@ -7,6 +7,7 @@ include/vte-2.91/vte/vteenums.h
include/vte-2.91/vte/vteglobals.h
include/vte-2.91/vte/vtemacros.h
include/vte-2.91/vte/vtepty.h
include/vte-2.91/vte/vteregex.h
include/vte-2.91/vte/vteterminal.h
include/vte-2.91/vte/vtetypebuiltins.h
include/vte-2.91/vte/vteversion.h

View File

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.10 2015/06/06 15:46:31 krytarowski Exp $
SHA1 (vte-0.42.1.tar.gz) = 1945c4a8339dedb9f741d49867c9e93e71db7293
RMD160 (vte-0.42.1.tar.gz) = 161c08cff04bb120ec081083204c27c4273a2e04
SHA512 (vte-0.42.1.tar.gz) = 122943d184ae5e290013c7c32ab0432461a0c53d460676bab26aa9620fba10ab70db393eeb962d8551335823c60a80b70410e2fc9fcfaa806d092db16c8e5f1e
Size (vte-0.42.1.tar.gz) = 613212 bytes
SHA1 (patch-src_app.vala) = cd8ff7daf6f22c3e3cc9c6535e47782e3e29fd36
SHA1 (vte-0.48.3.tar.gz) = 71bfc3f0f2e6286ddce0f30b2ddd667a5dbe5fc7
RMD160 (vte-0.48.3.tar.gz) = a02a85df3d7a171890fa455568750a737b985467
SHA512 (vte-0.48.3.tar.gz) = 6b837857487e8a8c2dff4d878d1eccc6995e443e42f34e1dfe714956e3f82350fe71d4ee5e3f75340be5e573f4575150f0a6a534c41715b483699c71fade284a
Size (vte-0.48.3.tar.gz) = 662855 bytes
SHA1 (patch-bindings_vala_app.vala) = fcb7c175fac42af26099828c5006ce56e33369e5

View File

@ -0,0 +1,25 @@
$NetBSD$
Backport fix for newer vala
https://gitlab.gnome.org/GNOME/vte/commit/53690d5cee51bdb7c3f7680d3c22b316b1086f2c
--- bindings/vala/app.vala.orig 2017-05-04 09:46:02.000000000 +0000
+++ bindings/vala/app.vala
@@ -491,7 +491,7 @@ class Window : Gtk.ApplicationWindow
switch (pid) {
case -1: /* error */
- printerr("Error forking: %m");
+ printerr("Error forking: %s", strerror(errno));
break;
case 0: /* child */ {
pty.child_setup();
@@ -811,6 +811,8 @@ class App : Gtk.Application
public struct Options
{
+ //FIXME Merge this struct into App class
+ public int dummy;
public static bool audible = false;
public static string? command = null;
private static string? cjk_ambiguous_width_string = null;

View File

@ -1,13 +0,0 @@
$NetBSD$
--- src/app.vala.orig 2015-04-28 21:51:21.000000000 +0000
+++ src/app.vala
@@ -257,7 +257,7 @@ class Window : Gtk.ApplicationWindow
switch (pid) {
case -1: /* error */
- printerr("Error forking: %m");
+ printerr("Error forking: %s", strerror(errno));
break;
case 0: /* child */ {
pty.child_setup();