gr-gsm: Gnuradio blocks and tools for receiving GSM transmissions

This commit is contained in:
Tobias Nygren 2019-02-05 12:35:33 +01:00
parent 13ad3d7e7c
commit 7b69953440
6 changed files with 236 additions and 0 deletions

View File

@ -1174,6 +1174,7 @@ SUBDIR+= gpsdrive
SUBDIR+= gpx2shp
SUBDIR+= gqrx
SUBDIR+= gr-fcdproplus-git
SUBDIR+= gr-gsm
SUBDIR+= gr-osmosdr-git
SUBDIR+= grafX2
SUBDIR+= grandr

1
gr-gsm/DESCR Normal file
View File

@ -0,0 +1 @@
Gnuradio blocks and tools for receiving GSM transmissions.

29
gr-gsm/Makefile Normal file
View File

@ -0,0 +1,29 @@
# $NetBSD$
DISTNAME= gr-gsm-0.42.2
CATEGORIES= ham
MASTER_SITES= ${MASTER_SITE_GITHUB:=ptrkrysik/}
GITHUB_TAG= v${PKGVERSION_NOREV}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/ptrkrysik/gr-gsm/
COMMENT= Gnuradio blocks and tools for receiving GSM transmissions
LICENSE= gnu-gpl-v3
USE_CMAKE= yes
USE_LANGUAGES= c c++
USE_TOOLS+= pkg-config
DEPENDS+= gnuradio-companion-[0-9]*:../../ham/gnuradio-companion
DEPENDS+= gnuradio-qtgui-[0-9]*:../../ham/gnuradio-qtgui
PY_PATCHPLIST= yes
.include "../../devel/boost-libs/buildlink3.mk"
.include "../../ham/gnuradio-core/buildlink3.mk"
.include "../../ham/gnuradio-digital/buildlink3.mk"
.include "../../ham/gnuradio-utils/buildlink3.mk"
.include "../../ham/gr-osmosdr/buildlink3.mk"
.include "../../lang/python/extension.mk"
.include "../../wip/libosmocore/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

183
gr-gsm/PLIST Normal file
View File

@ -0,0 +1,183 @@
@comment $NetBSD$
bin/grgsm_capture
bin/grgsm_channelize
bin/grgsm_decode
bin/grgsm_livemon
bin/grgsm_livemon_headless
bin/grgsm_scanner
bin/grgsm_trx
include/grgsm/api.h
include/grgsm/constants.h
include/grgsm/decoding/control_channels_decoder.h
include/grgsm/decoding/decryption.h
include/grgsm/decoding/grgsm/swig/constants.i
include/grgsm/decoding/grgsm/swig/grgsm_swig.i
include/grgsm/decoding/grgsm/swig/grgsm_swig_doc.i
include/grgsm/decoding/tch_f_decoder.h
include/grgsm/demapping/tch_f_chans_demapper.h
include/grgsm/demapping/universal_ctrl_chans_demapper.h
include/grgsm/flow_control/burst_fnr_filter.h
include/grgsm/flow_control/burst_sdcch_subslot_filter.h
include/grgsm/flow_control/burst_sdcch_subslot_splitter.h
include/grgsm/flow_control/burst_timeslot_filter.h
include/grgsm/flow_control/burst_timeslot_splitter.h
include/grgsm/flow_control/burst_type_filter.h
include/grgsm/flow_control/common.h
include/grgsm/flow_control/dummy_burst_filter.h
include/grgsm/flow_control/uplink_downlink_splitter.h
include/grgsm/gsm_constants.h
include/grgsm/gsmtap.h
include/grgsm/misc_utils/burst_file_sink.h
include/grgsm/misc_utils/burst_file_source.h
include/grgsm/misc_utils/burst_to_fn_time.h
include/grgsm/misc_utils/bursts_printer.h
include/grgsm/misc_utils/collect_system_info.h
include/grgsm/misc_utils/controlled_fractional_resampler_cc.h
include/grgsm/misc_utils/controlled_rotator_cc.h
include/grgsm/misc_utils/extract_assignment_cmd.h
include/grgsm/misc_utils/extract_cmc.h
include/grgsm/misc_utils/extract_immediate_assignment.h
include/grgsm/misc_utils/extract_system_info.h
include/grgsm/misc_utils/fn_time.h
include/grgsm/misc_utils/message_file_sink.h
include/grgsm/misc_utils/message_file_source.h
include/grgsm/misc_utils/message_printer.h
include/grgsm/misc_utils/msg_to_tag.h
include/grgsm/misc_utils/time_spec.h
include/grgsm/misc_utils/tmsi_dumper.h
include/grgsm/plotting.hpp
include/grgsm/qa_utils/burst_sink.h
include/grgsm/qa_utils/burst_source.h
include/grgsm/qa_utils/message_sink.h
include/grgsm/qa_utils/message_source.h
include/grgsm/receiver/clock_offset_control.h
include/grgsm/receiver/cx_channel_hopper.h
include/grgsm/receiver/receiver.h
include/grgsm/transmitter/gen_test_ab.h
include/grgsm/transmitter/preprocess_tx_burst.h
include/grgsm/transmitter/txtime_setter.h
include/grgsm/trx/trx_burst_if.h
lib/cmake/grgsm/gr-gsmConfig.cmake
lib/libgrgsm.so
lib/libgrgsm.so.${PKGVERSION}.
${PYSITELIB}/grgsm/__init__.py
${PYSITELIB}/grgsm/__init__.pyc
${PYSITELIB}/grgsm/__init__.pyo
${PYSITELIB}/grgsm/_grgsm_swig.so
${PYSITELIB}/grgsm/arfcn.py
${PYSITELIB}/grgsm/arfcn.pyc
${PYSITELIB}/grgsm/arfcn.pyo
${PYSITELIB}/grgsm/chirpz.py
${PYSITELIB}/grgsm/chirpz.pyc
${PYSITELIB}/grgsm/chirpz.pyo
${PYSITELIB}/grgsm/clock_offset_corrector_tagged.py
${PYSITELIB}/grgsm/clock_offset_corrector_tagged.pyc
${PYSITELIB}/grgsm/clock_offset_corrector_tagged.pyo
${PYSITELIB}/grgsm/fcch_burst_tagger.py
${PYSITELIB}/grgsm/fcch_burst_tagger.pyc
${PYSITELIB}/grgsm/fcch_burst_tagger.pyo
${PYSITELIB}/grgsm/fcch_detector.py
${PYSITELIB}/grgsm/fcch_detector.pyc
${PYSITELIB}/grgsm/fcch_detector.pyo
${PYSITELIB}/grgsm/fn_time.py
${PYSITELIB}/grgsm/fn_time.pyc
${PYSITELIB}/grgsm/fn_time.pyo
${PYSITELIB}/grgsm/grgsm_swig.py
${PYSITELIB}/grgsm/grgsm_swig.pyc
${PYSITELIB}/grgsm/grgsm_swig.pyo
${PYSITELIB}/grgsm/gsm_bcch_ccch_demapper.py
${PYSITELIB}/grgsm/gsm_bcch_ccch_demapper.pyc
${PYSITELIB}/grgsm/gsm_bcch_ccch_demapper.pyo
${PYSITELIB}/grgsm/gsm_bcch_ccch_sdcch4_demapper.py
${PYSITELIB}/grgsm/gsm_bcch_ccch_sdcch4_demapper.pyc
${PYSITELIB}/grgsm/gsm_bcch_ccch_sdcch4_demapper.pyo
${PYSITELIB}/grgsm/gsm_gmsk_mod.py
${PYSITELIB}/grgsm/gsm_gmsk_mod.pyc
${PYSITELIB}/grgsm/gsm_gmsk_mod.pyo
${PYSITELIB}/grgsm/gsm_input.py
${PYSITELIB}/grgsm/gsm_input.pyc
${PYSITELIB}/grgsm/gsm_input.pyo
${PYSITELIB}/grgsm/gsm_sdcch8_demapper.py
${PYSITELIB}/grgsm/gsm_sdcch8_demapper.pyc
${PYSITELIB}/grgsm/gsm_sdcch8_demapper.pyo
${PYSITELIB}/grgsm/hier_block.py
${PYSITELIB}/grgsm/hier_block.pyc
${PYSITELIB}/grgsm/hier_block.pyo
${PYSITELIB}/grgsm/sch_detector.py
${PYSITELIB}/grgsm/sch_detector.pyc
${PYSITELIB}/grgsm/sch_detector.pyo
${PYSITELIB}/grgsm/trx/__init__.py
${PYSITELIB}/grgsm/trx/__init__.pyc
${PYSITELIB}/grgsm/trx/__init__.pyo
${PYSITELIB}/grgsm/trx/change_sign_of_dict_elements.py
${PYSITELIB}/grgsm/trx/change_sign_of_dict_elements.pyc
${PYSITELIB}/grgsm/trx/change_sign_of_dict_elements.pyo
${PYSITELIB}/grgsm/trx/ctrl_if.py
${PYSITELIB}/grgsm/trx/ctrl_if.pyc
${PYSITELIB}/grgsm/trx/ctrl_if.pyo
${PYSITELIB}/grgsm/trx/ctrl_if_bb.py
${PYSITELIB}/grgsm/trx/ctrl_if_bb.pyc
${PYSITELIB}/grgsm/trx/ctrl_if_bb.pyo
${PYSITELIB}/grgsm/trx/fake_pm.py
${PYSITELIB}/grgsm/trx/fake_pm.pyc
${PYSITELIB}/grgsm/trx/fake_pm.pyo
${PYSITELIB}/grgsm/trx/radio_if.py
${PYSITELIB}/grgsm/trx/radio_if.pyc
${PYSITELIB}/grgsm/trx/radio_if.pyo
${PYSITELIB}/grgsm/trx/radio_if_grc.py
${PYSITELIB}/grgsm/trx/radio_if_grc.pyc
${PYSITELIB}/grgsm/trx/radio_if_grc.pyo
${PYSITELIB}/grgsm/trx/udp_link.py
${PYSITELIB}/grgsm/trx/udp_link.pyc
${PYSITELIB}/grgsm/trx/udp_link.pyo
${PYSITELIB}/grgsm/txtime_bursts_tagger.py
${PYSITELIB}/grgsm/txtime_bursts_tagger.pyc
${PYSITELIB}/grgsm/txtime_bursts_tagger.pyo
share/gnuradio/grc/blocks/gsm_bcch_ccch_demapper.xml
share/gnuradio/grc/blocks/gsm_bcch_ccch_sdcch4_demapper.xml
share/gnuradio/grc/blocks/gsm_block_tree.xml
share/gnuradio/grc/blocks/gsm_burst_file_sink.xml
share/gnuradio/grc/blocks/gsm_burst_file_source.xml
share/gnuradio/grc/blocks/gsm_burst_fnr_filter.xml
share/gnuradio/grc/blocks/gsm_burst_sdcch_subslot_filter.xml
share/gnuradio/grc/blocks/gsm_burst_sdcch_subslot_splitter.xml
share/gnuradio/grc/blocks/gsm_burst_timeslot_filter.xml
share/gnuradio/grc/blocks/gsm_burst_timeslot_splitter.xml
share/gnuradio/grc/blocks/gsm_burst_to_fn_time.xml
share/gnuradio/grc/blocks/gsm_burst_type_filter.xml
share/gnuradio/grc/blocks/gsm_bursts_printer.xml
share/gnuradio/grc/blocks/gsm_clock_offset_control.xml
share/gnuradio/grc/blocks/gsm_clock_offset_corrector_tagged.xml
share/gnuradio/grc/blocks/gsm_collect_system_info.xml
share/gnuradio/grc/blocks/gsm_control_channels_decoder.xml
share/gnuradio/grc/blocks/gsm_controlled_fractional_resampler_cc.xml
share/gnuradio/grc/blocks/gsm_controlled_rotator_cc.xml
share/gnuradio/grc/blocks/gsm_cx_channel_hopper.xml
share/gnuradio/grc/blocks/gsm_decryption.xml
share/gnuradio/grc/blocks/gsm_dummy_burst_filter.xml
share/gnuradio/grc/blocks/gsm_extract_assignment_cmd.xml
share/gnuradio/grc/blocks/gsm_extract_cmc.xml
share/gnuradio/grc/blocks/gsm_extract_immediate_assignment.xml
share/gnuradio/grc/blocks/gsm_extract_system_info.xml
share/gnuradio/grc/blocks/gsm_fcch_burst_tagger.xml
share/gnuradio/grc/blocks/gsm_fcch_detector.xml
share/gnuradio/grc/blocks/gsm_gen_test_ab.xml
share/gnuradio/grc/blocks/gsm_gmsk_mod.xml
share/gnuradio/grc/blocks/gsm_input.xml
share/gnuradio/grc/blocks/gsm_message_file_sink.xml
share/gnuradio/grc/blocks/gsm_message_file_source.xml
share/gnuradio/grc/blocks/gsm_message_printer.xml
share/gnuradio/grc/blocks/gsm_msg_to_tag.xml
share/gnuradio/grc/blocks/gsm_preprocess_tx_burst.xml
share/gnuradio/grc/blocks/gsm_receiver.xml
share/gnuradio/grc/blocks/gsm_receiver_with_uplink.xml
share/gnuradio/grc/blocks/gsm_sch_detector.xml
share/gnuradio/grc/blocks/gsm_sdcch8_demapper.xml
share/gnuradio/grc/blocks/gsm_tch_f_chans_demapper.xml
share/gnuradio/grc/blocks/gsm_tch_f_decoder.xml
share/gnuradio/grc/blocks/gsm_tmsi_dumper.xml
share/gnuradio/grc/blocks/gsm_trx_burst_if.xml
share/gnuradio/grc/blocks/gsm_txtime_bursts_tagger.xml
share/gnuradio/grc/blocks/gsm_txtime_setter.xml
share/gnuradio/grc/blocks/gsm_universal_ctrl_chans_demapper.xml
share/gnuradio/grc/blocks/gsm_uplink_downlink_splitter.xml

7
gr-gsm/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (gr-gsm-0.42.2.tar.gz) = 96ed1632d4b40680902ce4225dcc2daee58a6e02
RMD160 (gr-gsm-0.42.2.tar.gz) = 6cb833293577088f36b54a6cac9e597f621d49b8
SHA512 (gr-gsm-0.42.2.tar.gz) = 20fb7a0fbcd51c5ed05bcb1cbb3e96f6a7797b330158ce2a2f8b243742fc505cb286dd63fe1573c41f6a0229d6e57f0338eb82a9fa1070efc58209a7e505608e
Size (gr-gsm-0.42.2.tar.gz) = 413098 bytes
SHA1 (patch-include_grgsm_endian.h) = 51729dadd466dcfca307cfdfb221ae4c37e5fb2d

View File

@ -0,0 +1,15 @@
$NetBSD$
we have endian.h
--- include/grgsm/endian.h.orig 2018-08-12 18:13:50.000000000 +0000
+++ include/grgsm/endian.h
@@ -13,7 +13,7 @@
#endif
-#if defined(__linux__) || defined(__CYGWIN__)
+#if defined(__linux__) || defined(__CYGWIN__) || defined(__NetBSD__)
# include <endian.h>