Add valgrind v3.14.0.

This commit is contained in:
Brook Milligan 2019-02-17 19:35:10 +05:45
parent badec9ac6a
commit 7d16a790ff
7 changed files with 431 additions and 0 deletions

15
valgrind/DESCR Normal file
View File

@ -0,0 +1,15 @@
Valgrind is an instrumentation framework for building dynamic analysis
tools. There are Valgrind tools that can automatically detect many memory
management and threading bugs, and profile your programs in detail. You
can also use Valgrind to build new tools.
The Valgrind distribution currently includes six production-quality
tools: a memory error detector, two thread error detectors, a cache
and branch-prediction profiler, a call-graph generating cache and
branch-prediction profiler, and a heap profiler. It also includes three
experimental tools: a heap/stack/global array overrun detector, a second
heap profiler that examines how heap blocks are used, and a SimPoint basic
block vector generator. It runs on the following platforms: X86/Linux,
AMD64/Linux, ARM/Linux, PPC32/Linux, PPC64/Linux, S390X/Linux, MIPS/Linux,
ARM/Android (2.3.x and later), X86/Android (4.0 and later), X86/Darwin
and AMD64/Darwin (Mac OS X 10.6 and 10.7, with limited support for 10.8).

44
valgrind/Makefile Normal file
View File

@ -0,0 +1,44 @@
# $NetBSD: Makefile,v 1.25 2017/09/16 19:53:51 alnsn Exp $
#
DISTNAME= valgrind-3.14.0
CATEGORIES= devel
MASTER_SITES= http://valgrind.org/downloads/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://valgrind.org/
COMMENT= Debugging and profiling tools
LICENSE= gnu-gpl-v2
USE_PKGLOCALEDIR= yes
PKGCONFIG_OVERRIDE+= ${WRKSRC}/valgrind.pc.in
GNU_CONFIGURE= yes
ONLY_FOR_PLATFORM= Darwin-*-i386 Darwin-*-x86_64 \
Linux-*-x86_64 \
Linux-*-i386 \
Linux-*-arm* \
SunOS-*-i386 SunOS-*-x86_64
USE_TOOLS+= gmake perl
USE_LANGUAGES= c c++
TEST_TARGET= regtest
.include "../../mk/bsd.prefs.mk"
.if ${MACHINE_ARCH:C/arm.*/arm/} == "arm"
PLIST_SUBST+= VGCONF_ARCH_PRI=arm
.endif
.if ${MACHINE_ARCH} == "i386"
PLIST_SUBST+= VGCONF_ARCH_PRI=x86
.endif
.if ${MACHINE_ARCH} == "x86_64"
PLIST_SUBST+= VGCONF_ARCH_PRI=amd64
#PLIST_SUBST+= VGCONF_ARCH_SEC=x86
CONFIGURE_ARGS+= --enable-only64bit
.endif
.include "../../mk/bsd.pkg.mk"

318
valgrind/PLIST Normal file
View File

@ -0,0 +1,318 @@
@comment $NetBSD$
bin/callgrind_annotate
bin/callgrind_control
bin/cg_annotate
bin/cg_diff
bin/cg_merge
bin/ms_print
bin/valgrind
bin/valgrind-di-server
bin/valgrind-listener
bin/vgdb
include/valgrind/callgrind.h
include/valgrind/config.h
include/valgrind/drd.h
include/valgrind/helgrind.h
include/valgrind/libvex.h
include/valgrind/libvex_basictypes.h
include/valgrind/libvex_emnote.h
include/valgrind/libvex_guest_amd64.h
include/valgrind/libvex_guest_arm.h
include/valgrind/libvex_guest_arm64.h
include/valgrind/libvex_guest_mips32.h
include/valgrind/libvex_guest_mips64.h
include/valgrind/libvex_guest_offsets.h
include/valgrind/libvex_guest_ppc32.h
include/valgrind/libvex_guest_ppc64.h
include/valgrind/libvex_guest_s390x.h
include/valgrind/libvex_guest_x86.h
include/valgrind/libvex_inner.h
include/valgrind/libvex_ir.h
include/valgrind/libvex_s390x_common.h
include/valgrind/libvex_trc_values.h
include/valgrind/memcheck.h
include/valgrind/pub_tool_addrinfo.h
include/valgrind/pub_tool_aspacehl.h
include/valgrind/pub_tool_aspacemgr.h
include/valgrind/pub_tool_basics.h
include/valgrind/pub_tool_basics_asm.h
include/valgrind/pub_tool_clientstate.h
include/valgrind/pub_tool_clreq.h
include/valgrind/pub_tool_debuginfo.h
include/valgrind/pub_tool_deduppoolalloc.h
include/valgrind/pub_tool_errormgr.h
include/valgrind/pub_tool_execontext.h
include/valgrind/pub_tool_gdbserver.h
include/valgrind/pub_tool_guest.h
include/valgrind/pub_tool_hashtable.h
include/valgrind/pub_tool_libcassert.h
include/valgrind/pub_tool_libcbase.h
include/valgrind/pub_tool_libcfile.h
include/valgrind/pub_tool_libcprint.h
include/valgrind/pub_tool_libcproc.h
include/valgrind/pub_tool_libcsetjmp.h
include/valgrind/pub_tool_libcsignal.h
include/valgrind/pub_tool_machine.h
include/valgrind/pub_tool_mallocfree.h
include/valgrind/pub_tool_options.h
include/valgrind/pub_tool_oset.h
include/valgrind/pub_tool_poolalloc.h
include/valgrind/pub_tool_rangemap.h
include/valgrind/pub_tool_redir.h
include/valgrind/pub_tool_replacemalloc.h
include/valgrind/pub_tool_seqmatch.h
include/valgrind/pub_tool_signals.h
include/valgrind/pub_tool_sparsewa.h
include/valgrind/pub_tool_stacktrace.h
include/valgrind/pub_tool_threadstate.h
include/valgrind/pub_tool_tooliface.h
include/valgrind/pub_tool_transtab.h
include/valgrind/pub_tool_vki.h
include/valgrind/pub_tool_vkiscnums.h
include/valgrind/pub_tool_vkiscnums_asm.h
include/valgrind/pub_tool_wordfm.h
include/valgrind/pub_tool_xarray.h
include/valgrind/pub_tool_xtmemory.h
include/valgrind/pub_tool_xtree.h
include/valgrind/valgrind.h
include/valgrind/vki/vki-amd64-linux.h
include/valgrind/vki/vki-arm-linux.h
include/valgrind/vki/vki-arm64-linux.h
include/valgrind/vki/vki-linux-drm.h
include/valgrind/vki/vki-linux.h
include/valgrind/vki/vki-mips32-linux.h
include/valgrind/vki/vki-mips64-linux.h
include/valgrind/vki/vki-posixtypes-amd64-linux.h
include/valgrind/vki/vki-posixtypes-arm-linux.h
include/valgrind/vki/vki-posixtypes-arm64-linux.h
include/valgrind/vki/vki-posixtypes-mips32-linux.h
include/valgrind/vki/vki-posixtypes-mips64-linux.h
include/valgrind/vki/vki-posixtypes-ppc32-linux.h
include/valgrind/vki/vki-posixtypes-ppc64-linux.h
include/valgrind/vki/vki-posixtypes-s390x-linux.h
include/valgrind/vki/vki-posixtypes-x86-linux.h
include/valgrind/vki/vki-ppc32-linux.h
include/valgrind/vki/vki-ppc64-linux.h
include/valgrind/vki/vki-s390x-linux.h
include/valgrind/vki/vki-scnums-amd64-linux.h
include/valgrind/vki/vki-scnums-arm-linux.h
include/valgrind/vki/vki-scnums-arm64-linux.h
include/valgrind/vki/vki-scnums-mips32-linux.h
include/valgrind/vki/vki-scnums-mips64-linux.h
include/valgrind/vki/vki-scnums-ppc32-linux.h
include/valgrind/vki/vki-scnums-ppc64-linux.h
include/valgrind/vki/vki-scnums-s390x-linux.h
include/valgrind/vki/vki-scnums-solaris.h
include/valgrind/vki/vki-scnums-x86-linux.h
include/valgrind/vki/vki-solaris-repcache.h
include/valgrind/vki/vki-solaris.h
include/valgrind/vki/vki-x86-linux.h
include/valgrind/vki/vki-xen-domctl.h
include/valgrind/vki/vki-xen-evtchn.h
include/valgrind/vki/vki-xen-gnttab.h
include/valgrind/vki/vki-xen-hvm.h
include/valgrind/vki/vki-xen-memory.h
include/valgrind/vki/vki-xen-mmuext.h
include/valgrind/vki/vki-xen-physdev.h
include/valgrind/vki/vki-xen-schedop.h
include/valgrind/vki/vki-xen-sysctl.h
include/valgrind/vki/vki-xen-tmem.h
include/valgrind/vki/vki-xen-version.h
include/valgrind/vki/vki-xen-x86.h
include/valgrind/vki/vki-xen-xsm.h
include/valgrind/vki/vki-xen.h
lib/pkgconfig/valgrind.pc
lib/valgrind/32bit-core-valgrind-s1.xml
lib/valgrind/32bit-core-valgrind-s2.xml
lib/valgrind/32bit-core.xml
lib/valgrind/32bit-linux-valgrind-s1.xml
lib/valgrind/32bit-linux-valgrind-s2.xml
lib/valgrind/32bit-linux.xml
lib/valgrind/32bit-sse-valgrind-s1.xml
lib/valgrind/32bit-sse-valgrind-s2.xml
lib/valgrind/32bit-sse.xml
lib/valgrind/64bit-avx-valgrind-s1.xml
lib/valgrind/64bit-avx-valgrind-s2.xml
lib/valgrind/64bit-avx.xml
lib/valgrind/64bit-core-valgrind-s1.xml
lib/valgrind/64bit-core-valgrind-s2.xml
lib/valgrind/64bit-core.xml
lib/valgrind/64bit-linux-valgrind-s1.xml
lib/valgrind/64bit-linux-valgrind-s2.xml
lib/valgrind/64bit-linux.xml
lib/valgrind/64bit-sse-valgrind-s1.xml
lib/valgrind/64bit-sse-valgrind-s2.xml
lib/valgrind/64bit-sse.xml
lib/valgrind/amd64-avx-coresse-valgrind.xml
lib/valgrind/amd64-avx-coresse.xml
lib/valgrind/amd64-avx-linux-valgrind.xml
lib/valgrind/amd64-avx-linux.xml
lib/valgrind/amd64-coresse-valgrind.xml
lib/valgrind/amd64-linux-valgrind.xml
lib/valgrind/arm-core-valgrind-s1.xml
lib/valgrind/arm-core-valgrind-s2.xml
lib/valgrind/arm-core.xml
lib/valgrind/arm-vfpv3-valgrind-s1.xml
lib/valgrind/arm-vfpv3-valgrind-s2.xml
lib/valgrind/arm-vfpv3.xml
lib/valgrind/arm-with-vfpv3-valgrind.xml
lib/valgrind/arm-with-vfpv3.xml
lib/valgrind/cachegrind-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/callgrind-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/default.supp
lib/valgrind/drd-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/drd-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.dSYM/Contents/Resources/DWARF/drd-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/exp-bbv-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/exp-dhat-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/exp-dhat-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.dSYM/Contents/Resources/DWARF/exp-dhat-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/exp-sgcheck-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/exp-sgcheck-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.dSYM/Contents/Resources/DWARF/exp-sgcheck-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/getoff-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/helgrind-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/helgrind-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.dSYM/Contents/Resources/DWARF/helgrind-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/i386-coresse-valgrind.xml
lib/valgrind/i386-linux-valgrind.xml
lib/valgrind/lackey-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/libcoregrind-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.a
lib/valgrind/libreplacemalloc_toolpreload-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.a
lib/valgrind/libvex-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.a
lib/valgrind/libvexmultiarch-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.a
lib/valgrind/massif-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/massif-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.dSYM/Contents/Resources/DWARF/massif-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/memcheck-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/memcheck-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.dSYM/Contents/Resources/DWARF/memcheck-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/mips-cp0-valgrind-s1.xml
lib/valgrind/mips-cp0-valgrind-s2.xml
lib/valgrind/mips-cp0.xml
lib/valgrind/mips-cpu-valgrind-s1.xml
lib/valgrind/mips-cpu-valgrind-s2.xml
lib/valgrind/mips-cpu.xml
lib/valgrind/mips-fpu-valgrind-s1.xml
lib/valgrind/mips-fpu-valgrind-s2.xml
lib/valgrind/mips-fpu.xml
lib/valgrind/mips-linux-valgrind.xml
lib/valgrind/mips-linux.xml
lib/valgrind/mips64-cp0-valgrind-s1.xml
lib/valgrind/mips64-cp0-valgrind-s2.xml
lib/valgrind/mips64-cp0.xml
lib/valgrind/mips64-cpu-valgrind-s1.xml
lib/valgrind/mips64-cpu-valgrind-s2.xml
lib/valgrind/mips64-cpu.xml
lib/valgrind/mips64-fpu-valgrind-s1.xml
lib/valgrind/mips64-fpu-valgrind-s2.xml
lib/valgrind/mips64-fpu.xml
lib/valgrind/mips64-linux-valgrind.xml
lib/valgrind/mips64-linux.xml
lib/valgrind/none-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}
lib/valgrind/power-altivec-valgrind-s1.xml
lib/valgrind/power-altivec-valgrind-s2.xml
lib/valgrind/power-altivec.xml
lib/valgrind/power-core-valgrind-s1.xml
lib/valgrind/power-core-valgrind-s2.xml
lib/valgrind/power-core.xml
lib/valgrind/power-fpu-valgrind-s1.xml
lib/valgrind/power-fpu-valgrind-s2.xml
lib/valgrind/power-fpu.xml
lib/valgrind/power-linux-valgrind-s1.xml
lib/valgrind/power-linux-valgrind-s2.xml
lib/valgrind/power-linux.xml
lib/valgrind/power-vsx-valgrind-s1.xml
lib/valgrind/power-vsx-valgrind-s2.xml
lib/valgrind/power-vsx.xml
lib/valgrind/power64-core-valgrind-s1.xml
lib/valgrind/power64-core-valgrind-s2.xml
lib/valgrind/power64-core.xml
lib/valgrind/power64-core2-valgrind-s1.xml
lib/valgrind/power64-core2-valgrind-s2.xml
lib/valgrind/power64-linux-valgrind-s1.xml
lib/valgrind/power64-linux-valgrind-s2.xml
lib/valgrind/power64-linux.xml
lib/valgrind/powerpc-altivec32l-valgrind.xml
lib/valgrind/powerpc-altivec32l.xml
lib/valgrind/powerpc-altivec64l-valgrind.xml
lib/valgrind/powerpc-altivec64l.xml
lib/valgrind/s390-acr-valgrind-s1.xml
lib/valgrind/s390-acr-valgrind-s2.xml
lib/valgrind/s390-acr.xml
lib/valgrind/s390-fpr-valgrind-s1.xml
lib/valgrind/s390-fpr-valgrind-s2.xml
lib/valgrind/s390-fpr.xml
lib/valgrind/s390x-core64-valgrind-s1.xml
lib/valgrind/s390x-core64-valgrind-s2.xml
lib/valgrind/s390x-core64.xml
lib/valgrind/s390x-generic-valgrind.xml
lib/valgrind/s390x-generic.xml
lib/valgrind/s390x-linux64-valgrind-s1.xml
lib/valgrind/s390x-linux64-valgrind-s2.xml
lib/valgrind/s390x-linux64.xml
lib/valgrind/vgpreload_core-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so
lib/valgrind/vgpreload_core-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so.dSYM/Contents/Resources/DWARF/vgpreload_core-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so
lib/valgrind/vgpreload_drd-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so
lib/valgrind/vgpreload_drd-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so.dSYM/Contents/Resources/DWARF/vgpreload_drd-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so
lib/valgrind/vgpreload_exp-dhat-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so
lib/valgrind/vgpreload_exp-dhat-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so.dSYM/Contents/Resources/DWARF/vgpreload_exp-dhat-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so
lib/valgrind/vgpreload_exp-sgcheck-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so
lib/valgrind/vgpreload_exp-sgcheck-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so.dSYM/Contents/Resources/DWARF/vgpreload_exp-sgcheck-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so
lib/valgrind/vgpreload_helgrind-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so
lib/valgrind/vgpreload_helgrind-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so.dSYM/Contents/Resources/DWARF/vgpreload_helgrind-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so
lib/valgrind/vgpreload_massif-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so
lib/valgrind/vgpreload_massif-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so.dSYM/Contents/Resources/DWARF/vgpreload_massif-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so
lib/valgrind/vgpreload_memcheck-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so
lib/valgrind/vgpreload_memcheck-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so.dSYM/Contents/Resources/DWARF/vgpreload_memcheck-${VGCONF_ARCH_PRI}-${LOWER_OPSYS}.so
man/man1/callgrind_annotate.1
man/man1/callgrind_control.1
man/man1/cg_annotate.1
man/man1/cg_diff.1
man/man1/cg_merge.1
man/man1/ms_print.1
man/man1/valgrind-listener.1
man/man1/valgrind.1
man/man1/vgdb.1
share/doc/valgrind/html/FAQ.html
share/doc/valgrind/html/QuickStart.html
share/doc/valgrind/html/bbv-manual.html
share/doc/valgrind/html/cg-manual.html
share/doc/valgrind/html/cl-format.html
share/doc/valgrind/html/cl-manual.html
share/doc/valgrind/html/design-impl.html
share/doc/valgrind/html/dh-manual.html
share/doc/valgrind/html/dist.authors.html
share/doc/valgrind/html/dist.html
share/doc/valgrind/html/dist.news.html
share/doc/valgrind/html/dist.news.old.html
share/doc/valgrind/html/dist.readme-android.html
share/doc/valgrind/html/dist.readme-android_emulator.html
share/doc/valgrind/html/dist.readme-developers.html
share/doc/valgrind/html/dist.readme-mips.html
share/doc/valgrind/html/dist.readme-missing.html
share/doc/valgrind/html/dist.readme-packagers.html
share/doc/valgrind/html/dist.readme-s390.html
share/doc/valgrind/html/dist.readme-solaris.html
share/doc/valgrind/html/dist.readme.html
share/doc/valgrind/html/drd-manual.html
share/doc/valgrind/html/faq.html
share/doc/valgrind/html/hg-manual.html
share/doc/valgrind/html/images/home.png
share/doc/valgrind/html/images/kcachegrind_xtree.png
share/doc/valgrind/html/images/next.png
share/doc/valgrind/html/images/prev.png
share/doc/valgrind/html/images/up.png
share/doc/valgrind/html/index.html
share/doc/valgrind/html/license.gfdl.html
share/doc/valgrind/html/license.gpl.html
share/doc/valgrind/html/licenses.html
share/doc/valgrind/html/lk-manual.html
share/doc/valgrind/html/manual-core-adv.html
share/doc/valgrind/html/manual-core.html
share/doc/valgrind/html/manual-intro.html
share/doc/valgrind/html/manual-writing-tools.html
share/doc/valgrind/html/manual.html
share/doc/valgrind/html/mc-manual.html
share/doc/valgrind/html/ms-manual.html
share/doc/valgrind/html/nl-manual.html
share/doc/valgrind/html/quick-start.html
share/doc/valgrind/html/sg-manual.html
share/doc/valgrind/html/tech-docs.html
share/doc/valgrind/html/vg_basic.css
share/doc/valgrind/valgrind_manual.pdf
share/doc/valgrind/valgrind_manual.ps

16
valgrind/PLIST.Darwin Normal file
View File

@ -0,0 +1,16 @@
@comment $NetBSD$
include/valgrind/vki/vki-darwin.h
include/valgrind/vki/vki-scnums-darwin.h
lib/valgrind/drd-amd64-darwin.dSYM/Contents/Info.plist
lib/valgrind/exp-dhat-amd64-darwin.dSYM/Contents/Info.plist
lib/valgrind/exp-sgcheck-amd64-darwin.dSYM/Contents/Info.plist
lib/valgrind/helgrind-amd64-darwin.dSYM/Contents/Info.plist
lib/valgrind/massif-amd64-darwin.dSYM/Contents/Info.plist
lib/valgrind/memcheck-amd64-darwin.dSYM/Contents/Info.plist
lib/valgrind/vgpreload_core-amd64-darwin.so.dSYM/Contents/Info.plist
lib/valgrind/vgpreload_drd-amd64-darwin.so.dSYM/Contents/Info.plist
lib/valgrind/vgpreload_exp-dhat-amd64-darwin.so.dSYM/Contents/Info.plist
lib/valgrind/vgpreload_exp-sgcheck-amd64-darwin.so.dSYM/Contents/Info.plist
lib/valgrind/vgpreload_helgrind-amd64-darwin.so.dSYM/Contents/Info.plist
lib/valgrind/vgpreload_massif-amd64-darwin.so.dSYM/Contents/Info.plist
lib/valgrind/vgpreload_memcheck-amd64-darwin.so.dSYM/Contents/Info.plist

8
valgrind/distinfo Normal file
View File

@ -0,0 +1,8 @@
$NetBSD: distinfo,v 1.9 2016/10/25 17:41:02 alnsn Exp $
SHA1 (valgrind-3.14.0.tar.bz2) = 182afd405b92ddb6f52c6729e848eacf4b1daf46
RMD160 (valgrind-3.14.0.tar.bz2) = 562359c6222acd8546eedf6f0b6db964e91bd434
SHA512 (valgrind-3.14.0.tar.bz2) = 68e548c42df31dc2b883a403e0faff7480c49b3054841870f5d2f742141ba199eca5d83c96bbf283115f0633f2bdb0860161d422f98e3ec720ec65760d250f97
Size (valgrind-3.14.0.tar.bz2) = 16602858 bytes
SHA1 (patch-configure) = 7ebc6cbc534bbfc02329ccaf6ed87f364e2db423
SHA1 (patch-configure.ac) = d03da2c8e7ea6de826adf7bdb53e86c061de3524

View File

@ -0,0 +1,15 @@
$NetBSD$
test ... == ... is not portable.
--- configure.orig 2018-10-09 07:29:07.000000000 +0000
+++ configure
@@ -5691,7 +5691,7 @@ if test "x$ac_cv_prog_cc_c99" != xno; th
fi
-if test "$ac_cv_prog_cc_c99" == "no"; then
+if test "$ac_cv_prog_cc_c99" = "no"; then
as_fn_error $? "Valgrind relies on a C compiler supporting C99" "$LINENO" 5
fi

View File

@ -0,0 +1,15 @@
$NetBSD$
test ... == ... is not portable.
--- configure.ac.orig 2018-10-09 07:26:33.000000000 +0000
+++ configure.ac
@@ -115,7 +115,7 @@ rm $tmpfile
# Make sure we can compile in C99 mode.
AC_PROG_CC_C99
-if test "$ac_cv_prog_cc_c99" == "no"; then
+if test "$ac_cv_prog_cc_c99" = "no"; then
AC_MSG_ERROR([Valgrind relies on a C compiler supporting C99])
fi