Add MatrixSSL, an embedded SSL implementation designed for small

footprint applications and devices.
This commit is contained in:
Amitai Schleier 2020-11-19 12:24:32 +01:00
parent 074bf81514
commit 80b31f04b3
7 changed files with 118 additions and 0 deletions

2
matrixssl/DESCR Normal file
View File

@ -0,0 +1,2 @@
MatrixSSL is an embedded SSL implementation designed for small footprint
applications and devices.

40
matrixssl/Makefile Normal file
View File

@ -0,0 +1,40 @@
# $NetBSD$
DISTNAME= Crypt-MatrixSSL3-v${PKGVERSION_NOREV}
PKGNAME= matrixssl-3.9.3
CATEGORIES= security
MASTER_SITES= https://cpan.metacpan.org/authors/id/P/PO/POWERMAN/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/powerman/perl-Crypt-MatrixSSL3
COMMENT= Small embedded SSL implementation
LICENSE= gnu-gpl-v1 OR gnu-gpl-v2 OR gnu-gpl-v3
WRKSRC= ${WRKDIR}/${DISTNAME}/inc/${PKGNAME_NOREV:S/./-/g}-open
USE_TOOLS+= gmake
MAKE_ENV+= MATRIXSSL_ROOT=${WRKSRC:Q}
INSTALLATION_DIRS= include/matrixssl/core include/matrixssl/crypto lib/matrixssl
post-extract:
cd ${WRKDIR}/${DISTNAME}/inc; \
${TAR} -zxf matrixssl-3-9-3-open.tar.gz
do-install:
cd ${WRKSRC}; \
for f in matrixssl/*.h; do \
${INSTALL_DATA} $$f ${DESTDIR}${PREFIX}/include/matrixssl; \
done; \
for f in core/*.h; do \
${INSTALL_DATA} $$f ${DESTDIR}${PREFIX}/include/matrixssl/core; \
done; \
for f in crypto/*.h; do \
${INSTALL_DATA} $$f ${DESTDIR}${PREFIX}/include/matrixssl/crypto; \
done; \
for f in crypto/libcrypt_s.a core/libcore_s.a matrixssl/libssl_s.a; do \
${INSTALL_DATA} $$f ${DESTDIR}${PREFIX}/lib/matrixssl; \
done
.include "../../mk/bsd.pkg.mk"

27
matrixssl/PLIST Normal file
View File

@ -0,0 +1,27 @@
@comment $NetBSD$
include/matrixssl/core/coreApi.h
include/matrixssl/core/coreConfig.h
include/matrixssl/core/list.h
include/matrixssl/core/osdep-types.h
include/matrixssl/core/osdep.h
include/matrixssl/core/psUtil.h
include/matrixssl/core/psbuf.h
include/matrixssl/core/psmalloc.h
include/matrixssl/core/psnet.h
include/matrixssl/crypto/cryptoApi.h
include/matrixssl/crypto/cryptoCheck.h
include/matrixssl/crypto/cryptoConfig.h
include/matrixssl/crypto/cryptoImpl.h
include/matrixssl/crypto/cryptolib.h
include/matrixssl/matrixsslApi.h
include/matrixssl/matrixsslCheck.h
include/matrixssl/matrixsslConfig.h
include/matrixssl/matrixsslImpl.h
include/matrixssl/matrixsslNet.h
include/matrixssl/matrixsslSocket.h
include/matrixssl/matrixssllib.h
include/matrixssl/psExt.h
include/matrixssl/version.h
lib/matrixssl/libcore_s.a
lib/matrixssl/libcrypt_s.a
lib/matrixssl/libssl_s.a

15
matrixssl/buildlink3.mk Normal file
View File

@ -0,0 +1,15 @@
# $NetBSD$
BUILDLINK_TREE+= matrixssl
.if !defined(MATRIXSSL_BUILDLINK3_MK)
MATRIXSSL_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.matrixssl+= matrixssl>=3.9.3
BUILDLINK_PKGSRCDIR.matrixssl?= ../../wip/matrixssl
BUILDLINK_INCDIRS.matrixssl+= include/matrixssl
BUILDLINK_LIBDIRS.matrixssl+= lib/matrixssl
BUILDLINK_DEPMETHOD.matrixssl?= build
.endif # MATRIXSSL_BUILDLINK3_MK
BUILDLINK_TREE+= -matrixssl

8
matrixssl/distinfo Normal file
View File

@ -0,0 +1,8 @@
$NetBSD$
SHA1 (Crypt-MatrixSSL3-v3.9.3.tar.gz) = 6ee3a8dfb966560728f31de72bf3d7c2833b464c
RMD160 (Crypt-MatrixSSL3-v3.9.3.tar.gz) = e8c7a2882d6f5f3d645e80901ad73f9870b88605
SHA512 (Crypt-MatrixSSL3-v3.9.3.tar.gz) = 9a61e63f3f6666c473520deb9d9980561483e4b4461bac8eb627853085235eba1dd7f332e5b7d94b39bdbdc0dbbc11b93a7a782806ca15f568509c14c9b7d0b4
Size (Crypt-MatrixSSL3-v3.9.3.tar.gz) = 4865841 bytes
SHA1 (patch-common.mk) = f60a7be562de1076e8d5458c0fbc501b42e99b9a
SHA1 (patch-core_osdep-types.h) = 201039c3062e80d8a38ad425b9235da3d05a3084

View File

@ -0,0 +1,15 @@
$NetBSD$
Let pkgsrc tell us where macOS system headers are.
--- common.mk.orig 2017-06-28 06:34:11.000000000 +0000
+++ common.mk
@@ -309,7 +309,7 @@ endif
# OS X Target
ifneq (,$(findstring -apple,$(CCARCH)))
OSDEP:=POSIX
- CFLAGS+=-isystem -I/usr/include
+ #CFLAGS+=-isystem -I/usr/include
endif
# Bare Metal / RTOS Target

View File

@ -0,0 +1,11 @@
$NetBSD$
Get size_t on at least macOS.
--- core/osdep-types.h.orig 2017-06-28 06:34:11.000000000 +0000
+++ core/osdep-types.h
@@ -1,3 +1,4 @@
+#include <sys/types.h>
/**
* @file osdep-types.h
* @version 950bba4 (HEAD -> master)