dillo-devel: Update patches

Move OpenSSL detection patch to configure.ac.
This commit is contained in:
Michael Baeuerle 2020-10-14 15:46:07 +02:00
parent e30899c903
commit 8119cf7c18
3 changed files with 11 additions and 22 deletions

View File

@ -4,6 +4,5 @@ SHA1 (dillo-3.0.5.tar.bz2) = 1f6646f03e3c99f03a4e4abeeb5110bf7f7b3e6a
RMD160 (dillo-3.0.5.tar.bz2) = 404d7b1a0e60526a53a02d4d49ed5b747f4e43fb
SHA512 (dillo-3.0.5.tar.bz2) = d0e86f57e50da762debf592b6deb94de5ee58f84e0cae1159890262540a463aea8143d2b99c634021c1f273f91c2fe0918f30d72c3eaf91fdb541e741469b155
Size (dillo-3.0.5.tar.bz2) = 734472 bytes
SHA1 (patch-configure) = 18dc67f0fe302ee030cb7be2a5fa5ef5976fcece
SHA1 (patch-configure.ac) = 1a3fdec27de5d8b49bbd2fb6159811b71553ecfb
SHA1 (patch-configure.ac) = 6c37d8aa1dbd1f6499cfa17dd57c487672e4abdf
SHA1 (patch-dpi_https.c) = 1f95a8dfdc44a9ad6aa666cb880198708c6a5f1d

View File

@ -1,20 +0,0 @@
$NetBSD: patch-configure,v 1.1 2018/03/24 15:40:07 ryoon Exp $
* Detect OpenSSL 1.1.0
--- configure.orig 2015-06-30 14:07:22.000000000 +0000
+++ configure
@@ -6018,11 +6018,11 @@ cat confdefs.h - <<_ACEOF >conftest.$ac_
#ifdef __cplusplus
extern "C"
#endif
-char SSL_library_init ();
+void OPENSSL_config ();
int
main ()
{
-return SSL_library_init ();
+OPENSSL_config ();
;
return 0;
}

View File

@ -1,6 +1,7 @@
$NetBSD$
Use FLTK 1.4 for glyph substitution on X11 platform.
Modify detection for OpenSSL 1.1.
--- configure.ac.orig 2015-06-30 14:07:06.000000000 +0000
+++ configure.ac
@ -23,3 +24,12 @@ Use FLTK 1.4 for glyph substitution on X11 platform.
LIBFLTK_CXXFLAGS=`$FLTK_CONFIG --cxxflags`
LIBFLTK_CFLAGS=`$FLTK_CONFIG --cflags`
LIBFLTK_LIBS=`$FLTK_CONFIG --ldflags`;;
@@ -286,7 +286,7 @@ if test "x$enable_ssl" = "xyes"; then
if test "x$ssl_ok" = "xyes"; then
old_libs="$LIBS"
- AC_CHECK_LIB(ssl, SSL_library_init, ssl_ok=yes, ssl_ok=no, -lcrypto)
+ AC_CHECK_LIB(ssl, OPENSSL_config, ssl_ok=yes, ssl_ok=no, -lcrypto)
LIBS="$old_libs"
fi