git-spindle: Import git-spindle-3.4.2 as wip/git-spindle

Many central git hosting services, such as BitBucket, GitHub and GitLab,
provide an API to perform actions such as creating repositories and
filing pull requests.

git-spindle is a collection of git subcommands to make using these services
easier.
This commit is contained in:
Leonardo Taccari 2017-12-31 23:26:57 +01:00
parent e4696d2315
commit 8245074e11
6 changed files with 92 additions and 0 deletions

View File

@ -956,6 +956,7 @@ SUBDIR+= gimp-dds
SUBDIR+= gin
SUBDIR+= git-docs-html
SUBDIR+= git-modes-git
SUBDIR+= git-spindle
SUBDIR+= gitg
SUBDIR+= gitlab
SUBDIR+= gitless

6
git-spindle/DESCR Normal file
View File

@ -0,0 +1,6 @@
Many central git hosting services, such as BitBucket, GitHub and GitLab,
provide an API to perform actions such as creating repositories and
filing pull requests.
git-spindle is a collection of git subcommands to make using these services
easier.

20
git-spindle/Makefile Normal file
View File

@ -0,0 +1,20 @@
# $NetBSD$
DISTNAME= git-spindle-3.4.2
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_PYPI:=g/git-spindle/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://seveas.github.io/git-spindle
COMMENT= Command-line interface to GitHub and other central git services
LICENSE= gnu-gpl-v3
DEPENDS+= ${PYPKGPREFIX}-docopt>=0.5.0:../../devel/py-docopt
DEPENDS+= ${PYPKGPREFIX}-github3.py>=0.9.0:../../wip/py-github3.py
DEPENDS+= ${PYPKGPREFIX}-six-[0-9]*:../../lang/py-six
DEPENDS+= ${PYPKGPREFIX}-whelk>=2.6:../../wip/py-whelk
USE_LANGUAGES= # none
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

38
git-spindle/PLIST Normal file
View File

@ -0,0 +1,38 @@
@comment $NetBSD$
bin/git-bb
bin/git-bucket
bin/git-hub
bin/git-lab
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/entry_points.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/gitspindle/__init__.py
${PYSITELIB}/gitspindle/__init__.pyc
${PYSITELIB}/gitspindle/__init__.pyo
${PYSITELIB}/gitspindle/ansi.py
${PYSITELIB}/gitspindle/ansi.pyc
${PYSITELIB}/gitspindle/ansi.pyo
${PYSITELIB}/gitspindle/bbapi.py
${PYSITELIB}/gitspindle/bbapi.pyc
${PYSITELIB}/gitspindle/bbapi.pyo
${PYSITELIB}/gitspindle/bitbucket.py
${PYSITELIB}/gitspindle/bitbucket.pyc
${PYSITELIB}/gitspindle/bitbucket.pyo
${PYSITELIB}/gitspindle/github.py
${PYSITELIB}/gitspindle/github.pyc
${PYSITELIB}/gitspindle/github.pyo
${PYSITELIB}/gitspindle/gitlab.py
${PYSITELIB}/gitspindle/gitlab.pyc
${PYSITELIB}/gitspindle/gitlab.pyo
${PYSITELIB}/gitspindle/glapi.py
${PYSITELIB}/gitspindle/glapi.pyc
${PYSITELIB}/gitspindle/glapi.pyo
${PYSITELIB}/gitspindle/monkey.py
${PYSITELIB}/gitspindle/monkey.pyc
${PYSITELIB}/gitspindle/monkey.pyo
${PYSITELIB}/gitspindle/public_suffix.py
${PYSITELIB}/gitspindle/public_suffix.pyc
${PYSITELIB}/gitspindle/public_suffix.pyo

7
git-spindle/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (git-spindle-3.4.2.tar.gz) = 5f9748aa3e527c9ea1685f5289f3c20b6f979159
RMD160 (git-spindle-3.4.2.tar.gz) = 5927c465bf38faed023a38395e37969d049990c4
SHA512 (git-spindle-3.4.2.tar.gz) = bff36588dd68bde7fbed42a34f1e383061b63cd36bb08aa6384ed624df1fdda3b7c309bfd13017f5e3dac0267e582d2ad3f879a08daa9349f770df0ccff7d9bc
Size (git-spindle-3.4.2.tar.gz) = 1870475 bytes
SHA1 (patch-lib_gitspindle_github.py) = 5f17e46025241e31c3991204f00a8e26e9ae3df7

View File

@ -0,0 +1,20 @@
$NetBSD$
Avoid a:
TypeError: user() takes exactly 2 arguments (1 given)
Both github3.GitHub.user() and github3.GitHubEnterprise.user() functions need
the `username' argument.
--- lib/gitspindle/github.py.orig 2017-12-21 19:05:09.000000000 +0000
+++ lib/gitspindle/github.py
@@ -84,7 +84,7 @@ class GitHub(GitSpindle):
err("No user or token specified")
self.gh.login(username=user, token=token)
try:
- self.me = self.gh.user()
+ self.me = self.gh.user(user)
self.my_login = self.me.login
except github3.GitHubError:
# Token obsolete