coccigrep: Update to 1.20

Changes:
1.20
----
Some light fixes on the documentation and a cleaner setup.py so
the project looks decent on Pypi.

1.19
----
Address a issue with pygments installation on Python 2 and fix parallel
execution.

1.18
----
This release fixes #19 (add support for nested types) and improve
matching capabilities. Issue was linked to absolute include (like
relative include (include "toto.h").

1.17
----
 - Fix a python3 comptability issue
 - Add grep color mode
 - Fix multiple matches on one line
This commit is contained in:
Leonardo Taccari 2020-07-08 02:35:20 +02:00
parent 87627229ac
commit 82febd6bb5
4 changed files with 25 additions and 8 deletions

View File

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.16 2020/01/26 17:32:13 rillig Exp $
DISTNAME= coccigrep-1.16
PKGREVISION= 1
DISTNAME= coccigrep-1.20
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GITHUB:=regit/}
GITHUB_TAG= v${PKGVERSION_NOREV}
@ -11,7 +10,8 @@ HOMEPAGE= https://home.regit.org/software/coccigrep/
COMMENT= Semantic grep for the C language
LICENSE= gnu-gpl-v3
DEPENDS= coccinelle-[0-9]*:../../wip/coccinelle
DEPENDS+= ${PYPKGPREFIX}-pygments-[0-9]*:../../textproc/py-pygments
DEPENDS+= coccinelle-[0-9]*:../../wip/coccinelle
USE_LANGUAGES= # none

View File

@ -1,8 +1,9 @@
@comment $NetBSD: PLIST,v 1.2 2015/01/16 11:44:07 wiz Exp $
@comment $NetBSD$
bin/coccigrep
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/coccigrep/__init__.py
${PYSITELIB}/coccigrep/__init__.pyc

View File

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.6 2017/05/05 11:04:15 leot Exp $
SHA1 (coccigrep-1.16.tar.gz) = 4232bd9fec64282f96784bb2f26173b076e19cef
RMD160 (coccigrep-1.16.tar.gz) = ab9d0093860ed509be22d9fa1faba1a53cd6d5b2
SHA512 (coccigrep-1.16.tar.gz) = 113c308fd05af6ec8765b719ad4eef9d6c39e123c011aedcd0d3f10782b06f3b94e1c8b5e0c609270441d60ef295ab721a40145cc2fe3ebc11afed348f39b269
Size (coccigrep-1.16.tar.gz) = 32622 bytes
SHA1 (coccigrep-1.20.tar.gz) = 49216e5a4aeca59f4864f92fd2937ca068760d81
RMD160 (coccigrep-1.20.tar.gz) = 01b955b84ebb8b284e227c57767ddea8e8f985c8
SHA512 (coccigrep-1.20.tar.gz) = 35d6a43b515c261ba025b876a72566581f892624eb9f47cde4121f16b2922ead8cd94e2c0ea6e00e4c64a3fe0cdcc4aeadc4c49900a8de8cfc0b589208ecae9c
Size (coccigrep-1.20.tar.gz) = 33027 bytes
SHA1 (patch-setup.py) = 0353c852cd438fa275c4dca25514e8dd23789362

View File

@ -0,0 +1,15 @@
$NetBSD$
`encoding' argument is only available in Python 3.
--- setup.py.orig 2020-05-05 07:56:05.000000000 +0000
+++ setup.py
@@ -11,7 +11,7 @@ else:
pygments_deps = 'pygments<2.6.0'
here = path.abspath(path.dirname(__file__))
-with open(path.join(here, 'README.rst'), encoding='utf-8') as f:
+with open(path.join(here, 'README.rst'), **({'encoding': 'UTF-8'} if sys.version_info.major>=3 else {})) as f:
long_description = f.read()
setup(name='coccigrep',
version=COCCIGREP_VERSION,