wip/cfiles: import cfiles-1.3

Ncurses file manager written in C with vim like keybindings
This commit is contained in:
ng0 2019-02-21 02:59:56 +00:00
parent 6461146d88
commit 8362acc832
6 changed files with 71 additions and 0 deletions

View File

@ -358,6 +358,7 @@ SUBDIR+= cdpr
SUBDIR+= cedet
SUBDIR+= centrifuge
SUBDIR+= cereal
SUBDIR+= cfiles
SUBDIR+= cgal
SUBDIR+= cglib
SUBDIR+= cgnslib

1
cfiles/DESCR Normal file
View File

@ -0,0 +1 @@
Ncurses file manager written in C with vim like keybindings

45
cfiles/Makefile Normal file
View File

@ -0,0 +1,45 @@
# $NetBSD$
GITHUB_PROJECT= cfiles
DISTNAME= v1.3
PKGNAME= ${GITHUB_PROJECT}-${DISTNAME}
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_GITHUB:=mananapr/}
DIST_SUBDIR= ${GITHUB_PROJECT}
MAINTAINER= ng0@n0.is
HOMEPAGE= https://github.com/mananapr/cfiles/
COMMENT= Ncurses file manager written in C with vim like keybindings
LICENSE= mit
DEPENDS= fzf-[0-9]*:../../sysutils/fzf
USE_LANGUAGES= c
WRKSRC= ${WRKDIR}/cfiles-1.3
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1
SUBST_CLASSES+= gcc
SUBST_STAGE.gcc= pre-configure
SUBST_FILES.gcc+= Makefile
SUBST_SED.gcc+= -e 's|CC = gcc|CC = cc|g'
SUBST_CLASSES+= ncurses
SUBST_STAGE.ncurses= pre-configure
SUBST_MESSAGE.ncurses= Link with the proper curses type
SUBST_FILES.ncurses= Makefile
SUBST_SED.ncurses= -e 's|LIBS = -lncursesw|LIBS = -l${BUILDLINK_LIBNAME.curses}|g'
SUBST_CLASSES+= install
SUBST_STAGE.install= pre-configure
SUBST_FILES.install= Makefile
SUBST_SED.install+= -e 's|DEST = /usr/local|DEST = ${DESTDIR}${PREFIX}|g'
SUBST_SED.install+= -e 's|cp -v|${INSTALL_PROGRAM}|g'
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cfiles ${DESTDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/cfiles.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
.include "../../mk/curses.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3
cfiles/PLIST Normal file
View File

@ -0,0 +1,3 @@
@comment $NetBSD$
bin/cfiles
man/man1/cfiles.1

7
cfiles/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (cfiles/v1.3.tar.gz) = d961707ed2a684d850301afcfe6bcb70cc052e25
RMD160 (cfiles/v1.3.tar.gz) = 91b07847eba9e74f37f66a38595474cda8e89167
SHA512 (cfiles/v1.3.tar.gz) = 0f36f7dca89bd71465e6d25569911fb6322bc139f132a559fda0c31b96caf3f2854d7a071bc8e5d8c0535c72cadc748f9775c4ca5d19f86921a43fc9a3f1136c
Size (cfiles/v1.3.tar.gz) = 277136 bytes
SHA1 (patch-aa) = 5e5b838261ffdd04c5ac0b4bf9486646b553396b

14
cfiles/patches/patch-aa Normal file
View File

@ -0,0 +1,14 @@
$NetBSD$
* include <signal.h>
--- cf.c.orig
+++ cf.c
@@ -15,6 +15,7 @@
#include <dirent.h>
#include <curses.h>
#include <unistd.h>
+#include <signal.h>
#include <stdlib.h>
#include <string.h>
#include <strings.h>