nudoku: remove, imported in pkgsrc as games/nudoku.

This commit is contained in:
Frederic Cambus 2020-03-16 14:00:55 +01:00
parent e1a89b6358
commit 86b90ea0fa
No known key found for this signature in database
GPG Key ID: B0C0843E8831F5A9
6 changed files with 0 additions and 80 deletions

View File

@ -2409,7 +2409,6 @@ SUBDIR+= nspr-hg
SUBDIR+= nss-hg
SUBDIR+= nss-pam-ldapd
SUBDIR+= ntimed-git
SUBDIR+= nudoku
SUBDIR+= nuget-git
SUBDIR+= nullpop
SUBDIR+= num-utils

View File

@ -1,2 +0,0 @@
nudoku is a ncurses based sudoku game. Perfect to relax a little or
just waste some time when you are on the console.

View File

@ -1,28 +0,0 @@
# $NetBSD$
DISTNAME= nudoku-2.0.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GITHUB:=jubalh/}
GITHUB_RELEASE= ${PKGVERSION_NOREV}
MAINTAINER= fcambus@NetBSD.org
HOMEPAGE= https://jubalh.github.io/nudoku/
COMMENT= Ncurses based sudoku game
LICENSE= gnu-gpl-v3
# Fix gettext includes
SUBST_CLASSES+= includes
SUBST_STAGE.includes= post-configure
SUBST_MESSAGE.includes= Fix gettext includes
SUBST_FILES.includes= src/main.c
SUBST_FILES.includes+= src/sudoku.c
SUBST_SED.includes+= -e 's,"gettext.h",<libintl.h>,'
GNU_CONFIGURE= yes
USE_PKGLOCALEDIR= yes
FAKE_NCURSES= yes
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../mk/curses.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,7 +0,0 @@
@comment $NetBSD$
bin/nudoku
man/man6/nudoku.6
share/locale/de/LC_MESSAGES/nudoku.mo
share/locale/es/LC_MESSAGES/nudoku.mo
share/locale/fr/LC_MESSAGES/nudoku.mo
share/locale/ru/LC_MESSAGES/nudoku.mo

View File

@ -1,7 +0,0 @@
$NetBSD$
SHA1 (nudoku-2.0.0.tar.gz) = 4eb056fa5d58551d7b57a2698428ddfcc521a9c5
RMD160 (nudoku-2.0.0.tar.gz) = ebe12ecf0a2f51a322d512e312e969c44cace8d4
SHA512 (nudoku-2.0.0.tar.gz) = acf0a5714fc767bb580c97d5ceb586db5390ce7a1428e56c1e7413af653cd784939dc5ae3681c4ad19fde0a3ee5e941f1a4466bc35eac4bdf802f0b9ba6b025f
Size (nudoku-2.0.0.tar.gz) = 203292 bytes
SHA1 (patch-src_main.c) = 3e8d32d3830c839727fda4bb74a4c6346553efa9

View File

@ -1,35 +0,0 @@
$NetBSD$
- Add missing <locale.h> header, for setlocale.
- Use wgetch(grid) instead of getch(), otherwise wmove() doesn't
move the cursor in the grid window.
--- src/main.c.orig 2019-07-30 09:50:49.000000000 +0000
+++ src/main.c
@@ -19,7 +19,8 @@ along with this program. If not, see <ht
*/
/* INCLUDES */
-#include "gettext.h" /* gettext */
+#include <libintl.h> /* gettext */
+#include <locale.h> /* setlocale */
#include <stdlib.h> /* rand, srand */
#include <unistd.h> /* getopt */
#include <ncurses.h> /* ncurses */
@@ -294,6 +295,7 @@ static void init_windows(void)
status = newwin(STATUS_LINES, STATUS_COLS, STATUS_Y, STATUS_X);
grid = newwin(GRID_LINES, GRID_COLS, GRID_Y, GRID_X);
+ keypad(grid, true);
_draw_grid();
infobox = newwin(INFO_LINES, INFO_COLS, INFO_Y, INFO_X);
@@ -497,7 +499,7 @@ int main(int argc, char *argv[])
#endif // DEBUG
refresh();
wrefresh(grid);
- key = getch();
+ key = wgetch(grid);
// clear status window
werase(status);
switch(key)