wine32: Import Wine-4.4 (i386) as wip/wine32

This commit is contained in:
Naveen Narayanan 2019-06-11 07:59:59 +02:00
parent d715cafc97
commit 87b90e22db
7 changed files with 3153 additions and 0 deletions

4
wine32/DESCR Normal file
View File

@ -0,0 +1,4 @@
Wine is a program which facilitates running Microsoft Windows Programs
on Unix. It acts as a compatibility layer by translating Windows API
calls into POSIX calls on the fly; thereby allowing you to run Windows
Applications on your UNIX desktop.

11
wine32/MESSAGE Normal file
View File

@ -0,0 +1,11 @@
===========================================================================
$NetBSD$
If you are experiencing crashes, it may be due to a security measure
blocking the mapping of the NULL page.
You can disable this (at a security cost) with the following commands:
NetBSD:
# sysctl -w vm.user_va0_disable=0
===========================================================================

35
wine32/Makefile Normal file
View File

@ -0,0 +1,35 @@
# $NetBSD$
DISTNAME= wine-4.4
CATEGORIES= emulators
MASTER_SITES= https://dl.winehq.org/wine/source/4.x/
EXTRACT_SUFX= .tar.xz
MAINTAINER= zerous@nocebo.space
HOMEPAGE= http://www.winehq.org/
COMMENT= Compatibility layer for running Microsoft Windows Applications
LICENSE= gnu-lgpl-v2.1
ONLY_FOR_PLATFORM+= *-*-i386
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-tests
USE_LANGUAGES= c c++
USE_TOOLS+= bison flex gmake mktemp msgfmt autoconf perl
PKG_DESTDIR_SUPPORT= user-destdir
REPLACE_PERL+= tools/winemaker/winemaker tools/winedump/function_grep.pl
NOT_PAX_MPROTECT_SAFE+= bin/wine64
.include "../../devel/ncurses/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../graphics/giflib/buildlink3.mk"
.include "../../graphics/lcms2/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk"
.include "../../security/gnutls/buildlink3.mk"
.include "../../security/mit-krb5/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../textproc/libxslt/buildlink3.mk"
.include "../../mk/jpeg.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3055
wine32/PLIST Normal file

File diff suppressed because it is too large Load Diff

8
wine32/distinfo Normal file
View File

@ -0,0 +1,8 @@
$NetBSD$
SHA1 (wine-4.4.tar.xz) = c08501490e7f819aa4704ad8c3f820997fe64391
RMD160 (wine-4.4.tar.xz) = 83721cce68156958a42efe2885134cb9f82fa5fd
SHA512 (wine-4.4.tar.xz) = 6678c9b0e086bdc9fab9f9fd2517226352b49f846bbae7be6000bb60db2f302aad49622192077b45880d45ad33ba4d82bfe3403fb82a1e65159f1352b40933de
Size (wine-4.4.tar.xz) = 21805668 bytes
SHA1 (patch-dlls_ntdll_thread.c) = 8a13e956e6622cc215fbe6e9943a704b3a926168
SHA1 (patch-dlls_wininet_http.c) = 9e539ed70a5bf010e50c7beb1c3b3c877ed5e5d8

View File

@ -0,0 +1,16 @@
$NetBSD$
Fix Unhandled page fault on write access owing to pthread_attr_setstack(3)
setting guard on NetBSD 8.0 and newer. This patch has been submitted to Wine
and can be removed to once upstreamed.
--- dlls/ntdll/thread.c.orig 2019-03-15 20:18:31.000000000 +0000
+++ dlls/ntdll/thread.c
@@ -526,6 +526,7 @@ NTSTATUS WINAPI RtlCreateUserThread( HAN
pthread_attr_init( &attr );
pthread_attr_setstack( &attr, teb->DeallocationStack,
(char *)teb->Tib.StackBase + extra_stack - (char *)teb->DeallocationStack );
+ pthread_attr_setguardsize(&attr, 0);
pthread_attr_setscope( &attr, PTHREAD_SCOPE_SYSTEM ); /* force creating a kernel thread */
interlocked_xchg_add( &nb_threads, 1 );
if (pthread_create( &pthread_id, &attr, (void * (*)(void *))start_thread, info ))

View File

@ -0,0 +1,24 @@
$NetBSD$
Fix headers
--- dlls/wininet/http.c.orig 2019-03-15 20:18:31.000000000 +0000
+++ dlls/wininet/http.c
@@ -35,14 +35,14 @@
# include <zlib.h>
#endif
-#include "winsock2.h"
-#include "ws2ipdef.h"
-
#include <stdarg.h>
#include <stdio.h>
#include <time.h>
#include <assert.h>
+#include "winsock2.h"
+#include "ws2ipdef.h"
+
#include "windef.h"
#include "winbase.h"
#include "wininet.h"