lapack,lapacke,blas: bump to LAPACK 3.9.0

The source now comes via github archive URL.
This commit is contained in:
Dr. Thomas Orgis 2020-01-03 21:21:38 +01:00
parent 1701674045
commit 888c6f5c00
7 changed files with 42 additions and 30 deletions

View File

@ -7,7 +7,7 @@
# until everyone uses mk/blas.buildlink3.mk (and people removed
# math/blas from their pkgsrc-related scripts).
PKGNAME= blas-3.8.0
PKGNAME= blas-3.9.0
PKGREVISION= 1
CATEGORIES= math

View File

@ -7,11 +7,11 @@
# You set LAPACK_PART (lowercase) and LAPACK_PART_CMAKE_ARGS to choose
# the library to install.
PORTVERSION= 3.8.0
PORTVERSION= 3.9.0
DISTNAME= lapack-${PORTVERSION}
PKGNAME= ${LAPACK_PART}-${PORTVERSION}
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_NETLIB:=lapack/}
MASTER_SITES= -https://github.com/Reference-LAPACK/lapack/archive/v${PORTVERSION}.tar.gz
HOMEPAGE= http://www.netlib.org/lapack/
LICENSE= modified-bsd

View File

@ -1,14 +1,14 @@
$NetBSD: distinfo,v 1.21 2017/09/11 20:56:28 wiz Exp $
SHA1 (lapack-3.8.0.tar.gz) = 55ac9d6be510883c5442c8aca967722cdf58fb29
RMD160 (lapack-3.8.0.tar.gz) = ff306181c4c125e7594c57c1eeece8b0aa8f8523
SHA512 (lapack-3.8.0.tar.gz) = 17786cb7306fccdc9b4a242de7f64fc261ebe6a10b6ec55f519deb4cb673cb137e8742aa5698fd2dc52f1cd56d3bd116af3f593a01dcf6770c4dcc86c50b2a7f
Size (lapack-3.8.0.tar.gz) = 7426094 bytes
SHA1 (lapack-3.9.0.tar.gz) = 0451d180eed2b12b94aaae77e772d7573e87bec4
RMD160 (lapack-3.9.0.tar.gz) = 333bf17b3e2503c26cdd2139566fdc788be1d0c3
SHA512 (lapack-3.9.0.tar.gz) = 424956ad941a60a4b71e0d451ad48db12a692f8a71a90f3ca7f71d6ecc1922f392746ea84df1c47a46577ed2db32e9e47ec44ad248207c5ac7da179becb712ef
Size (lapack-3.9.0.tar.gz) = 7534567 bytes
SHA1 (patch-BLAS_SRC_CMakeLists.txt) = c8c69e6e0c67337af999863c4f5c64618d1374d7
SHA1 (patch-CBLAS_cblas.pc.in) = 3befb18c1b7f2f82c6da83ea10f913c817acf09f
SHA1 (patch-CBLAS_src_CMakeLists.txt) = faa1ad6c322830cb62e0f5bdab33732c0372cce3
SHA1 (patch-CMakeLists.txt) = 3f93b4745b1e64fb248249b845c0a44761c382d6
SHA1 (patch-LAPACKE_CMakeLists.txt) = 1d26a94cbbd92a29b4e750a079add13de1d94d1e
SHA1 (patch-CMakeLists.txt) = 0d853fc8bd17daaeb03e6f0a9993a050eea80c91
SHA1 (patch-LAPACKE_CMakeLists.txt) = 745c662d7f9ca45905434bffafaec2566e1a5559
SHA1 (patch-LAPACKE_lapacke.pc.in) = 7f0d91aaceac7f9980650ec90dbda95cf09b768f
SHA1 (patch-SRC_CMakeLists.txt) = a667a733298c25ed63e653e44390b4600725609e
SHA1 (patch-SRC_CMakeLists.txt) = 2908cdeb0d94f51ec16b02b8a6426dd6cde7e10f
SHA1 (patch-TESTING_MATGEN_CMakeLists.txt) = 84d4cde8fef49c6efc9f50a3219b0299375934d5

View File

@ -3,9 +3,9 @@ $NetBSD$
Avoid installation of LAPACK CMake and pkg-config files when not installing
LAPACK.
--- CMakeLists.txt.orig 2019-03-23 09:03:24.021091079 +0000
+++ CMakeLists.txt
@@ -332,10 +332,12 @@ include(CPack)
--- CMakeLists.txt.orig 2019-11-21 08:57:43.000000000 +0100
+++ CMakeLists.txt 2020-01-03 19:48:54.141281263 +0100
@@ -372,10 +372,12 @@
if(NOT BLAS_FOUND)
set(ALL_TARGETS ${ALL_TARGETS} blas)
@ -18,26 +18,27 @@ LAPACK.
endif()
if(BUILD_TESTING OR LAPACKE_WITH_TMG)
@@ -378,11 +380,13 @@ configure_file(${LAPACK_SOURCE_DIR}/CMAK
@@ -420,12 +422,14 @@
${LAPACK_BINARY_DIR}/lapack-config.cmake @ONLY)
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/lapack.pc.in ${CMAKE_CURRENT_BINARY_DIR}/lapack.pc @ONLY)
- install(FILES
- ${CMAKE_CURRENT_BINARY_DIR}/lapack.pc
- DESTINATION ${PKG_CONFIG_DIR}
- )
+if(LAPACK)
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/lapack.pc.in ${CMAKE_CURRENT_BINARY_DIR}/lapack.pc @ONLY)
+ install(FILES
install(FILES
- ${CMAKE_CURRENT_BINARY_DIR}/lapack.pc
- DESTINATION ${PKG_CONFIG_DIR}
- COMPONENT Development
- )
+ ${CMAKE_CURRENT_BINARY_DIR}/lapack.pc
+ DESTINATION ${PKG_CONFIG_DIR}
+ COMPONENT Development
+ )
+endif()
configure_file(${LAPACK_SOURCE_DIR}/CMAKE/lapack-config-install.cmake.in
${LAPACK_BINARY_DIR}/CMakeFiles/lapack-config.cmake @ONLY)
@@ -394,8 +398,10 @@ write_basic_package_version_file(
@@ -437,10 +441,12 @@
COMPATIBILITY SameMajorVersion
)
@ -45,11 +46,16 @@ LAPACK.
- ${LAPACK_BINARY_DIR}/CMakeFiles/lapack-config.cmake
- ${LAPACK_BINARY_DIR}/lapack-config-version.cmake
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/lapack-${LAPACK_VERSION}
- COMPONENT Development
- )
-
\ Kein Zeilenumbruch am Dateiende.
+if(LAPACK)
+ install(FILES
+ ${LAPACK_BINARY_DIR}/CMakeFiles/lapack-config.cmake
+ ${LAPACK_BINARY_DIR}/lapack-config-version.cmake
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/lapack-${LAPACK_VERSION}
+ COMPONENT Development
+ )
+endif()
+

View File

@ -2,9 +2,9 @@ $NetBSD$
Support combined build of shared and static libraries.
--- LAPACKE/CMakeLists.txt.orig 2017-11-13 04:15:54.000000000 +0000
+++ LAPACKE/CMakeLists.txt
@@ -71,6 +71,26 @@ endif()
--- LAPACKE/CMakeLists.txt.orig 2020-01-03 19:33:52.766364829 +0100
+++ LAPACKE/CMakeLists.txt 2020-01-03 19:49:05.115280246 +0100
@@ -94,6 +94,26 @@
target_link_libraries(lapacke PRIVATE ${LAPACK_LIBRARIES})
lapack_install_library(lapacke)
@ -28,6 +28,11 @@ Support combined build of shared and static libraries.
+ lapack_install_library(lapacke_static)
+endif()
+
install(FILES ${LAPACKE_INCLUDE} ${LAPACK_BINARY_DIR}/include/lapacke_mangling.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
if(BUILD_TESTING)
install(
FILES ${LAPACKE_INCLUDE} ${LAPACK_BINARY_DIR}/include/lapacke_mangling.h
DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
@@ -130,3 +150,4 @@
DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/lapacke-${LAPACK_VERSION}
COMPONENT Development
)
+

View File

@ -2,9 +2,9 @@ $NetBSD$
Support combined build of shared and static libraries.
--- SRC/CMakeLists.txt.orig 2017-11-13 04:15:54.000000000 +0000
+++ SRC/CMakeLists.txt
@@ -510,3 +510,23 @@ if (${CMAKE_BUILD_TYPE_UPPER} STREQUAL "
--- SRC/CMakeLists.txt.orig 2019-11-21 08:57:43.000000000 +0100
+++ SRC/CMakeLists.txt 2020-01-03 19:53:12.452257316 +0100
@@ -518,3 +518,23 @@
endif()
lapack_install_library(lapack)
@ -21,7 +21,7 @@ Support combined build of shared and static libraries.
+ endif()
+ target_link_libraries(lapack_static PRIVATE ${BLAS_LIBRARIES})
+
+ if (${CMAKE_BUILD_TYPE_UPPER} STREQUAL "COVERAGE")
+ if (_is_coverage_build)
+ target_link_libraries(lapack_static PRIVATE gcov)
+ add_coverage(lapack_static)
+ endif()

View File

@ -1,4 +1,5 @@
@comment $NetBSD$
include/lapack.h
include/lapacke.h
include/lapacke_config.h
include/lapacke_mangling.h