Quake2 multiplayer orientated client, builds but not installs

This commit is contained in:
andyb 2019-03-08 14:18:31 +01:00
parent d22d34eaf0
commit 89352a7f0b
10 changed files with 87 additions and 0 deletions

View File

@ -11,6 +11,10 @@ COMMENT= Openbox window manager themes
WRKSRC= ${WRKDIR}/themes
USE_LANGUAGES= # none
NO_BUILD= yes
DESTDIR= $WRKSRC
do-install:
${INSTALL_PROGRAM} ${WRKSRC} ${DESTDIR}${PREFIX}/themes
.include "../../mk/bsd.pkg.mk"

1
q2pro/DESCR Normal file
View File

@ -0,0 +1 @@
Quake2 multiplayer orientated client

26
q2pro/Makefile Normal file
View File

@ -0,0 +1,26 @@
# $NetBSD$
GITHUB_PROJECT= qtxqfsts
DISTNAME= q2pro20190305
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GITHUB:=bsfd80/}
GITHUB_RELEASE= 20190228
EXTRACT_SUFX= .zip
DIST_SUBDIR= ${GITHUB_PROJECT}
DEPENDS+= openal-soft-[0-9]*:../../audio/openal-soft
DEPENDS+= SDL2-[0-9]*:../../devel/SDL2
MAINTAINER= pkgls@gmx.net
HOMEPAGE= https://github.com/bsfd80/qtxqfsts/
COMMENT= Quake2 multiplayer orientated client
LICENSE= gnu-gpl-v2
WRKSRC= ${WRKDIR}/q2pro-master
USE_LANGUAGES= c
USE_TOOLS+= gmake
.include "../../audio/openal-soft/buildlink3.mk"
.include "../../devel/SDL2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

1
q2pro/PLIST Normal file
View File

@ -0,0 +1 @@
@comment $NetBSD$

1
q2pro/TODO Normal file
View File

@ -0,0 +1 @@
builds but not installs

10
q2pro/distinfo Normal file
View File

@ -0,0 +1,10 @@
$NetBSD$
SHA1 (qtxqfsts/q2pro20190305.zip) = b7392c4bacb4aa6019d4408aca52b20b6c1d835e
RMD160 (qtxqfsts/q2pro20190305.zip) = 5a87dda5a8ab38b0d2ee218290b9bd90033cf8a9
SHA512 (qtxqfsts/q2pro20190305.zip) = aea9e3458979980b4f4bbceb5cc065c86cda9c3341ca54544de8bdd836ab2fda075306d70481f46b27035a90e1d071781a50150cdfa515c7b35368fd3b305677
Size (qtxqfsts/q2pro20190305.zip) = 1059443 bytes
SHA1 (patch-qgl.h) = db3f888a93e09c2a42592e044593b57fa11021b7
SHA1 (patch-sound.c) = 87fbbf70c8f2c055bdeef964e8a43569096ab519
SHA1 (patch-system.c) = 2e97f04cf9a23fd48f60fdaf349a420b261e4d2f
SHA1 (patch-video.c) = 134901056e2302b9c1736a74c2090dd07a2d4dd1

11
q2pro/patches/patch-qgl.h Normal file
View File

@ -0,0 +1,11 @@
--- src/refresh/qgl.h 2018-12-28 14:34:51.000000000 +0100
+++ src/refresh/qgl.h 2019-03-08 13:48:06.995958009 +0100
@@ -20,7 +20,7 @@
#define QGL_H
#if USE_SDL
-#include <SDL_opengl.h>
+#include <SDL2/SDL_opengl.h>
#else
#include <GL/gl.h>
#include <GL/glext.h>

View File

@ -0,0 +1,11 @@
--- src/unix/sound.c 2018-12-28 14:34:51.000000000 +0100
+++ src/unix/sound.c 2019-03-08 13:51:27.435968350 +0100
@@ -23,7 +23,7 @@
#include "shared/shared.h"
#include "common/zone.h"
#include "client/sound/dma.h"
-#include <SDL.h>
+#include <SDL2/SDL.h>
static void Filler(void *userdata, Uint8 *stream, int len)
{

View File

@ -0,0 +1,11 @@
--- src/unix/system.c 2018-12-28 14:34:51.000000000 +0100
+++ src/unix/system.c 2019-03-08 13:51:42.469969126 +0100
@@ -44,7 +44,7 @@
#endif
#if USE_SDL
-#include <SDL.h>
+#include <SDL2/SDL.h>
#endif
cvar_t *sys_basedir;

View File

@ -0,0 +1,11 @@
--- src/unix/video.c 2018-12-28 14:34:51.000000000 +0100
+++ src/unix/video.c 2019-03-08 13:50:50.311966435 +0100
@@ -33,7 +33,7 @@
#include "refresh/refresh.h"
#include "system/system.h"
#include "res/q2pro.xbm"
-#include <SDL.h>
+#include <SDL2/SDL.h>
static SDL_Window *sdl_window;
static SDL_GLContext *sdl_context;