xf86-video-virtualbox: updated to 6.0.14

This commit is contained in:
Adam Ciarciński 2019-12-15 10:25:52 +01:00
parent c59b824b2a
commit 89c87ca18c
10 changed files with 82 additions and 56 deletions

View File

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.1 2015/09/15 20:56:03 tnn2 Exp $
DISTNAME= VirtualBox-5.0.14
DISTNAME= VirtualBox-6.0.14
PKGNAME= ${DISTNAME:S/VirtualBox/xf86-video-virtualbox/}
PKGREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://download.virtualbox.org/virtualbox/${PKGVERSION_NOREV}/
EXTRACT_SUFX= .tar.bz2
@ -12,18 +11,22 @@ HOMEPAGE= http://www.virtualbox.org/
COMMENT= Modular Xorg Virtualbox video driver
LICENSE= gnu-gpl-v2
USE_LANGUAGES= c c++
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
USE_TOOLS+= pkg-config autoconf automake autoreconf
GNU_CONFIGURE= yes
VBOXVIDEO_DIR= src/VBox/Additions/x11/vboxvideo
CONFIGURE_DIRS= ${VBOXVIDEO_DIR}
EXTRACT_ELEMENTS= ${DISTNAME}/include
EXTRACT_ELEMENTS+= ${DISTNAME}/src
CHECK_PORTABILITY_SKIP= * # don't care
post-extract:
.for f in configure.ac Makefile.am
cp ${FILESDIR}/${f} ${WRKSRC}/${VBOXVIDEO_DIR}
${CP} ${FILESDIR}/${f} ${WRKSRC}/${VBOXVIDEO_DIR}
.endfor
pre-configure:

View File

@ -1,10 +1,11 @@
$NetBSD: distinfo,v 1.1 2015/09/15 20:56:03 tnn2 Exp $
SHA1 (VirtualBox-5.0.14.tar.bz2) = d19b06df4af90e0b641ce2ce0c4c91b39ad3fc74
RMD160 (VirtualBox-5.0.14.tar.bz2) = 64193fa20d21e54836a846fd392e58515bcb26f7
SHA512 (VirtualBox-5.0.14.tar.bz2) = 5547da58b50c9cf5d096f81c005134e1f56c4fb55d4d40a6fbd1efe1fe1fbeebc0747f0903933da9238a24c63eeed2c6c15bfc5cae5ce6e3e2eb4a18511d6258
Size (VirtualBox-5.0.14.tar.bz2) = 111033626 bytes
SHA1 (patch-include_VBox_VBoxGuest.h) = 8798bf144c62e52e141269a3ebfa214b561fb4fb
SHA1 (patch-include_iprt_string.h) = 53f7a496dfe5d23e758d85dc805f555ca11bc557
SHA1 (patch-src_VBox_Additions_x11_vboxvideo_pointer.c) = 3d4733a8ffcdaea59783f982e32f61581ed8c4d2
SHA1 (patch-src_VBox_Additions_x11_vboxvideo_vboxvideo.c) = 871c5529ae304eb378b3a7069e6c84b2ad60372e
SHA1 (VirtualBox-6.0.14.tar.bz2) = 2e0356ce6c41b92e526add21e65dc4904d3d5152
RMD160 (VirtualBox-6.0.14.tar.bz2) = 4ca116a3e4c93424d9e6bd6de8267e3d112d80aa
SHA512 (VirtualBox-6.0.14.tar.bz2) = e1a64c6633987e178b368dc17e738c6fbef4ab262c574188819f1186bf33f38d8c5accd6a566279a12ccd3544bab4ee5a1f8dce7c8c56d7373489c5ff7f8556d
Size (VirtualBox-6.0.14.tar.bz2) = 154236138 bytes
SHA1 (patch-include_VBox_VBoxGuest.h) = 5882e1340101d4b1cb6e183c61d7e8f19f728151
SHA1 (patch-src_VBox_Additions_x11_vboxvideo_VBoxVideoIPRT.h) = 6bf757dcbe2e25ca1ea8120b6decafad881e1db3
SHA1 (patch-src_VBox_Additions_x11_vboxvideo_edid.c) = 6888d49f37e20dcf84d49319be9c336e901725d8
SHA1 (patch-src_VBox_Additions_x11_vboxvideo_pointer.c) = 927ef89d4c04338866063ecb9e4758a088e03f08
SHA1 (patch-src_VBox_Additions_x11_vboxvideo_vboxvideo.c) = 6bb61fcf7ead6916ab9701fb6614a3af31e34d87

View File

@ -3,14 +3,22 @@
vboxvideo_drv_la_LTLIBRARIES = vboxvideo_drv.la
vboxvideo_drv_la_LDFLAGS = -module -avoid-version
vboxvideo_drv_la_CFLAGS = $(CWARNFLAGS) @XORG_CFLAGS@
vboxvideo_drv_la_CXXFLAGS = $(CWARNFLAGS) @XORG_CFLAGS@
vboxvideo_drv_ladir = @moduledir@/drivers
vboxvideo_drv_la_SOURCES = \
../../common/VBoxVideo/HGSMIBase.cpp \
../../common/VBoxVideo/HGSMIBuffers.cpp \
../../common/VBoxVideo/Modesetting.cpp \
../../common/VBoxVideo/VBVABase.cpp \
../../../GuestHost/HGSMI/HGSMICommon.cpp \
HGSMIMemAlloc.h \
VBoxVideoIPRT.h \
edid.c \
getmode.c \
helpers.c \
hgsmimemalloc.c \
pointer.c \
setmode.c \
vboxvideo.c \
vboxvideo.h \
vboxvideo_dri2.c \
vbva.c

View File

@ -1,7 +1,7 @@
# minimal autoconf goop to build vboxvideo outside the VirtualBox framework
AC_PREREQ([2.60])
AC_INIT([xf86-video-virtualbox], [5.0.4])
AC_INIT([xf86-video-virtualbox], [6.0.14])
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_AUX_DIR(.)
AC_SYS_LARGEFILE
@ -15,6 +15,7 @@ XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
AC_DISABLE_STATIC
AC_PROG_CXX
AC_PROG_LIBTOOL
AM_PROG_CC_C_O
@ -25,10 +26,10 @@ AC_ARG_WITH(xorg-module-dir,
[moduledir="$withval"],
[moduledir="$libdir/xorg/modules"])
PKG_CHECK_MODULES(XORG, [xorg-server >= 1.17.0])
PKG_CHECK_EXISTS([xorg-server >= 1.17.0 ],
[AC_DEFINE([HAVE_XORG_SERVER_1_17_0], 1,
[Has version 1.17.0 or greater of the Xserver])])
PKG_CHECK_MODULES(XORG, [xorg-server >= 1.18.0])
PKG_CHECK_EXISTS([xorg-server >= 1.18.0 ],
[AC_DEFINE([HAVE_XORG_SERVER_1_18_0], 1,
[Has version 1.18.0 or greater of the Xserver])])
AC_SUBST([moduledir])
@ -39,14 +40,14 @@ if [ "${RT_OS}" = "SUNOS" ]; then
RT_OS=SOLARIS
fi
CPPFLAGS="${CPPFLAGS} -I../../../../../include -DIN_RING3 -DPCIACCESS -DVBOXVIDEO_13 -DVBOX_DRI -DXORG_7X -DRT_OS_${RT_OS}"
CPPFLAGS="${CPPFLAGS} -I../../../../../include -I../../../../../include/VBox/Graphics -DIN_RING3 -DPCIACCESS -DVBOXVIDEO_13 -DVBOX_DRI -DXORG_7X -DRT_OS_${RT_OS} -DIN_MODULE -DRENDER=1 -DIN_RT_STATIC -DX_BYTE_ORDER=X_LITTLE_ENDIAN -DNO_ANSIC -DXSERVER_LIBPCIACCESS"
cat > version-generated.h << EOF
#include "xorg-server.h"
#define VBOX_VERSION_MAJOR 5
#define VBOX_VERSION_MAJOR 6
#define VBOX_VERSION_MINOR 0
#define VBOX_VERSION_BUILD 4
#define VBOX_VERSION_STRING "5.0.4"
#define VBOX_VERSION_BUILD 14
#define VBOX_VERSION_STRING "6.0.14"
#define VBOX_VENDOR "The NetBSD Foundation, inc."
#define VBOX_SVN_REV 0
EOF

View File

@ -1,10 +1,10 @@
$NetBSD: patch-include_VBox_VBoxGuest.h,v 1.1 2015/09/15 20:56:04 tnn2 Exp $
$NetBSD$
--- include/VBox/VBoxGuest.h.orig 2015-09-08 07:03:01.000000000 +0000
--- include/VBox/VBoxGuest.h.orig 2019-10-10 18:25:38.000000000 +0000
+++ include/VBox/VBoxGuest.h
@@ -527,7 +527,7 @@ typedef VBOXGUESTOS2IDCCONNECT *PVBOXGUE
@@ -980,7 +980,7 @@ RT_C_DECLS_END
#endif
#endif /* RT_OS_OS2 */
-#if defined(RT_OS_LINUX) || defined(RT_OS_SOLARIS) || defined(RT_OS_FREEBSD)
+#if defined(RT_OS_LINUX) || defined(RT_OS_SOLARIS) || defined(RT_OS_FREEBSD) || defined(RT_OS_NETBSD)

View File

@ -1,18 +0,0 @@
$NetBSD$
--- include/iprt/string.h.orig 2016-01-19 16:39:50.000000000 +0000
+++ include/iprt/string.h
@@ -113,11 +113,13 @@ char *strpbrk(const char *pszStr, const
RT_C_DECLS_END
#endif
+#if 0
#if !defined(RT_OS_LINUX) || !defined(_GNU_SOURCE)
RT_C_DECLS_BEGIN
void *memrchr(const char *pv, int ch, size_t cb);
RT_C_DECLS_END
#endif
+#endif
/** @def RT_USE_RTC_3629

View File

@ -0,0 +1,19 @@
$NetBSD$
--- src/VBox/Additions/x11/vboxvideo/VBoxVideoIPRT.h.orig 2019-12-01 07:29:52.207638937 +0000
+++ src/VBox/Additions/x11/vboxvideo/VBoxVideoIPRT.h
@@ -78,6 +78,14 @@ RT_C_DECLS_END
RT_C_DECLS_BEGIN
extern int RTASSERTVAR[1];
+typedef struct RTLISTNODE
+{
+ /** Pointer to the next list node. */
+ struct RTLISTNODE *pNext;
+ /** Pointer to the previous list node. */
+ struct RTLISTNODE *pPrev;
+} RTLISTNODE;
+typedef RTLISTNODE RTLISTANCHOR;
RT_C_DECLS_END
#define AssertCompile(expr) \

View File

@ -0,0 +1,12 @@
$NetBSD$
--- src/VBox/Additions/x11/vboxvideo/edid.c.orig 2019-11-29 19:39:42.639615817 +0000
+++ src/VBox/Additions/x11/vboxvideo/edid.c
@@ -35,6 +35,7 @@
* Michael Thayer <michael.thayer@oracle.com>
*/
+#include "xorg-server.h"
#include "misc.h"
#include "xf86DDC.h"
#include "xf86Crtc.h"

View File

@ -1,13 +1,13 @@
$NetBSD: patch-src_VBox_Additions_x11_vboxvideo_pointer.c,v 1.1 2015/09/15 20:56:04 tnn2 Exp $
$NetBSD$
--- src/VBox/Additions/x11/vboxvideo/pointer.c.orig 2015-09-08 07:03:17.000000000 +0000
--- src/VBox/Additions/x11/vboxvideo/pointer.c.orig 2019-10-10 18:28:12.000000000 +0000
+++ src/VBox/Additions/x11/vboxvideo/pointer.c
@@ -17,6 +17,8 @@
#include <VBox/VBoxGuestLib.h>
@@ -28,6 +28,8 @@
* OTHER DEALINGS IN THE SOFTWARE.
*/
+#include "xorg-server.h"
+
#ifndef PCIACCESS
# include <xf86Pci.h>
# include "xf86Pci.h"
# include <Pci.h>

View File

@ -1,10 +1,10 @@
$NetBSD: patch-src_VBox_Additions_x11_vboxvideo_vboxvideo.c,v 1.1 2015/09/15 20:56:04 tnn2 Exp $
$NetBSD$
--- src/VBox/Additions/x11/vboxvideo/vboxvideo.c.orig 2015-09-08 07:03:17.000000000 +0000
--- src/VBox/Additions/x11/vboxvideo/vboxvideo.c.orig 2019-10-10 18:28:12.000000000 +0000
+++ src/VBox/Additions/x11/vboxvideo/vboxvideo.c
@@ -62,6 +62,7 @@
#include "product-generated.h"
#include "revision-generated.h"
@@ -44,6 +44,7 @@
#include "vboxvideo.h"
#include <VBoxVideoVBE.h>
+#include "xorg-server.h"
/* Basic definitions and functions needed by all drivers. */