wip/py-symEnergy: import py37-symenergy-1.0.7

SymEnergy provides a framework for the structured solution of cost-optimization
of energy systems using the standard Lagrange multiplier approach. The result
consists in the close-form analytical solutions to the optimization problem.
For example, the energy production from a power plant is expressed as a
function of the vector of symbolic parameters. These solutions are evaluated
for certain parameters in order to identify relevant constraint combinations
This commit is contained in:
K.I.A.Derouiche 2020-09-14 01:37:22 +01:00
parent df03561cc2
commit 8aa1c08420
5 changed files with 146 additions and 0 deletions

6
py-symEnergy/DESCR Normal file
View File

@ -0,0 +1,6 @@
SymEnergy provides a framework for the structured solution of cost-optimization
of energy systems using the standard Lagrange multiplier approach. The result
consists in the close-form analytical solutions to the optimization problem.
For example, the energy production from a power plant is expressed as a
function of the vector of symbolic parameters. These solutions are evaluated
for certain parameters in order to identify relevant constraint combinations

14
py-symEnergy/Makefile Normal file
View File

@ -0,0 +1,14 @@
# $NetBSD$
DISTNAME= SymEnergy-1.0.7
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:tl}
CATEGORIES= math python
MASTER_SITES= https://files.pythonhosted.org/packages/47/20/5af6911dbd914cf9d4e507e6f209f7e03aad22db0f74a48a7185b6a34f5b/
MAINTAINER= jihbed.research@gmail.com
HOMEPAGE= https://github.com/mcsoini/symenergy
COMMENT= Lagrange multiplier based energy market toy modeling framework
LICENSE= 2-clause-bsd
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

96
py-symEnergy/PLIST Normal file
View File

@ -0,0 +1,96 @@
@comment $NetBSD$
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/symenergy/__init__.py
${PYSITELIB}/symenergy/__init__.pyc
${PYSITELIB}/symenergy/__init__.pyo
${PYSITELIB}/symenergy/assets/__init__.py
${PYSITELIB}/symenergy/assets/__init__.pyc
${PYSITELIB}/symenergy/assets/__init__.pyo
${PYSITELIB}/symenergy/assets/curtailment.py
${PYSITELIB}/symenergy/assets/curtailment.pyc
${PYSITELIB}/symenergy/assets/curtailment.pyo
${PYSITELIB}/symenergy/assets/plant.py
${PYSITELIB}/symenergy/assets/plant.pyc
${PYSITELIB}/symenergy/assets/plant.pyo
${PYSITELIB}/symenergy/assets/storage.py
${PYSITELIB}/symenergy/assets/storage.pyc
${PYSITELIB}/symenergy/assets/storage.pyo
${PYSITELIB}/symenergy/auxiliary/__init__.py
${PYSITELIB}/symenergy/auxiliary/__init__.pyc
${PYSITELIB}/symenergy/auxiliary/__init__.pyo
${PYSITELIB}/symenergy/auxiliary/constrcomb.py
${PYSITELIB}/symenergy/auxiliary/constrcomb.pyc
${PYSITELIB}/symenergy/auxiliary/constrcomb.pyo
${PYSITELIB}/symenergy/auxiliary/decorators.py
${PYSITELIB}/symenergy/auxiliary/decorators.pyc
${PYSITELIB}/symenergy/auxiliary/decorators.pyo
${PYSITELIB}/symenergy/auxiliary/io.py
${PYSITELIB}/symenergy/auxiliary/io.pyc
${PYSITELIB}/symenergy/auxiliary/io.pyo
${PYSITELIB}/symenergy/auxiliary/parallelization.py
${PYSITELIB}/symenergy/auxiliary/parallelization.pyc
${PYSITELIB}/symenergy/auxiliary/parallelization.pyo
${PYSITELIB}/symenergy/auxiliary/params.py
${PYSITELIB}/symenergy/auxiliary/params.pyc
${PYSITELIB}/symenergy/auxiliary/params.pyo
${PYSITELIB}/symenergy/cache/__init__.py
${PYSITELIB}/symenergy/cache/__init__.pyc
${PYSITELIB}/symenergy/cache/__init__.pyo
${PYSITELIB}/symenergy/cache/l4B7A1DA2C1E2_eval_temp.py
${PYSITELIB}/symenergy/cache/l4B7A1DA2C1E2_eval_temp.pyc
${PYSITELIB}/symenergy/cache/l4B7A1DA2C1E2_eval_temp.pyo
${PYSITELIB}/symenergy/core/__init__.py
${PYSITELIB}/symenergy/core/__init__.pyc
${PYSITELIB}/symenergy/core/__init__.pyo
${PYSITELIB}/symenergy/core/altlinsolve.py
${PYSITELIB}/symenergy/core/altlinsolve.pyc
${PYSITELIB}/symenergy/core/altlinsolve.pyo
${PYSITELIB}/symenergy/core/asset.py
${PYSITELIB}/symenergy/core/asset.pyc
${PYSITELIB}/symenergy/core/asset.pyo
${PYSITELIB}/symenergy/core/collections.py
${PYSITELIB}/symenergy/core/collections.pyc
${PYSITELIB}/symenergy/core/collections.pyo
${PYSITELIB}/symenergy/core/component.py
${PYSITELIB}/symenergy/core/component.pyc
${PYSITELIB}/symenergy/core/component.pyo
${PYSITELIB}/symenergy/core/constraint.py
${PYSITELIB}/symenergy/core/constraint.pyc
${PYSITELIB}/symenergy/core/constraint.pyo
${PYSITELIB}/symenergy/core/model.py
${PYSITELIB}/symenergy/core/model.pyc
${PYSITELIB}/symenergy/core/model.pyo
${PYSITELIB}/symenergy/core/parameter.py
${PYSITELIB}/symenergy/core/parameter.pyc
${PYSITELIB}/symenergy/core/parameter.pyo
${PYSITELIB}/symenergy/core/slot.py
${PYSITELIB}/symenergy/core/slot.pyc
${PYSITELIB}/symenergy/core/slot.pyo
${PYSITELIB}/symenergy/core/variable.py
${PYSITELIB}/symenergy/core/variable.pyc
${PYSITELIB}/symenergy/core/variable.pyo
${PYSITELIB}/symenergy/evaluator/__init__.py
${PYSITELIB}/symenergy/evaluator/__init__.pyc
${PYSITELIB}/symenergy/evaluator/__init__.pyo
${PYSITELIB}/symenergy/evaluator/evaluator.py
${PYSITELIB}/symenergy/evaluator/evaluator.pyc
${PYSITELIB}/symenergy/evaluator/evaluator.pyo
${PYSITELIB}/symenergy/evaluator/plotting.py
${PYSITELIB}/symenergy/evaluator/plotting.pyc
${PYSITELIB}/symenergy/evaluator/plotting.pyo
${PYSITELIB}/symenergy/patches/__init__.py
${PYSITELIB}/symenergy/patches/__init__.pyc
${PYSITELIB}/symenergy/patches/__init__.pyo
${PYSITELIB}/symenergy/patches/symenergy_solveset.py
${PYSITELIB}/symenergy/patches/symenergy_solveset.pyc
${PYSITELIB}/symenergy/patches/symenergy_solveset.pyo
${PYSITELIB}/symenergy/patches/sympy_linear_coeffs.py
${PYSITELIB}/symenergy/patches/sympy_linear_coeffs.pyc
${PYSITELIB}/symenergy/patches/sympy_linear_coeffs.pyo
${PYSITELIB}/symenergy/patches/sympy_linsolve.py
${PYSITELIB}/symenergy/patches/sympy_linsolve.pyc
${PYSITELIB}/symenergy/patches/sympy_linsolve.pyo

7
py-symEnergy/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (SymEnergy-1.0.7.tar.gz) = 15cbb07b499927e0edbc860261af1463e961ce1a
RMD160 (SymEnergy-1.0.7.tar.gz) = 0e2de9273d60a6936ea7bd1cdf228c81e0b70bd4
SHA512 (SymEnergy-1.0.7.tar.gz) = 0854fcf14c8a178c631941288bcce9b1b481a0fc889763aa94dbd7f5ce7f644846c26b87541373b88c75daf46e301d7dcf51bbafb137cf702286e948438f855a
Size (SymEnergy-1.0.7.tar.gz) = 81362 bytes
SHA1 (patch-setup.py) = c8964352bd0e3538cc190ce9059523e74313cf6c

View File

@ -0,0 +1,23 @@
$NetBSD$
--- setup.py.orig 2020-04-08 12:33:37.000000000 +0000
+++ setup.py
@@ -2,9 +2,6 @@ import fnmatch
from setuptools import find_packages, setup
from setuptools.command.build_py import build_py as build_py_orig
-with open("description_pypi.rst", "r") as fh:
- long_description = fh.read()
-
setup(
name="SymEnergy",
version="1.0.7",
@@ -12,8 +9,6 @@ setup(
author_email="m.c.soini@posteo.de",
description=("Lagrange multiplier based energy market toy "
"modeling framework"),
- long_description=long_description,
- long_description_content_type="text/x-rst",
url="https://github.com/mcsoini/symenergy",
packages=find_packages(),
install_requires=['pandas', 'orderedset', 'sympy', 'numpy', 'wrapt',