f3: Import f3-7.1 as sysutils/f3

f3 is a simple tool that tests flash cards capacity and performance to see
if they live up to claimed specifications.

F3 stands for Fight Flash Fraud, or Fight Fake Flash.
This commit is contained in:
Travis Paul 2019-05-22 01:26:03 +08:00
parent d790397c43
commit 8c93d6a2f1
No known key found for this signature in database
GPG Key ID: 0CA1F92FA8ED3A64
7 changed files with 79 additions and 0 deletions

View File

@ -759,6 +759,7 @@ SUBDIR+= exult-snapshot
SUBDIR+= ez-pine-gpg
SUBDIR+= ezbounce
SUBDIR+= f1spirit
SUBDIR+= f3
SUBDIR+= faast
SUBDIR+= facedetect
SUBDIR+= fairymax

4
f3/DESCR Normal file
View File

@ -0,0 +1,4 @@
f3 is a simple tool that tests flash cards capacity and performance to see
if they live up to claimed specifications.
F3 stands for Fight Flash Fraud, or Fight Fake Flash.

21
f3/Makefile Normal file
View File

@ -0,0 +1,21 @@
# $NetBSD$
GITHUB_PROJECT= f3
DISTNAME= v7.1
PKGNAME= ${GITHUB_PROJECT}-7.1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_GITHUB:=AltraMayor/}
DIST_SUBDIR= ${GITHUB_PROJECT}
MAINTAINER= tpaul@NetBSD.org
HOMEPAGE= http://oss.digirati.com.br/f3/
COMMENT= Tests capacity and performance of flash media
LICENSE= gnu-gpl-v3
WRKSRC= ${WRKDIR}/f3-7.1
NO_CONFIGURE= yes
USE_TOOLS+= gmake
.include "../../devel/argp/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

5
f3/PLIST Normal file
View File

@ -0,0 +1,5 @@
@comment $NetBSD$
bin/f3read
bin/f3write
man/man1/f3read.1
man/man1/f3write.1

9
f3/TODO Normal file
View File

@ -0,0 +1,9 @@
f3write on fails(?) on ffs:
Creating file 1.h2w ... 85.80% -- 178.17 MB/s -- 1s
[ 28376.7885906] /mnt: write failed, file system is full
OK!
Free space: 796.00 KB
Average writing speed: 176.36 MB/s
f3read fails on FAT:
assertion "!fdatasync(fd)" failed: file "f3read.c", line 162, function

7
f3/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (f3/v7.1.tar.gz) = 0552423125ccc53eec5ccabb95615e9e17e4068c
RMD160 (f3/v7.1.tar.gz) = 8a3d09d1772b802a7c27901eff4a7ac5dc9b1b13
SHA512 (f3/v7.1.tar.gz) = d696bb96ebaefab13c50a4479be01c206365d8dcf7d3c3b1d906b68705b654fffabdbeee49ea208047383c117bcac2a85c2c5fb129cace82f8addc16f22d7514
Size (f3/v7.1.tar.gz) = 67934 bytes
SHA1 (patch-Makefile) = 48a85dd33248b6b506e49dbe5bfc10cd96681500

32
f3/patches/patch-Makefile Normal file
View File

@ -0,0 +1,32 @@
$NetBSD$
- Allow setting PREFIX
- manpages should be installed to $(PREFIX)/man
Not yet upstreamed as other changes are likely needed.
See TODO.
--- Makefile.orig 2018-07-27 08:10:35.000000000 +0000
+++ Makefile
@@ -4,7 +4,7 @@ CFLAGS += -std=c99 -Wall -Wextra -pedant
TARGETS = f3write f3read
EXTRA_TARGETS = f3probe f3brew f3fix
-PREFIX = /usr/local
+PREFIX?= /usr/local
INSTALL = install
LN = ln
@@ -23,9 +23,9 @@ extra: $(EXTRA_TARGETS)
install: all
$(INSTALL) -d $(DESTDIR)$(PREFIX)/bin
$(INSTALL) -m755 $(TARGETS) $(DESTDIR)$(PREFIX)/bin
- $(INSTALL) -d $(DESTDIR)$(PREFIX)/share/man/man1
- $(INSTALL) -m644 f3read.1 $(DESTDIR)$(PREFIX)/share/man/man1
- $(LN) -sf f3read.1 $(DESTDIR)$(PREFIX)/share/man/man1/f3write.1
+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/man/man1
+ $(INSTALL) -m644 f3read.1 $(DESTDIR)$(PREFIX)/man/man1
+ $(LN) -sf f3read.1 $(DESTDIR)$(PREFIX)/man/man1/f3write.1
install-extra: extra
$(INSTALL) -d $(DESTDIR)$(PREFIX)/bin