Add svt-vp9 version 0.3.0

The Scalable Video Technology for VP9 Encoder (SVT-VP9 Encoder) is
a VP9-compliant encoder library core. The SVT-VP9 Encoder development
is a work-in-progress targeting performance levels applicable to
both VOD and Live encoding/transcoding video applications.
This commit is contained in:
Maya Rashish 2020-11-02 11:57:16 +02:00
parent fc16687308
commit 8d475c1b1a
8 changed files with 113 additions and 0 deletions

4
svt-vp9/DESCR Normal file
View File

@ -0,0 +1,4 @@
The Scalable Video Technology for VP9 Encoder (SVT-VP9 Encoder) is
a VP9-compliant encoder library core. The SVT-VP9 Encoder development
is a work-in-progress targeting performance levels applicable to
both VOD and Live encoding/transcoding video applications.

20
svt-vp9/Makefile Normal file
View File

@ -0,0 +1,20 @@
# $NetBSD$
GITHUB_PROJECT= SVT-VP9
GITHUB_TAG= v0.3.0
DISTNAME= v0.3.0
PKGNAME= ${GITHUB_PROJECT:tl}-${DISTNAME:S,^v,,}
CATEGORIES= # TODO: add primary category
MASTER_SITES= ${MASTER_SITE_GITHUB:=OpenVisualCloud/}
DIST_SUBDIR= ${GITHUB_PROJECT}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/OpenVisualCloud/SVT-VP9/
COMMENT= VP9 encoder
LICENSE= modified-bsd
USE_TOOLS+= pkg-config
WRKSRC= ${WRKDIR}/SVT-VP9-0.3.0/
USE_CMAKE= yes
.include "../../mk/bsd.pkg.mk"

8
svt-vp9/PLIST Normal file
View File

@ -0,0 +1,8 @@
@comment $NetBSD$
bin/SvtVp9EncApp
include/svt-vp9/EbApiVersion.h
include/svt-vp9/EbSvtVp9Enc.h
include/svt-vp9/EbSvtVp9ErrorCodes.h
lib/libSvtVp9Enc.so
lib/libSvtVp9Enc.so.1
lib/pkgconfig/SvtVp9Enc.pc

12
svt-vp9/buildlink3.mk Normal file
View File

@ -0,0 +1,12 @@
# $NetBSD$
BUILDLINK_TREE+= svt-vp9
.if !defined(SVT_VP9_BUILDLINK3_MK)
SVT_VP9_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.svt-vp9+= svt-vp9>=0.3.0
BUILDLINK_PKGSRCDIR.svt-vp9?= ../../wip/svt-vp9
.endif # SVT_VP9_BUILDLINK3_MK
BUILDLINK_TREE+= -svt-vp9

9
svt-vp9/distinfo Normal file
View File

@ -0,0 +1,9 @@
$NetBSD$
SHA1 (SVT-VP9/v0.3.0.tar.gz) = cb3b9f53dd34231dca9d2583628525a763a7ba84
RMD160 (SVT-VP9/v0.3.0.tar.gz) = 62f5b0429e86d2c023f1c56186cf2df9ccd4d6f7
SHA512 (SVT-VP9/v0.3.0.tar.gz) = 2b65d4cc731061c2a07010314f7c306664fd9cf122917f96b94ec87350c8bab1a1118527263eb39347a6f6f572088337e1c5f7ae738b52de30a28ccb54c321c1
Size (SVT-VP9/v0.3.0.tar.gz) = 1009838 bytes
SHA1 (patch-Source_Lib_Codec_EbEncHandle.c) = 15560480ea5a63db6cbb1e695e9e5676e7acf904
SHA1 (patch-Source_Lib_Codec_EbThreads.c) = 277915e2589faa825c40904dc0af0255b52b0ff5
SHA1 (patch-Source_Lib_Codec_EbUtility.c) = a2edd52ebb3675a653ae7dc5681dd9506ffa3821

View File

@ -0,0 +1,15 @@
$NetBSD$
Avoid the need to port cpu-pinning code designed for linux
--- Source/Lib/Codec/EbEncHandle.c.orig 2020-10-30 01:51:10.000000000 +0000
+++ Source/Lib/Codec/EbEncHandle.c
@@ -378,7 +378,7 @@ EbErrorType init_thread_managment_params
// Initialize eb_vp9_group_affinity structure with Current thread info
GetThreadGroupAffinity(GetCurrentThread(), &eb_vp9_group_affinity);
eb_vp9_num_groups = (uint8_t)GetActiveProcessorGroupCount();
-#else
+#elif __linux__
const char* PROCESSORID = "processor";
const char* PHYSICALID = "physical id";
int processor_id_len = EB_STRLEN(PROCESSORID, 128);

View File

@ -0,0 +1,21 @@
$NetBSD$
avoid platform whitelist
--- Source/Lib/Codec/EbThreads.c.orig 2020-10-30 01:51:10.000000000 +0000
+++ Source/Lib/Codec/EbThreads.c
@@ -21,13 +21,11 @@
****************************************/
#ifdef _WIN32
#include <windows.h>
-#elif __linux__
+#else
#include <pthread.h>
#include <semaphore.h>
#include <time.h>
#include <errno.h>
-#else
-#error OS/Platform not supported.
#endif // _WIN32
#if PRINTF_TIME
#ifdef _WIN32

View File

@ -0,0 +1,24 @@
$NetBSD$
avoid platform whitelist
--- Source/Lib/Codec/EbUtility.c.orig 2020-10-30 01:51:10.000000000 +0000
+++ Source/Lib/Codec/EbUtility.c
@@ -13,7 +13,7 @@
#include <stdio.h>
//#endif
-#elif __linux__
+#else
#include <stdio.h>
#include <stdlib.h>
#include "EbDefinitions.h"
@@ -22,8 +22,6 @@
#include <time.h>
//#endif
-#else
-#error OS/Platform not supported.
#endif
static PaBlockStats pa_get_block_stats_array[] = {