wip/dps8m: import dps8m-2.0

A simulator for the Multics dps-8/m mainframe
This commit is contained in:
Kamil Rytarowski 2020-10-21 02:11:43 +02:00
parent 31ba1cd3a2
commit 8df91d1200
7 changed files with 113 additions and 0 deletions

1
dps8m/DESCR Normal file
View File

@ -0,0 +1 @@
A simulator for the Multics dps-8/m mainframe

24
dps8m/Makefile Normal file
View File

@ -0,0 +1,24 @@
# $NetBSD$
PKGNAME= dps8m-${VER}
DISTNAME= dps8_R${VER}_source
CATEGORIES= emulators
MASTER_SITES= http://ringzero.wikidot.com/local--files/start/
EXTRACT_SUFX= .tgz
VER= 2.0
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://gitlab.com/dps8m/dps8m
COMMENT= Multics DPS8/M emulator
LICENSE= # icu
WRKSRC= ${WRKDIR}/${PKGBASE}-code
USE_TOOLS+= gmake
LDFLAGS.NetBSD+= -lm
.include "../../devel/libuv/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

2
dps8m/PLIST Normal file
View File

@ -0,0 +1,2 @@
@comment $NetBSD$
bin/dps8

9
dps8m/distinfo Normal file
View File

@ -0,0 +1,9 @@
$NetBSD$
SHA1 (dps8_R2.0_source.tgz) = c649be9577b5c10b31dea9ce23145e662601cb78
RMD160 (dps8_R2.0_source.tgz) = 1bab7084e35ce71d7318eadf38778127cc1fc390
SHA512 (dps8_R2.0_source.tgz) = 88f888192685fe4f82d98a812578fec5e4e66a73831d5977b7ccd6c309404e46bc5eec68656cef5429d2dfdb25daf1e2f015312f9c79682151b4d86513924e1b
Size (dps8_R2.0_source.tgz) = 2292032 bytes
SHA1 (patch-src_Makefile.mk) = 3dd1a72fd4636cc3bce7516ed460f7216081e185
SHA1 (patch-src_dps8_Makefile) = 828e2ff8c7363373ee16c2c1748dd189a124c19f
SHA1 (patch-src_utils_prt2pdf.c) = 9015f488cf3461129ce8819f1027567d36102ecc

View File

@ -0,0 +1,41 @@
$NetBSD$
--- src/Makefile.mk.orig 2019-08-13 22:06:36.000000000 +0000
+++ src/Makefile.mk
@@ -15,31 +15,10 @@ ifneq ($(OS),Windows_NT)
endif
endif
-ifeq ($(OS), OSX)
- msys_version = 0
-else
- msys_version := $(if $(findstring Msys, $(shell uname -o)),$(word 1, $(subst ., ,$(shell uname -r))),0)
-endif
-
-ifeq ($(msys_version),0)
-else
- CROSS=MINGW64
-endif
-ifeq ($(CROSS),MINGW64)
- CC = x86_64-w64-mingw32-gcc
- LD = x86_64-w64-mingw32-gcc
-ifeq ($(msys_version),0)
- AR = x86_64-w64-mingw32-ar
-else
- AR = ar
-endif
- EXE = .exe
-else
#CC = gcc
#LD = gcc
CC = clang
LD = clang
-endif
# for Linux (Ubuntu 12.10 64-bit) or Apple OS/X 10.8
#CFLAGS += -g -O0
@@ -107,4 +86,3 @@ $(warning #### Using ../Makefile.local)
$(warning ####)
include ../Makefile.local
endif
-

View File

@ -0,0 +1,23 @@
$NetBSD$
--- src/dps8/Makefile.orig 2019-08-27 18:08:20.000000000 +0000
+++ src/dps8/Makefile
@@ -20,7 +20,9 @@ all :
SIMHx = ../simh-master
-INSTALL_ROOT ?= /usr/local/
+DESTDIR ?=
+PREFIX ?= /usr/local
+INSTALL_ROOT ?= $(DESTDIR)$(PREFIX)
INSTALL_BIN ?= $(INSTALL_ROOT)/bin
@@ -270,6 +272,7 @@ all: utils $(TAGS) locallibs_then_dps8
# $(CC) remote.c -o remote fnp_udplib.o
install: all
+ install -d $(INSTALL_BIN)
cp dps8$(EXE) $(INSTALL_BIN)/dps8$(EXE)
cscope:

View File

@ -0,0 +1,13 @@
$NetBSD$
--- src/utils/prt2pdf.c.orig 2019-08-10 21:30:47.000000000 +0000
+++ src/utils/prt2pdf.c
@@ -83,7 +83,7 @@ o added command line options for
#include <stdlib.h>
#include <ctype.h>
#include <unistd.h>
-char *gets(char *s);
+//char *gets(char *s);
/* ============================================================================================================================== */
#define MAX(x, y) ((x) > (y) ? (x) : (y))