This commit is contained in:
Jonathan Schleifer 2020-02-15 20:48:01 +01:00
parent 142f3cb7ad
commit 92d76d8644
No known key found for this signature in database
GPG Key ID: E2BCCE6B35E1AF8B
5 changed files with 3372 additions and 0 deletions

8
fpc/DESCR Normal file
View File

@ -0,0 +1,8 @@
Free Pascal is a 32, 64 and 16 bit professional Pascal compiler. It can
target many processor architectures: Intel x86 (including 8086),
AMD64/x86-64, PowerPC, PowerPC64, SPARC, ARM, AArch64, MIPS and the JVM.
Supported operating systems include Linux, FreeBSD, Haiku, Mac OS
X/iOS/iPhoneSimulator/Darwin, DOS (16 and 32 bit), Win32, Win64, WinCE,
OS/2, MorphOS, Nintendo GBA, Nintendo DS, Nintendo Wii, Android, AIX and
AROS. Additionally, support for the Motorola 68k architecture is
available in the development versions.

29
fpc/Makefile Normal file
View File

@ -0,0 +1,29 @@
# $NetBSD$
VERSION= 3.0.4
PKGNAME= fpc-${VERSION}
DISTNAME= fpc-${VERSION}.source
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=freepascal/Source/${VERSION}/}
MASTER_SITES+= ${MASTER_SITE_SOURCEFORGE:=freepascal/Bootstrap/3.0.0/}
DISTFILES= ${DEFAULT_DISTFILES}
MAINTAINER= js-pkgsrc@nil.im
HOMEPAGE= https://www.freepascal.org/
COMMENT= Pascal compiler
LICENSE= gnu-gpl-v2
WRKSRC= ${WRKDIR}/fpc-${VERSION}
USE_TOOLS+= gmake
MAKEFLAGS+= PREFIX=${PREFIX} INSTALL_PREFIX=${DESTDIR}${PREFIX}
ONLY_FOR_PLATFORM+= Darwin-*-x86_64
.if empty(MACHINE_PLATFORM:MDarwin-*-x86_64)
DISTFILES:= ${DISTFILES} x86_64-macosx-10.7-ppcx64.tar.bz2
MAKEFLAGS+= PP=${WRKDIR}/ppcx64
MAKEFLAGS+= OPT="-XR/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk"
.endif
.include "../../mk/bsd.pkg.mk"

3308
fpc/PLIST Normal file

File diff suppressed because it is too large Load Diff

11
fpc/distinfo Normal file
View File

@ -0,0 +1,11 @@
$NetBSD$
SHA1 (fpc-3.0.4.source.tar.gz) = 7b4d214f2de56e5a60cca6b6ab8f192e786894b4
RMD160 (fpc-3.0.4.source.tar.gz) = 40e1be365e69ed30b4114303c6891cbc60d4b8f3
SHA512 (fpc-3.0.4.source.tar.gz) = fc64fd94c39f220bd7531126d6281fa2141aed61c218595a7906a025660b46629a305ff7eb023f5e1359eafdec2dba69aa5405f1bbc3c1182414968689cbb52e
Size (fpc-3.0.4.source.tar.gz) = 40347617 bytes
SHA1 (x86_64-macosx-10.7-ppcx64.tar.bz2) = 2f1e11c8dc2f2bd06c6c34d4954064c74feeea49
RMD160 (x86_64-macosx-10.7-ppcx64.tar.bz2) = 25fb3c2eb9fa364ee56a5f3c2667151143f39777
SHA512 (x86_64-macosx-10.7-ppcx64.tar.bz2) = db60937f1ff09d4087d8d169da98ffbe6f8cc7eef5726ad59d50d1933e5aeb16d5996863c60fd1f9451d2d36b090707572c240c090e7020cafa341fa163baec2
Size (x86_64-macosx-10.7-ppcx64.tar.bz2) = 1095556 bytes
SHA1 (patch-compiler_systems_t_bsd.pas) = f2b536e27f7a5f1686c6be0cc61b2ee1f16f7870

View File

@ -0,0 +1,16 @@
$NetBSD$
--- compiler/systems/t_bsd.pas.orig 2014-12-07 20:27:02.000000000 +0000
+++ compiler/systems/t_bsd.pas
@@ -310,7 +310,10 @@ begin
if startupfile<>'' then
begin
if not librarysearchpath.FindFile(startupfile,false,result) then
- result:='/usr/lib/'+startupfile
+ if sysutils.DirectoryExists('/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/lib') then
+ result:='/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/lib/'+startupfile
+ else
+ result:='/usr/lib/'+startupfile
end
else
result:='';