boringssl: update to 20170919 snapshot

No changes posted.
This commit is contained in:
coypu 2017-09-19 12:26:21 +03:00
parent dfb7ea4af8
commit 99d64e5044
10 changed files with 39 additions and 122 deletions

View File

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.8 2017/04/13 15:12:06 bsiegert Exp $
DISTNAME= boringssl-20151230
PKGREVISION= 6
DISTNAME= boringssl-20170919
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_LOCAL}
@ -15,24 +14,27 @@ WRKSRC= ${WRKDIR}/boringssl
BUILD_DEPENDS+= go>=1.4:../../lang/go
USE_TOOLS+= cmake perl
USE_LANGUAGES+= c c++
USE_LANGUAGES+= c gnu++11
USE_CMAKE= yes
TEST_TARGET= run_tests
AUTO_MKDIRS= yes
do-build:
mkdir -p ${WRKSRC}/build
cd ${WRKSRC}/build && cmake ..
cd ${WRKSRC}/build && make
CFLAGS+= -D_XOPEN_SOURCE=600 -D_NETBSD_SOURCE
post-extract:
${RUN} mkdir -p ${WRKDIR}/build
do-install:
for d in bssl/bin bssl/lib bssl/include/openssl; do \
mkdir -p ${DESTDIR}${PREFIX}/$$d; \
done
${INSTALL_LIB} ${WRKSRC}/build/crypto/libcrypto.a ${DESTDIR}${PREFIX}/bssl/lib
${INSTALL_LIB} ${WRKSRC}/build/ssl/libssl.a ${DESTDIR}${PREFIX}/bssl/lib
${INSTALL_PROGRAM} ${WRKSRC}/build/ssl/test/bssl_shim ${DESTDIR}${PREFIX}/bssl/bin/bssl_shim
${INSTALL_PROGRAM} ${WRKSRC}/build/ssl/ssl_test ${DESTDIR}${PREFIX}/bssl/bin/ssl_test
${INSTALL_PROGRAM} ${WRKSRC}/build/tool/bssl ${DESTDIR}${PREFIX}/bssl/bin/bssl
${INSTALL_LIB} ${WRKSRC}/crypto/libcrypto.a ${DESTDIR}${PREFIX}/bssl/lib
${INSTALL_LIB} ${WRKSRC}/ssl/libssl.a ${DESTDIR}${PREFIX}/bssl/lib
${INSTALL_PROGRAM} ${WRKSRC}/ssl/test/bssl_shim ${DESTDIR}${PREFIX}/bssl/bin/bssl_shim
${INSTALL_PROGRAM} ${WRKSRC}/ssl/ssl_test ${DESTDIR}${PREFIX}/bssl/bin/ssl_test
${INSTALL_PROGRAM} ${WRKSRC}/tool/bssl ${DESTDIR}${PREFIX}/bssl/bin/bssl
(cd ${WRKSRC}/include/openssl && \
for f in *.h; do \
${INSTALL_DATA} $$f ${DESTDIR}${PREFIX}/bssl/include/openssl/$$f; \

View File

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2015/12/31 02:57:35 agc Exp $
@comment $NetBSD$
bssl/bin/bssl
bssl/bin/bssl_shim
bssl/bin/ssl_test
@ -39,15 +39,17 @@ bssl/include/openssl/evp.h
bssl/include/openssl/ex_data.h
bssl/include/openssl/hkdf.h
bssl/include/openssl/hmac.h
bssl/include/openssl/is_boringssl.h
bssl/include/openssl/lhash.h
bssl/include/openssl/lhash_macros.h
bssl/include/openssl/md4.h
bssl/include/openssl/md5.h
bssl/include/openssl/mem.h
bssl/include/openssl/nid.h
bssl/include/openssl/obj.h
bssl/include/openssl/obj_mac.h
bssl/include/openssl/objects.h
bssl/include/openssl/opensslfeatures.h
bssl/include/openssl/opensslconf.h
bssl/include/openssl/opensslv.h
bssl/include/openssl/ossl_typ.h
bssl/include/openssl/pem.h
@ -55,19 +57,19 @@ bssl/include/openssl/pkcs12.h
bssl/include/openssl/pkcs7.h
bssl/include/openssl/pkcs8.h
bssl/include/openssl/poly1305.h
bssl/include/openssl/pqueue.h
bssl/include/openssl/pool.h
bssl/include/openssl/rand.h
bssl/include/openssl/rc4.h
bssl/include/openssl/ripemd.h
bssl/include/openssl/rsa.h
bssl/include/openssl/safestack.h
bssl/include/openssl/sha.h
bssl/include/openssl/span.h
bssl/include/openssl/srtp.h
bssl/include/openssl/ssl.h
bssl/include/openssl/ssl3.h
bssl/include/openssl/stack.h
bssl/include/openssl/stack_macros.h
bssl/include/openssl/thread.h
bssl/include/openssl/time_support.h
bssl/include/openssl/tls1.h
bssl/include/openssl/type_check.h
bssl/include/openssl/x509.h

13
boringssl/buildlink3.mk Normal file
View File

@ -0,0 +1,13 @@
# $NetBSD$
BUILDLINK_DEPMETHOD.boringssl?= build
BUILDLINK_TREE+= boringssl
.if !defined(BORINGSSL_BUILDLINK3_MK)
BORINGSSL_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.boringssl+= boringssl>=20151230nb6
BUILDLINK_PKGSRCDIR.boringssl?= ../../wip/boringssl
.endif # BORINGSSL_BUILDLINK3_MK
BUILDLINK_TREE+= -boringssl

View File

@ -1,13 +1,8 @@
$NetBSD: distinfo,v 1.2 2016/12/21 13:38:16 joerg Exp $
SHA1 (boringssl-20151230.tar.gz) = eb3681358044990bc54c9ab58a3ce8d951edd022
RMD160 (boringssl-20151230.tar.gz) = cf2b15e5dc261efcba44cb493947e9c48d346c36
SHA512 (boringssl-20151230.tar.gz) = 868e53f5cc695c115b261cae67855f95bc017278aecb86b57941a8f0bfa553cb01ebc8cef65d82c18c65cf34b36fbd33a663805b1fcde37f40a88a11c30d7b73
Size (boringssl-20151230.tar.gz) = 21984504 bytes
SHA1 (patch-crypto__bio__bio_test.cc) = 441f14b565c566528d175d56fec34b905c1400cf
SHA1 (patch-crypto__bio__internal.h) = ca998dc82f208fcc46144c932154c456474a9e88
SHA1 (patch-crypto__bio__socket_helper.c) = 6ac17f5899817522d3ba883a88d87b5d8541213e
SHA1 (patch-crypto__lhash__lhash_test.c) = 9f411a45fcb8d861911f8ef69651f591a70211b2
SHA1 (patch-crypto__mem.c) = 186c7f7af8b28defc80266a351456328df0976cc
SHA1 (patch-crypto_aes_aes__test.cc) = d5c442101a42ca46456cb42b6e4cea053f7a98cb
SHA1 (boringssl-20170919.tar.gz) = d8830bbe590081793b5d4bd3774e408143c0955e
RMD160 (boringssl-20170919.tar.gz) = cf5facc74cc90471c6a5c0f2ba8ec61d712f4504
SHA512 (boringssl-20170919.tar.gz) = 199722e9f247bd5172f118309d936139f66ed7b2f254f02dae941629dd0a03755080173ef8bada30281d732e04e02e0945b313a20c5892047773a91de9d719c7
Size (boringssl-20170919.tar.gz) = 27761764 bytes
SHA1 (patch-CMakeLists.txt) = a1d04114ffaa7e4e135c9954a16303acd131ca93
SHA1 (patch-include__openssl__thread.h) = 0faf11db8591026c10ae3271936b1ef6381d977a

View File

@ -1,16 +0,0 @@
$NetBSD: patch-crypto__bio__bio_test.cc,v 1.1.1.1 2015/12/31 02:57:35 agc Exp $
NetBSD portability patches
--- crypto/bio/bio_test.cc.orig 2015-12-30 15:55:50.000000000 -0800
+++ crypto/bio/bio_test.cc 2015-12-30 18:06:05.000000000 -0800
@@ -13,7 +13,9 @@
* CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. */
#if !defined(_POSIX_C_SOURCE)
+# if !defined(__NetBSD__)
#define _POSIX_C_SOURCE 201410L
+# endif
#endif
#include <openssl/base.h>

View File

@ -1,15 +0,0 @@
$NetBSD: patch-crypto__bio__internal.h,v 1.1.1.1 2015/12/31 02:57:35 agc Exp $
NetBSD portability patches
--- crypto/bio/internal.h.orig 2015-12-30 15:55:50.000000000 -0800
+++ crypto/bio/internal.h 2015-12-30 18:06:05.000000000 -0800
@@ -59,6 +59,8 @@
#include <openssl/base.h>
+#include <netdb.h>
+
#if !defined(OPENSSL_WINDOWS)
#if defined(OPENSSL_PNACL)
/* newlib uses u_short in socket.h without defining it. */

View File

@ -1,17 +0,0 @@
$NetBSD: patch-crypto__bio__socket_helper.c,v 1.1.1.1 2015/12/31 02:57:35 agc Exp $
NetBSD portability patches
--- crypto/bio/socket_helper.c.orig 2015-12-30 15:55:50.000000000 -0800
+++ crypto/bio/socket_helper.c 2015-12-30 18:06:05.000000000 -0800
@@ -12,8 +12,10 @@
* OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
* CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. */
+#if !defined(__NetBSD__)
#undef _POSIX_C_SOURCE
#define _POSIX_C_SOURCE 200112L
+#endif
#include <openssl/bio.h>
#include <openssl/err.h>

View File

@ -1,16 +0,0 @@
$NetBSD: patch-crypto__lhash__lhash_test.c,v 1.1.1.1 2015/12/31 02:57:35 agc Exp $
NetBSD portability patches
--- crypto/lhash/lhash_test.c.orig 2015-12-30 15:55:51.000000000 -0800
+++ crypto/lhash/lhash_test.c 2015-12-30 18:06:05.000000000 -0800
@@ -13,7 +13,9 @@
* CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. */
#if !defined(_POSIX_C_SOURCE)
+# if !defined(__NetBSD__)
#define _POSIX_C_SOURCE 201410L
+# endif
#endif
#include <openssl/crypto.h>

View File

@ -1,16 +0,0 @@
$NetBSD: patch-crypto__mem.c,v 1.1.1.1 2015/12/31 02:57:35 agc Exp $
NetBSD portability patches
--- crypto/mem.c.orig 2015-12-30 15:55:51.000000000 -0800
+++ crypto/mem.c 2015-12-30 18:06:05.000000000 -0800
@@ -55,7 +55,9 @@
* [including the GNU Public Licence.] */
#if !defined(_POSIX_C_SOURCE)
+# if !defined(__NetBSD__)
#define _POSIX_C_SOURCE 201410L /* needed for strdup, snprintf, vprintf etc */
+# endif
#endif
#include <openssl/mem.h>

View File

@ -1,15 +0,0 @@
$NetBSD: patch-crypto_aes_aes__test.cc,v 1.1 2016/12/21 13:38:16 joerg Exp $
main() does not return bool.
--- crypto/aes/aes_test.cc.orig 2016-12-21 00:28:18.783846441 +0000
+++ crypto/aes/aes_test.cc
@@ -94,7 +94,7 @@ int main() {
"\x88\x99\xaa\xbb\xcc\xdd\xee\xff",
(const uint8_t *)"\x8e\xa2\xb7\xca\x51\x67\x45\xbf"
"\xea\xfc\x49\x90\x4b\x49\x60\x89")) {
- return false;
+ return 0;
}
printf("PASS\n");