poke-git: Initial import

GNU poke is an interactive, extensible editor for binary data.  Not
limited to editing basic entities such as bits and bytes, it provides
a full-fledged procedural, interactive programming language designed
to describe data structures and to operate on them.
This commit is contained in:
Sijmen J. Mulder 2020-11-18 17:03:26 +01:00
parent fba4a081a0
commit 9a7cf5c77d
7 changed files with 145 additions and 0 deletions

4
poke-git/DESCR Normal file
View File

@ -0,0 +1,4 @@
GNU poke is an interactive, extensible editor for binary data. Not
limited to editing basic entities such as bits and bytes, it provides
a full-fledged procedural, interactive programming language designed
to describe data structures and to operate on them.

53
poke-git/Makefile Normal file
View File

@ -0,0 +1,53 @@
# $NetBSD$
GNULIB_HASH= 160d5e7d9a64a29a52d4821fd0ef2136d7e2102a
JITTER_HASH= 37b32d525e91c855b9836c62394310f8af73d50e
PKGNAME= poke-git-0.20201118
DISTNAME= poke-750c179b57ee8ea522f599fa5ea1efb31ba0b31e
CATEGORIES= textproc devel
MASTER_SITES= https://git.savannah.gnu.org/cgit/poke.git/snapshot/
DISTFILES= ${DISTNAME}.tar.gz
DISTFILES+= gnulib-${GNULIB_HASH}.tar.gz
DISTFILES+= jitter-${JITTER_HASH}.tar.gz
SITES.gnulib-${GNULIB_HASH}.tar.gz= \
https://git.savannah.gnu.org/cgit/gnulib.git/snapshot/
SITES.jitter-${JITTER_HASH}.tar.gz= \
http://git.ageinghacker.net/jitter/snapshot/
MAINTAINER= sjmulder@NetBSD.org
HOMEPAGE= http://www.jemarch.net/poke
COMMENT= Extensible editor for structured binary data
LICENSE= gnu-gpl-v3
GNU_CONFIGURE= yes
USE_TOOLS+= pkg-config
USE_TOOLS+= gmake makeinfo gawk
USE_TOOLS+= autoconf automake aclocal autoheader
USE_TOOLS+= flex bison
TOOL_DEPENDS+= bison>=3.6:../../devel/bison
TOOLS_PLATFORM.bison=
TOOLS_PLATFORM.bison-yacc=
BOOTSTRAP_FLAGS+= --skip-po --no-git
BOOTSTRAP_FLAGS+= --gnulib-srcdir=${WRKSRC}/gnulib
CONFIGURE_FLAGS+= --enable-mi
post-extract:
rmdir ${WRKSRC}/gnulib ${WRKSRC}/jitter
mv ${EXTRACT_DIR}/gnulib-${GNULIB_HASH} ${WRKSRC}/gnulib
mv ${EXTRACT_DIR}/jitter-${JITTER_HASH} ${WRKSRC}/jitter
pre-configure:
cd ${WRKSRC} && ${SH} ./bootstrap ${BOOTSTRAP_FLAGS}
.include "options.mk"
.include "../../devel/boehm-gc/buildlink3.mk"
.include "../../devel/gettext-tools/buildlink3.mk"
.include "../../textproc/json-c/buildlink3.mk"
.include "../../mk/readline.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

43
poke-git/PLIST Normal file
View File

@ -0,0 +1,43 @@
@comment $NetBSD$
bin/poke
bin/poke-gui
include/libpoke.h
lib/libpoke.la
man/man1/poke.1
share/info/dir
share/info/poke.info
share/info/poke.info-1
share/info/poke.info-2
share/poke/gui/pk-gui.tcl
share/poke/gui/pk-main.tcl
share/poke/gui/pk-mi-msg.tcl
share/poke/gui/pk-mi.tcl
share/poke/maps/dwarf.map
share/poke/maps/elf.map
share/poke/maps/mp3.map
share/poke/nodelist
share/poke/pickles/bmp.pk
share/poke/pickles/bpf.pk
share/poke/pickles/btf.pk
share/poke/pickles/color.pk
share/poke/pickles/ctf.pk
share/poke/pickles/dwarf-common.pk
share/poke/pickles/dwarf-frame.pk
share/poke/pickles/dwarf-pubnames.pk
share/poke/pickles/dwarf-types.pk
share/poke/pickles/dwarf.pk
share/poke/pickles/elf.pk
share/poke/pickles/id3v1.pk
share/poke/pickles/leb128.pk
share/poke/pickles/rgb24.pk
share/poke/pickles/time.pk
share/poke/pk-cmd.pk
share/poke/pk-copy.pk
share/poke/pk-dump.pk
share/poke/pk-extract.pk
share/poke/pk-save.pk
share/poke/pkl-rt.pk
share/poke/poke-default.css
share/poke/poke.pk
share/poke/poke.text
share/poke/std.pk

3
poke-git/TODO Normal file
View File

@ -0,0 +1,3 @@
- Package and (optionally) use libnbd
- Upstream some fix for the bootstrap patch
- See if we can use non-bundled Jitter

15
poke-git/distinfo Normal file
View File

@ -0,0 +1,15 @@
$NetBSD$
SHA1 (gnulib-160d5e7d9a64a29a52d4821fd0ef2136d7e2102a.tar.gz) = 5e57b346b9b14054ae8fad09446da631e80ffb43
RMD160 (gnulib-160d5e7d9a64a29a52d4821fd0ef2136d7e2102a.tar.gz) = d1c49728c5a8a810de7096e3fed9614cd9d2c3f2
SHA512 (gnulib-160d5e7d9a64a29a52d4821fd0ef2136d7e2102a.tar.gz) = aa7a1d9d85058fa5e8f3f0ff3baba325075de5e1e8ec23264608d213096979efbb56d7b531259ac9861fd684377d6504012032328691538000c0401b6b6aa74a
Size (gnulib-160d5e7d9a64a29a52d4821fd0ef2136d7e2102a.tar.gz) = 7141665 bytes
SHA1 (jitter-37b32d525e91c855b9836c62394310f8af73d50e.tar.gz) = 451005d669f512ee0a3bf24a06cc3de167e4d5e3
RMD160 (jitter-37b32d525e91c855b9836c62394310f8af73d50e.tar.gz) = 2e9e26c13bf0c101e2a0d6fb70bd209c8918692a
SHA512 (jitter-37b32d525e91c855b9836c62394310f8af73d50e.tar.gz) = e020d8d516679126f91415ae4cbe3d6383cdc1838968e5d76b80b36d0164409595a3a7851b3ba4f839508beee9483750be39d3d7a8178a4c873d0575211a30e1
Size (jitter-37b32d525e91c855b9836c62394310f8af73d50e.tar.gz) = 754827 bytes
SHA1 (poke-750c179b57ee8ea522f599fa5ea1efb31ba0b31e.tar.gz) = 60f9574f466fb92d2efba89b0d8c6290efdd3d18
RMD160 (poke-750c179b57ee8ea522f599fa5ea1efb31ba0b31e.tar.gz) = 66522a1a7b6bbc6d845a804c1042272e4c62bb33
SHA512 (poke-750c179b57ee8ea522f599fa5ea1efb31ba0b31e.tar.gz) = 08031ac6dc250234451feb0f5ef2f72b92c8f17f3052c09ab1d1db8761f30bacae41ef01de841962696d7609c4f3389e488c5bc7f4b8ac618f7351ec0954590c
Size (poke-750c179b57ee8ea522f599fa5ea1efb31ba0b31e.tar.gz) = 727301 bytes
SHA1 (patch-bootstrap.conf) = b216451b26cf4abf9fc45e7315c078bf6a889535

13
poke-git/options.mk Normal file
View File

@ -0,0 +1,13 @@
# $NetBSD$
PKG_OPTIONS_VAR= PKG_OPTIONS.poke-git
PKG_SUPPORTED_OPTIONS+= x11
PKG_SUGGESTED_OPTIONS+= x11
.include "../../mk/bsd.options.mk"
.if !empty(PKG_OPTIONS:Mx11)
CONFIGURE_FLAGS+= --enable-gui
.include "../../lang/tcl/buildlink3.mk"
.include "../../x11/tk/buildlink3.mk"
.endif

View File

@ -0,0 +1,14 @@
$NetBSD$
--- bootstrap.conf.orig 2020-11-18 10:40:52.000000000 +0000
+++ bootstrap.conf
@@ -168,9 +168,6 @@ bootstrap_post_import_hook ()
# create gl-gui
${GNULIB_SRCDIR}/gnulib-tool --import --lib=libgnu --source-base=gl-gui --m4-base=m4/gui --doc-base=doc --aux-dir=build-aux --no-conditional-dependencies --libtool --without-tests --macro-prefix=gui ${gui_modules}
- echo 'Updating the Jitter submodule'
- git submodule update --init -- ./jitter
-
echo 'Bootstrapping Jitter'
(
cd jitter