fine tune wireshark

This commit is contained in:
Adam Ciarciński 2019-04-17 17:26:07 +02:00
parent 5947afa6ce
commit 9f088b49de
4 changed files with 49 additions and 41 deletions

View File

@ -658,9 +658,11 @@ man/man1/sshdump.1
man/man1/text2pcap.1
man/man1/tshark.1
man/man1/udpdump.1
${PLIST.mans}man/man1/wireshark.1
man/man1/wireshark.1
man/man4/extcap.4
man/man4/wireshark-filter.4
${PLIST.icons}share/appdata/wireshark.appdata.xml
${PLIST.icons}share/applications/wireshark.desktop
share/doc/wireshark/androiddump.html
share/doc/wireshark/capinfos.html
share/doc/wireshark/captype.html
@ -681,8 +683,6 @@ share/doc/wireshark/tshark.html
share/doc/wireshark/udpdump.html
share/doc/wireshark/wireshark-filter.html
share/doc/wireshark/wireshark.html
${PLIST.icons}share/appdata/wireshark.appdata.xml
${PLIST.icons}share/applications/wireshark.desktop
${PLIST.icons}share/icons/hicolor/128x128/apps/wireshark.png
${PLIST.icons}share/icons/hicolor/128x128/mimetypes/application-vnd.tcpdump.pcap.png
${PLIST.icons}share/icons/hicolor/128x128/mimetypes/application-wireshark-doc.png

View File

@ -4,4 +4,4 @@ SHA1 (wireshark-3.0.1.tar.xz) = 33b880fb76b356dce4713a207c0bb9624f9b2c43
RMD160 (wireshark-3.0.1.tar.xz) = 27ed3498a1e9a89706c1461736219c4ae4b08085
SHA512 (wireshark-3.0.1.tar.xz) = 59c3f36e4e7a1a7ea8f926dbf8ca495f83346396e1df5edf6a1bb34823c84308f52a1b6d46be9675d3af9ce8718da4a574f63a4fb210d8fc52131f4534d8670d
Size (wireshark-3.0.1.tar.xz) = 30903792 bytes
SHA1 (patch-CMakeLists.txt) = 431afe779ed4c41ef11f2dc94f1c0e665610d6b5
SHA1 (patch-CMakeLists.txt) = c78289d6ded796674b947d6bddd0ba9749ab4569

View File

@ -1,66 +1,62 @@
# $NetBSD: options.mk,v 1.22 2018/12/03 15:35:15 adam Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.wireshark
PKG_SUPPORTED_OPTIONS= http2 lua qt5
PKG_SUGGESTED_OPTIONS= qt5 lua
PKG_OPTIONS_VAR= PKG_OPTIONS.wireshark
PKG_SUPPORTED_OPTIONS= http2 lua qt5
PKG_SUGGESTED_OPTIONS= qt5 lua
.include "../../mk/bsd.options.mk"
PLIST_VARS+= icons lua mans qt
PLIST_VARS+= icons lua qt
.if !empty(PKG_OPTIONS:Mhttp2)
. include "../../www/nghttp2/buildlink3.mk"
.else
CMAKE_ARGS+= -DENABLE_NGHTTP2=OFF
.endif
.if !empty(PKG_OPTIONS:Mlua)
LUA_VERSIONS_INCOMPATIBLE= 53
. include "../../lang/lua/buildlink3.mk"
PLIST.lua= yes
.else
CMAKE_ARGS+= -DENABLE_LUA=OFF
.endif
.if !empty(PKG_OPTIONS:Mqt5)
. include "../../x11/qt5-qtsvg/buildlink3.mk"
. include "../../x11/qt5-qttools/buildlink3.mk"
PLIST.qt= yes
. if ${OPSYS} == "Darwin"
. include "../../x11/qt5-qtmacextras/buildlink3.mk"
. else
. include "../../x11/qt5-qtx11extras/buildlink3.mk"
. endif
PLIST.qt= yes
.endif
.if empty(PKG_OPTIONS:Mqt5)
#CONFIGURE_ARGS+= --disable-wireshark
.else
#CONFIGURE_ARGS+= --enable-wireshark
PLIST.mans= yes
INSTALLATION_DIRS+= share/applications
PLIST.icons= yes
. include "../../x11/qt5-qtx11extras/buildlink3.mk"
POST_INSTALL_TARGETS+= install-icons
INSTALLATION_DIRS+= share/applications
INSTALLATION_DIRS+= share/icons/hicolor/scalable/apps
ICON_SIZES= 16 32 48
MIMEICON_SIZES= 16 24 32 48 64 128 256
. for d in ${ICON_SIZES}
. for d in ${ICON_SIZES}
INSTALLATION_DIRS+= share/icons/hicolor/${d}x${d}/apps
. endfor
. endfor
. for d in ${MIMEICON_SIZES}
. for d in ${MIMEICON_SIZES}
INSTALLATION_DIRS+= share/icons/hicolor/${d}x${d}/mimetypes
. endfor
. endfor
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
. include "../../sysutils/desktop-file-utils/desktopdb.mk"
. include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.PHONY: install-icons
install-icons:
${INSTALL_DATA} ${WRKSRC}/image/wsicon.svg \
${DESTDIR}${PREFIX}/share/icons/hicolor/scalable/apps/wireshark.svg
. for d in ${MIMEICON_SIZES}
. for d in ${MIMEICON_SIZES}
${INSTALL_DATA} ${WRKSRC}/image/WiresharkDoc-${d}.png \
${DESTDIR}${PREFIX}/share/icons/hicolor/${d}x${d}/mimetypes/application-vnd.tcpdump.pcap.png
. endfor
.endif
.if !empty(PKG_OPTIONS:Mlua)
LUA_VERSIONS_INCOMPATIBLE= 53
.include "../../lang/lua/buildlink3.mk"
#CONFIGURE_ARGS+= --with-lua=yes
PLIST.lua= yes
. endfor
. endif
.else
#CONFIGURE_ARGS+= --with-lua=no
.endif
.if !empty(PKG_OPTIONS:Mhttp2)
.include "../../www/nghttp2/buildlink3.mk"
CMAKE_ARGS+= -DBUILD_wireshark=OFF
.endif

View File

@ -1,6 +1,7 @@
$NetBSD$
Do not make application bundle on Darwin.
Store correct version number in version.h.
Avoid
CMake Error at CMakeLists.txt:3021 (install):
install FILES given directory
@ -17,7 +18,18 @@ Avoid
#
# As https://developer.apple.com/library/archive/technotes/tn2206/_index.html
# says,
@@ -2229,7 +2229,11 @@ if(BUILD_wireshark AND QT_FOUND)
@@ -1462,9 +1462,7 @@ gmx_test_large_files(GMX_LARGEFILES)
set( VERSION ${PROJECT_VERSION} )
add_custom_target(version
BYPRODUCTS version.h
- COMMAND ${PERL_EXECUTABLE}
- ${CMAKE_SOURCE_DIR}/tools/make-version.pl
- ${CMAKE_SOURCE_DIR}
+ COMMAND ${CMAKE_COMMAND} -E echo '\#define VCSVERSION \"${VERSION}\"' > ${CMAKE_BINARY_DIR}/version.h
)
set_target_properties(version PROPERTIES FOLDER "Auxiliary")
@@ -2229,7 +2227,11 @@ if(BUILD_wireshark AND QT_FOUND)
$<$<BOOL:${WIN32}>:UxTheme.lib>
)
@ -30,7 +42,7 @@ Avoid
set(PROGLIST ${PROGLIST} wireshark)
set_target_properties(wireshark PROPERTIES
LINK_FLAGS "${WS_LINK_FLAGS}"
@@ -3022,11 +3026,11 @@ endif()
@@ -3022,11 +3024,11 @@ endif()
install(
FILES