gjs: Import gjs-1.66.1 as wip/gjs

gnome-shell-3.38 requires newer version of gjs
This commit is contained in:
Dan Cîrnaț 2020-11-08 19:22:53 +01:00
parent 3531d0a076
commit 9f6eadf629
6 changed files with 94 additions and 0 deletions

3
gjs/DESCR Normal file
View File

@ -0,0 +1,3 @@
Gjs is a Javascript binding for GNOME. It's mainly based on
Spidermonkey javascript engine and the GObject introspection
framework.

34
gjs/Makefile Normal file
View File

@ -0,0 +1,34 @@
# $NetBSD: Makefile,v 1.6 2020/11/05 17:12:00 nia Exp $
DISTNAME= gjs-1.66.1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gjs/${PKGVERSION_NOREV:R}/}
EXTRACT_SUFX= .tar.xz
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://live.gnome.org/Gjs
COMMENT= Javascript binding for GNOME based on Spidermonkey
LICENSE= mit
USE_TOOLS+= pkg-config
USE_LANGUAGES= c c++
MAKE_ENV+= LD_LIBRARY_PATH=${WRKSRC}/output/gjs@sha:${WRKSRC}/output/gjs-jsapi@sta:${WRKSRC}/output/gjs-console@exe
MESON_ARGS+= -Dinstalled_tests=false
MESON_ARGS+= -Dprofiler=disabled
PKGCONFIG_OVERRIDE+= output/meson-private/gjs-1.0.pc
PKGCONFIG_OVERRIDE_STAGE= post-configure
.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/gobject-introspection/buildlink3.mk"
.include "../../devel/libffi/buildlink3.mk"
.include "../../devel/meson/build.mk"
.include "../../graphics/cairo-gobject/buildlink3.mk"
.include "../../graphics/gdk-pixbuf2/buildlink3.mk"
.include "../../lang/python/extension.mk"
.include "../../wip/mozjs78/buildlink3.mk"
.include "../../sysutils/dbus-glib/buildlink3.mk"
.include "../../x11/gtk3/buildlink3.mk"
.include "../../mk/readline.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

17
gjs/PLIST Normal file
View File

@ -0,0 +1,17 @@
@comment $NetBSD: PLIST,v 1.2 2020/11/05 17:12:00 nia Exp $
bin/gjs
bin/gjs-console
include/gjs-1.0/gjs/context.h
include/gjs-1.0/gjs/coverage.h
include/gjs-1.0/gjs/error-types.h
include/gjs-1.0/gjs/gjs.h
include/gjs-1.0/gjs/macros.h
include/gjs-1.0/gjs/mem.h
include/gjs-1.0/gjs/profiler.h
lib/gjs/girepository-1.0/GjsPrivate-1.0.typelib
lib/libgjs.so
lib/libgjs.so.0
lib/libgjs.so.0.0.0
lib/pkgconfig/gjs-1.0.pc
share/gjs-1.0/lsan/lsan.supp
share/gjs-1.0/valgrind/gjs.supp

19
gjs/buildlink3.mk Normal file
View File

@ -0,0 +1,19 @@
# $NetBSD: buildlink3.mk,v 1.5 2020/11/05 17:14:45 wiz Exp $
BUILDLINK_TREE+= gjs
.if !defined(GJS_BUILDLINK3_MK)
GJS_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.gjs+= gjs>=1.53.4
BUILDLINK_ABI_DEPENDS.gjs?= gjs>=1.53.4nb3
BUILDLINK_PKGSRCDIR.gjs?= ../../wip/gjs
.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/gobject-introspection/buildlink3.mk"
.include "../../wip/mozjs78/buildlink3.mk"
.include "../../graphics/cairo-gobject/buildlink3.mk"
.include "../../sysutils/dbus-glib/buildlink3.mk"
.endif # GJS_BUILDLINK3_MK
BUILDLINK_TREE+= -gjs

7
gjs/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.4 2020/11/05 17:58:56 nia Exp $
SHA1 (gjs-1.66.1.tar.xz) = c03c2a7c8653e40464b160a5c8cd71c0cddab146
RMD160 (gjs-1.66.1.tar.xz) = cddea5febfe1e2c93eafc1e4bcaa3e2d6149619a
SHA512 (gjs-1.66.1.tar.xz) = 601d0c645ab1586e7d770f753bf68653816dc631faf89b5e70216320f6b7707e4aaa3507111fb6ff3331f76656050e32e8b1441720bf080de957e03e4565a43f
Size (gjs-1.66.1.tar.xz) = 439992 bytes
SHA1 (patch-gjs_jsapi-util.cpp) = 91b267616071bde63afb835d82859bd44a364da1

View File

@ -0,0 +1,14 @@
$NetBSD$
Fix va_list error
--- gjs/jsapi-util.cpp.orig 2020-10-08 22:26:17.390874100 +0000
+++ gjs/jsapi-util.cpp
@@ -26,6 +26,7 @@
#include <stdio.h> // for sscanf
#include <string.h> // for strlen
+#include <stdarg.h>
#ifdef _WIN32
# define WIN32_LEAN_AND_MEAN