Add freeserf.

A faithful clone of the brilliant simulation game The Settlers
(also known as Serf City: Life is Feudal).
This commit is contained in:
nia 2019-09-21 15:21:12 +01:00
parent d51ae96061
commit a2867ede4a
9 changed files with 115 additions and 0 deletions

View File

@ -876,6 +876,7 @@ SUBDIR+= freedup16
SUBDIR+= freefem++
SUBDIR+= freej
SUBDIR+= freerdp
SUBDIR+= freeserf
SUBDIR+= freeswitch-core
SUBDIR+= freeswitch-music
SUBDIR+= freesynd

2
freeserf/DESCR Normal file
View File

@ -0,0 +1,2 @@
A faithful clone of the brilliant simulation game The Settlers
(also known as Serf City: Life is Feudal).

19
freeserf/MESSAGE Normal file
View File

@ -0,0 +1,19 @@
===========================================================================
$NetBSD: MESSAGE,v 1.2 2018/10/15 17:53:23 nia Exp $
The original data files from the DOS or Amiga versions is required for the
game to function.
The name of the Amiga files are: gfxheader, gfxfast, gfxchip, gfxpics,
sounds, music.
The name of the DOS file is SPAE.PA, SPAD.PA, SPAF.PA, or SPAU.PA,
depending on the language.
It is very important that you copy the data after actually installing the
original game, otherwise the data file will be compressed. The DOS data
file will be about 1.3MB.
Place them in ${PREFIX}/share/freeserf or ~/.local/share/freeserf.
===========================================================================

52
freeserf/Makefile Normal file
View File

@ -0,0 +1,52 @@
# $NetBSD$
DISTNAME= freeserf-0.3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GITHUB:=freeserf/}
GITHUB_TAG= v${PKGVERSION_NOREV}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://jonls.dk/freeserf/
COMMENT= Settlers 1 (Serf City: Life is Feudal) clone
LICENSE= gnu-gpl-v3
USE_CMAKE= yes
USE_TOOLS+= pkg-config
USE_LANGUAGES= c c++11
# C++11
GCC_REQD+= 4.7
CMAKE_ARGS+= -DENABLE_TESTS=OFF
CMAKE_ARGS+= -DFREESERF_VERSION=${PKGVERSION}
SUBST_CLASSES+= prefix
SUBST_STAGE.prefix= pre-configure
SUBST_MESSAGE.prefix= Correcting path to PREFIX.
SUBST_FILES.prefix+= src/data.cc
SUBST_SED.prefix+= -e "s,/usr/local,${PREFIX},g"
PYTHON_FOR_BUILD_ONLY= tool
INSTALLATION_DIRS+= bin
INSTALLATION_DIRS+= share/applications
INSTALLATION_DIRS+= share/doc/freeserf
INSTALLATION_DIRS+= share/freeserf
INSTALLATION_DIRS+= share/pixmaps
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/FreeSerf \
${DESTDIR}${PREFIX}/bin/freeserf
${INSTALL_DATA} ${FILESDIR}/freeserf.desktop \
${DESTDIR}${PREFIX}/share/applications
${INSTALL_DATA} ${WRKSRC}/cmake/icon.png \
${DESTDIR}${PREFIX}/share/pixmaps/freeserf.png
cd ${WRKSRC} && ${INSTALL_DATA} README.md COPYING \
${DESTDIR}${PREFIX}/share/doc/freeserf
.include "../../audio/SDL2_mixer/buildlink3.mk"
.include "../../audio/libxmp/buildlink3.mk"
.include "../../devel/SDL2/buildlink3.mk"
.include "../../graphics/SDL2_image/buildlink3.mk"
.include "../../lang/python/tool.mk"
.include "../../mk/bsd.pkg.mk"

7
freeserf/PLIST Normal file
View File

@ -0,0 +1,7 @@
@comment $NetBSD$
bin/freeserf
share/applications/freeserf.desktop
share/doc/freeserf/COPYING
share/doc/freeserf/README.md
share/pixmaps/freeserf.png
@pkgdir share/freeserf

1
freeserf/TODO Normal file
View File

@ -0,0 +1 @@
Segfaults a lot. Wait for it to become more stable, probably.

7
freeserf/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (freeserf-0.3.tar.gz) = f8c9e038536b8dc4519104d8ce32ebf66b909830
RMD160 (freeserf-0.3.tar.gz) = 174287b4c95b26879c96d8a013c86e9a2871e4b0
SHA512 (freeserf-0.3.tar.gz) = fe7ef340d736990218d561316812031f58af9f258bab296f1cbd8de0d4c58610a4e8d8d11f490fc873a596cf49f7b203cfb51881c25717ce31fa7ba3eb0299b1
Size (freeserf-0.3.tar.gz) = 862188 bytes
SHA1 (patch-CMakeLists.txt) = 15d6fc895f72fe25aa5cedd2c38e24119c9a2e8c

View File

@ -0,0 +1,9 @@
[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=Freeserf
Comment=Settlers 1 (Serf City) clone
Icon=freeserf
Exec=FreeSerf
Terminal=false
Categories=Game;StrategyGame;

View File

@ -0,0 +1,17 @@
$NetBSD$
Don't try to use git to find the version.
--- CMakeLists.txt.orig 2019-01-20 08:58:53.000000000 +0000
+++ CMakeLists.txt
@@ -10,10 +10,6 @@ set_property(GLOBAL PROPERTY USE_FOLDERS
list(APPEND CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
-include(GitTools)
-git_make_version(FREESERF_VERSION ${CMAKE_CURRENT_SOURCE_DIR} ${PROJECT_VERSION})
-message(STATUS "FREESERF_VERSION = ${FREESERF_VERSION}")
-
if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
set(CMAKE_CXX_FLAGS "-std=gnu++11 ${CMAKE_CXX_FLAGS}")
elseif(CMAKE_CXX_COMPILER_ID STREQUAL "Clang")