scalapack: added package for parallel LAPACK

This commit is contained in:
Dr. Thomas Orgis 2020-11-12 13:52:12 +01:00
parent 8bc5285735
commit a2ef7c0df1
7 changed files with 5767 additions and 0 deletions

7
scalapack/DESCR Normal file
View File

@ -0,0 +1,7 @@
ScaLAPACK, or Scalable LAPACK, is a library of high performance linear
algebra routines for distributed memory computers supporting MPI.
The complete ScaLAPACK package is freely available on netlib and
can be obtained via the World Wide Web or anonymous ftp.
http://www.netlib.org/scalapack/

27
scalapack/Makefile Normal file
View File

@ -0,0 +1,27 @@
# $NetBSD$
DISTNAME= scalapack-2.1.0
CATEGORIES= math
MASTER_SITES= http://www.netlib.org/scalapack/
EXTRACT_SUFX= .tgz
MAINTAINER= thomas.orgis@uni-hamburg.de
HOMEPAGE= http://www.netlib.org/scalapack/
COMMENT= Scalable Linear Algebra PACKage
LICENSE= modified-bsd
USE_CMAKE= yes
USE_TOOLS+= pkg-config
USE_LANGUAGES= c fortran
CMAKE_ARGS= -DLAPACK_LIBRARIES=${LAPACK_LIBS:Q} \
-DBLAS_LIBRARIES=${BLAS_LIBS:Q} \
-DBUILD_SHARED_LIBS=ON \
-DBUILD_STATIC_LIBS=ON \
PKGCONFIG_OVERRIDE+= scalapack.pc.in
.include "../../mk/blas.buildlink3.mk"
.include "../../mk/mpi.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

8
scalapack/PLIST Normal file
View File

@ -0,0 +1,8 @@
@comment $NetBSD$
lib/cmake/${PKGNAME}/scalapack-config-version.cmake
lib/cmake/${PKGNAME}/scalapack-config.cmake
lib/cmake/${PKGNAME}/scalapack-targets-noconfig.cmake
lib/cmake/${PKGNAME}/scalapack-targets.cmake
lib/libscalapack.a
lib/libscalapack.so
lib/pkgconfig/scalapack.pc

9
scalapack/distinfo Normal file
View File

@ -0,0 +1,9 @@
$NetBSD$
SHA1 (scalapack-2.1.0.tgz) = 9dae1d4d49fe187583eec88e71770edb68e082b7
RMD160 (scalapack-2.1.0.tgz) = 4eee240e39bcfaad1c2a38657014e1a51b778340
SHA512 (scalapack-2.1.0.tgz) = 0e77fb535ebcc28e2d97499ef4bd5161f76ca0ba4a3e308c26ce5071cfc4be4f3814262f3fb38f378ce0b5b31c0913432fea00a1e9e3f7717b853d1182bdf5b4
Size (scalapack-2.1.0.tgz) = 5307441 bytes
SHA1 (patch-CMakeLists.txt) = a826593cfbc0fe2cfbb87d4dfc2b342c1a45d0d6
SHA1 (patch-gcc10fixfromgit) = a6ac951efdf93bfde597cf83ef75de8afb615d8c
SHA1 (patch-scalapack.pc.in) = 53dd2eeba58462e8788e92f4684d943357799361

View File

@ -0,0 +1,18 @@
$NetBSD$
This enables building both shared and static libs.
--- CMakeLists.txt.orig 2020-06-09 19:05:01.803103294 +0200
+++ CMakeLists.txt 2020-06-09 19:09:46.581054808 +0200
@@ -234,6 +234,11 @@
add_library(scalapack ${blacs} ${tools} ${tools-C} ${extra_lapack} ${pblas} ${pblas-F} ${ptzblas} ${ptools} ${pbblas} ${redist} ${src} ${src-C})
target_link_libraries( scalapack ${LAPACK_LIBRARIES} ${BLAS_LIBRARIES})
scalapack_install_library(scalapack)
+ if(BUILD_SHARED_LIBS AND BUILD_STATIC_LIBS)
+ add_library(scalapack_static STATIC ${blacs} ${tools} ${tools-C} ${extra_lapack} ${pblas} ${pblas-F} ${ptzblas} ${ptools} ${pbblas} ${redist} ${src} ${src-C})
+ set_target_properties(scalapack_static PROPERTIES OUTPUT_NAME scalapack)
+ scalapack_install_library(scalapack_static)
+ endif()
else (UNIX) # Need to separate Fortran and C Code
OPTION(BUILD_SHARED_LIBS "Build shared libraries" ON )
add_library(scalapack ${blacs} ${tools-C} ${pblas} ${ptools} ${redist} ${src-C})

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,13 @@
$NetBSD$
Do not assume fixed names for MPI and BLAS dependency pkg-config
packages. They can vary. Rather use provided libraries directly.
--- scalapack.pc.in.orig 2020-06-09 07:23:53.989672521 +0200
+++ scalapack.pc.in 2020-06-09 07:24:47.789286720 +0200
@@ -6,4 +6,4 @@
Version: @SCALAPACK_VERSION@
URL: http://www.netlib.org/scalapack/
Libs: -L${libdir} -lscalapack
-Requires: mpi lapack blas
+Libs.private: @MPI_LIBRARIES@ @BLAS_LIBRARIES@ @LAPACK_LIBRARIES@