glkterm: update to glkterm-1.0.4

* Version History

1.0.4:
    Updated the Blorb-resource functions to understand FORM chunks
    (Glk 0.7.4 amendment).
    Added stub for autosave/autorestore hooks. (This library does not
    support autosave, however.)

1.0.3:
    Added the Blorb-resource functions (Glk 0.7.4).
    External filenames now follow the new spec recommendations: standard
    filename suffixes, and removing more questionable characters in
    fileref_create_by_name().

1.0.2:
    Fixed a really stupid bug where glk_put_char_uni() was sending text
    to stdout instead of curses, thus destroying the screen.
    Fixed a bug with reading and writing to the same file without a
    reposition operation in between.
    In gi_dispa.c, fixed a notation that was preventing stream_open_memory
    and stream_open_memory_uni from accepting a null array argument.
    Fixed get_line_stream() to include the terminal null when reading
    from a Unicode stream.
    Added stubs for the improved sound functions (Glk 0.7.3).

1.0.1:
    Added the date-time functions (Glk 0.7.2).
    Fixed bugs in Unicode normalization and case-changing (thanks David
    Fletcher and David Kinder).

1.0.0:
    Support for all the Glk 0.7.1 features: window borders, line input
    terminator keys, line input echo control, Unicode normalization.
    Added glkunix_stream_open_pathname_gen(), a more general form of
    the pathname opening function in the startup code. (This is needed
    for profiling improvements.)

0.8.1:
    Fixed file-creation bug in glk_stream_open_file().
    Deleted long-obsolete check on the size of a pointer.
    Fixed a bug that could leave cruft in a grid window that was
    contracted and then expanded.

0.8.0:
    Upgraded to Glk API version 0.7.0; added the Unicode functions.
    (But the interface cannot yet print or read Unicode characters.)
This commit is contained in:
Yorick Hardy 2020-01-29 22:33:08 +02:00
parent a3e59b4ff4
commit aab58786b5
4 changed files with 20 additions and 20 deletions

View File

@ -1,18 +1,17 @@
# $NetBSD: Makefile,v 1.10 2012/12/12 10:44:37 thomasklausner Exp $
#
DISTNAME= glkterm-078
PKGNAME= glkterm-0.7.8
DISTNAME= glkterm-104
PKGNAME= glkterm-1.0.4
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_IFARCHIVE:=programming/glk/implementations/}
EXTRACT_SUFX= .tar.Z
MASTER_SITES= https://www.eblong.com/zarf/glk/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://www.eblong.com/zarf/glk/index.html
COMMENT= Curses port of Glk interface
# uses halfkey (present since 1.6M)
INCOMPAT_CURSES+= NetBSD-1.4[Y-Z]* NetBSD-1.5* NetBSD-1.6-* NetBSD-1.6.*
INCOMPAT_CURSES+= NetBSD-1.4[Y-Z]* NetBSD-1.5.* NetBSD-1.6-* NetBSD-1.6.*
INCOMPAT_CURSES+= NetBSD-1.6[A-L]*

View File

@ -17,7 +17,7 @@ buildlink-glkterm-hook:
${LN} -s Make.glkterm ${BUILDLINK_DIR}/include/glk/Make.glk
# uses halfkey (present since 1.6M)
INCOMPAT_CURSES+= NetBSD-1.4[Y-Z]* NetBSD-1.5* NetBSD-1.6-* NetBSD-1.6.*
INCOMPAT_CURSES+= NetBSD-1.4[Y-Z]* NetBSD-1.5.* NetBSD-1.6-* NetBSD-1.6.*
INCOMPAT_CURSES+= NetBSD-1.6[A-L]*
.include "../../devel/ncurses/buildlink3.mk"

View File

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.4 2005/03/07 15:25:29 dillo Exp $
SHA1 (glkterm-078.tar.Z) = 813bdd8e6c03ffc18ef3714edd5fcb52e0829e76
RMD160 (glkterm-078.tar.Z) = b96bf5fdc102cc35188bef5e1da316a85174c831
Size (glkterm-078.tar.Z) = 98911 bytes
SHA1 (patch-aa) = e2b04877cb645a54ff4a2daeb5743321d29c0d58
SHA1 (glkterm-104.tar.gz) = cf67bc8f93e6c71898f59e8083fc65622ed02d54
RMD160 (glkterm-104.tar.gz) = 21d77e00d49582d0398a6be6f11d3e7b1a5e9329
SHA512 (glkterm-104.tar.gz) = a8264f487128eb9ee06a9c97202ed7ee67573d06d0f764597788b3deb032a4de614d9ab06cc91f39aa5ab92760e4280a1962c7e3292c429202a40d35240bfcc7
Size (glkterm-104.tar.gz) = 123440 bytes
SHA1 (patch-aa) = 95bae3b908487e75d694fa98ba37c9a00e7f80f6

View File

@ -1,6 +1,6 @@
$NetBSD: patch-aa,v 1.3 2005/03/02 17:10:05 dillo Exp $
--- Makefile.orig Mon Dec 20 01:21:49 1999
--- Makefile.orig 2012-10-14 17:17:28.000000000 +0000
+++ Makefile
@@ -10,18 +10,19 @@
@ -27,18 +27,18 @@ $NetBSD: patch-aa,v 1.3 2005/03/02 17:10:05 dillo Exp $
GLKTERM_OBJS = \
main.o gtevent.o gtfref.o gtgestal.o gtinput.o \
@@ -35,9 +36,20 @@ GLKTERM_HEADERS = \
@@ -37,9 +38,20 @@ all: $(GLKLIB) Make.glkterm
all: $(GLKLIB) Make.glkterm
cgunicod.o: cgunigen.c
+install: all
+ ${LIBTOOL} --mode=install ${BSD_INSTALL_DATA} $(GLKLIB) ${PREFIX}/lib
+ ${BSD_INSTALL_DATA_DIR} ${GLKINCDIR}
+ ${BSD_INSTALL_DATA} gi_blorb.h ${GLKINCDIR}
+ ${BSD_INSTALL_DATA} gi_dispa.h ${GLKINCDIR}
+ ${BSD_INSTALL_DATA} glk.h ${GLKINCDIR}
+ ${BSD_INSTALL_DATA} glkstart.h ${GLKINCDIR}
+ ${BSD_INSTALL_DATA} Make.glkterm ${GLKINCDIR}
+ ${LIBTOOL} --mode=install ${BSD_INSTALL_LIB} $(GLKLIB) ${DESTDIR}${PREFIX}/lib
+ ${BSD_INSTALL_DATA_DIR} ${DESTDIR}${GLKINCDIR}
+ ${BSD_INSTALL_DATA} gi_blorb.h ${DESTDIR}${GLKINCDIR}
+ ${BSD_INSTALL_DATA} gi_dispa.h ${DESTDIR}${GLKINCDIR}
+ ${BSD_INSTALL_DATA} glk.h ${DESTDIR}${GLKINCDIR}
+ ${BSD_INSTALL_DATA} glkstart.h ${DESTDIR}${GLKINCDIR}
+ ${BSD_INSTALL_DATA} Make.glkterm ${DESTDIR}${GLKINCDIR}
+
+.c.o:
+ ${LIBTOOL} --mode=compile ${CC} ${CFLAGS} -c -o $@ $<