plasma-desktop: add more HAVE_X11 patches I had lingering around

This commit is contained in:
coypu 2019-05-01 20:14:42 +03:00
parent 7421e2943f
commit ab5774ec1f
3 changed files with 26 additions and 0 deletions

View File

@ -4,3 +4,5 @@ SHA1 (plasma-desktop-5.12.4.tar.xz) = 6fa92090acac258d1296cc715309d92c14a85b1f
RMD160 (plasma-desktop-5.12.4.tar.xz) = e1b1878dfbd509a0fd9be6786bf3ab1e2936738a
SHA512 (plasma-desktop-5.12.4.tar.xz) = 1aaecdddfd373512eaabea2c1c2e172c058b4aac52144feb14c8c0bc096db0e8242f7f712e228fc4f9188877e045cfd4d1e9890578234c61f6b408f8c3cfb660
Size (plasma-desktop-5.12.4.tar.xz) = 8532112 bytes
SHA1 (patch-CMakeLists.txt) = 706a7384a8ec64646585c80b7301ed989dad1533
SHA1 (patch-config-X11.h.cmake) = 57611149f2680a8d972eeeb5247e8227dc0a98b4

View File

@ -0,0 +1,13 @@
$NetBSD$
--- CMakeLists.txt.orig 2019-04-27 20:25:02.908207375 +0000
+++ CMakeLists.txt
@@ -138,6 +138,8 @@ if(${AppStreamQt_FOUND})
set(HAVE_APPSTREAMQT true)
endif()
+set(HAVE_X11 ${X11_FOUND})
+
include_directories("${CMAKE_CURRENT_BINARY_DIR}")
configure_file(config-workspace.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-workspace.h)

View File

@ -0,0 +1,11 @@
$NetBSD$
--- config-X11.h.cmake.orig 2018-03-27 11:21:06.000000000 +0000
+++ config-X11.h.cmake
@@ -41,4 +41,4 @@
#cmakedefine HAS_RANDR_1_3 1
/* Define if you have X11 at all */
-#define HAVE_X11 ${X11_FOUND}
\ No newline at end of file
+#cmakedefine01 HAVE_X11