d2x-rebirth: Get it working on NetBSD 8.99.27!

This commit is contained in:
Charlotte Koch 2019-03-04 23:10:54 -08:00
parent 310c101254
commit ae2d6774e4
2 changed files with 42 additions and 0 deletions

View File

@ -2,4 +2,6 @@ $NetBSD: distinfo,v 1.1 2015/08/19 19:11:02 yhardy Exp $
SHA1 (d2x-rebirth_v0.58.1-src.tar.gz) = 2f8576da0ab445a1cd79663996b06b8c53ebb5c1
RMD160 (d2x-rebirth_v0.58.1-src.tar.gz) = 0d5edf7becbe4114525d84fad33f5ae2e0fc21f4
SHA512 (d2x-rebirth_v0.58.1-src.tar.gz) = 19281c8dc554d595f6c40cbef2f4921c6325cd736ec648cb1abf60ad6a339e59b882b8a1426987f7bcfb8413c78bbda9b6f7fa86a6ff8927550a37d0290873fd
Size (d2x-rebirth_v0.58.1-src.tar.gz) = 1375376 bytes
SHA1 (patch-include_physfsrwops.h) = 31496ca6262412a3f62945086236fb863dd16af7

View File

@ -0,0 +1,40 @@
$NetBSD$
--- ./include/physfsrwops.h.orig 2019-03-04 22:58:02.523929348 -0800
+++ ./include/physfsrwops.h 2019-03-04 22:58:18.372226593 -0800
@@ -44,7 +44,7 @@
* @return A valid SDL_RWops structure on success, NULL on error. Specifics
* of the error can be gleaned from PHYSFS_getLastError().
*/
-__EXPORT__ SDL_RWops *PHYSFSRWOPS_openRead(const char *fname);
+SDL_RWops *PHYSFSRWOPS_openRead(const char *fname);
/**
* Open a platform-independent filename for writing, and make it accessible
@@ -56,7 +56,7 @@
* @return A valid SDL_RWops structure on success, NULL on error. Specifics
* of the error can be gleaned from PHYSFS_getLastError().
*/
-__EXPORT__ SDL_RWops *PHYSFSRWOPS_openWrite(const char *fname);
+SDL_RWops *PHYSFSRWOPS_openWrite(const char *fname);
/**
* Open a platform-independent filename for appending, and make it accessible
@@ -68,7 +68,7 @@
* @return A valid SDL_RWops structure on success, NULL on error. Specifics
* of the error can be gleaned from PHYSFS_getLastError().
*/
-__EXPORT__ SDL_RWops *PHYSFSRWOPS_openAppend(const char *fname);
+SDL_RWops *PHYSFSRWOPS_openAppend(const char *fname);
/**
* Make a SDL_RWops from an existing PhysicsFS file handle. You should
@@ -80,7 +80,7 @@
* @return A valid SDL_RWops structure on success, NULL on error. Specifics
* of the error can be gleaned from PHYSFS_getLastError().
*/
-__EXPORT__ SDL_RWops *PHYSFSRWOPS_makeRWops(PHYSFS_file *handle);
+SDL_RWops *PHYSFSRWOPS_makeRWops(PHYSFS_file *handle);
#ifdef __cplusplus
}