vsearch: Upgrade to 2.13.4

pkgsrc patches incorporated into new release
This commit is contained in:
Jason Bacon 2019-05-11 08:44:37 -05:00
parent e6d47db681
commit ae45544fb6
4 changed files with 5 additions and 94 deletions

View File

@ -1,6 +1,6 @@
# $NetBSD$
DISTNAME= vsearch-2.13.3
DISTNAME= vsearch-2.13.4
CATEGORIES= biology
MASTER_SITES= ${MASTER_SITE_GITHUB:=torognes/}
GITHUB_TAG= v${PKGVERSION_NOREV}

View File

@ -1,10 +1,8 @@
$NetBSD$
SHA1 (vsearch-2.13.3.tar.gz) = 064bfbef4271c254848f18b03bed7c41a15ae2ab
RMD160 (vsearch-2.13.3.tar.gz) = d8f00a88449fb827878b7e301f9127799ce3d43c
SHA512 (vsearch-2.13.3.tar.gz) = a3c539d60ed6db8bdb964a1aee18e79a6b8ed397dc01d47aad873019a8f123ed8892b08536dfd5f785f8d327fee75d42b4a744f354f5c6e3bb03d0bf10f054e5
Size (vsearch-2.13.3.tar.gz) = 233846 bytes
SHA1 (vsearch-2.13.4.tar.gz) = adb36075cf873620aebae6ab25f33cbac002065e
RMD160 (vsearch-2.13.4.tar.gz) = e65a908014cbab903bef81b55c9e67003bb55458
SHA512 (vsearch-2.13.4.tar.gz) = 31cc321f96309385414f3847a4cb29a5b3e43e42870b3f41e34fa0e6b3a928b2dd306edeff896ffa6bca85ecea776b33655611fa62749e9b29e86bf1adbe7de3
Size (vsearch-2.13.4.tar.gz) = 234364 bytes
SHA1 (patch-configure.ac) = 536a8565514cf9b43f4f8892d1cba0444f752c5e
SHA1 (patch-src_Makefile.am) = bcdd1bbe9f04197084825e2c3560ba27a750f124
SHA1 (patch-src_city.cc) = 3a5bcbca0a0c733a32a9d152189de10df3cb515f
SHA1 (patch-src_vsearch.h) = 26b8dc6ce0448e7463ee1c3ff73747ad07286543

View File

@ -1,20 +0,0 @@
$NetBSD$
# Portability
--- src/city.cc.orig 2019-04-30 11:57:32 UTC
+++ src/city.cc
@@ -60,6 +60,13 @@ static uint32 UNALIGNED_LOAD32(const char *p) {
#define bswap_32(x) OSSwapInt32(x)
#define bswap_64(x) OSSwapInt64(x)
+#elif defined(__FreeBSD__)
+
+#include <sys/endian.h>
+
+#define bswap_32(x) bswap32(x)
+#define bswap_64(x) bswap64(x)
+
#elif defined(__NetBSD__)
#include <sys/types.h>

View File

@ -1,67 +0,0 @@
$NetBSD$
# Add FreeBSD and NetBSD support
--- src/vsearch.h.orig 2019-04-30 11:57:32.000000000 +0000
+++ src/vsearch.h
@@ -138,30 +138,50 @@
#define bswap_32(x) _byteswap_ulong(x)
#define bswap_64(x) _byteswap_uint64(x)
-#else
-
-#ifdef __APPLE__
+#elif defined(__APPLE__)
#define PROG_OS "macos"
#include <sys/sysctl.h>
#include <libkern/OSByteOrder.h>
+#include <sys/resource.h>
#define bswap_16(x) OSSwapInt16(x)
#define bswap_32(x) OSSwapInt32(x)
#define bswap_64(x) OSSwapInt64(x)
-#else
+#elif defined(__linux__)
-#ifdef __linux__
#define PROG_OS "linux"
-#else
-#define PROG_OS "unknown"
-#endif
-
#include <sys/sysinfo.h>
#include <byteswap.h>
+#include <sys/resource.h>
-#endif
+#elif defined(__FreeBSD__)
+#define PROG_OS "freebsd"
+#include <sys/sysinfo.h>
+#include <sys/resource.h>
+#include <sys/endian.h>
+#define bswap_16(x) bswap16(x)
+#define bswap_32(x) bswap32(x)
+#define bswap_64(x) bswap64(x)
+
+#elif defined(__NetBSD__)
+
+#define PROG_OS "netbsd"
+#include <sys/resource.h>
+#include <sys/types.h>
+#include <machine/bswap.h>
+#define bswap_16(x) bswap16(x)
+#define bswap_32(x) bswap32(x)
+#define bswap_64(x) bswap64(x)
+// Alters behavior, but NetBSD 7 does not have getopt_long_only()
+#define getopt_long_only getopt_long
+
+#else // Other Unix
+
+#define PROG_OS "unknown"
+#include <sys/sysinfo.h>
+#include <byteswap.h>
#include <sys/resource.h>
#endif