Import multimail 0.51 as wip/multimail.

MultiMail is an offline mail packet reader, supporting the Blue Wave,
QWK, OMEN, SOUP and OPX formats. It uses a simple curses-based
interface.

SOUP is used for Internet email and Usenet. The other formats are
primarily used with dialup (or telnet) BBSes, to save connect time and
to provide a better interface to the message base.
This commit is contained in:
Frederic Cambus 2019-01-25 15:20:42 +01:00
parent 6103b1679d
commit ae9a7c4704
5 changed files with 85 additions and 0 deletions

7
multimail/DESCR Normal file
View File

@ -0,0 +1,7 @@
MultiMail is an offline mail packet reader, supporting the Blue Wave,
QWK, OMEN, SOUP and OPX formats. It uses a simple curses-based
interface.
SOUP is used for Internet email and Usenet. The other formats are
primarily used with dialup (or telnet) BBSes, to save connect time and
to provide a better interface to the message base.

19
multimail/Makefile Normal file
View File

@ -0,0 +1,19 @@
# $NetBSD$
DISTNAME= mmail-0.51
CATEGORIES= news
MASTER_SITES= https://downloads.sourceforge.net/project/multimail/MultiMail/0.51/
MAINTAINER= fred@statdns.com
HOMEPAGE= https://multimail.sourceforge.io/
COMMENT= Offline mail reader for Blue Wave, QWK, OMEN, SOUP and OPX
LICENSE= gnu-gpl-v3
USE_LANGUAGES= c++
USE_TOOLS+= gmake
AUTO_MKDIRS= yes
INSTALLATION_DIRS+= bin ${PKGMANDIR}/man1
.include "../../devel/ncursesw/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

4
multimail/PLIST Normal file
View File

@ -0,0 +1,4 @@
@comment $NetBSD$
bin/mm
man/man1/mm.1
man/man1/mmail.1

7
multimail/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (mmail-0.51.tar.gz) = eb16f372af41079da17b9f792008e90a5086ff24
RMD160 (mmail-0.51.tar.gz) = d64e3c31e48f32ac25e5922bf3fe48fdcd23d01d
SHA512 (mmail-0.51.tar.gz) = 8a7e0f450c204b927e9a01461abc51f5cd278d26d9110efc919dbe04d1b4c90c39dbd71f3ed5db186184070d5d25dcdc3cb1322edcc75dbd6117ecb400666072
Size (mmail-0.51.tar.gz) = 220574 bytes
SHA1 (patch-Makefile) = 69c9263c3ab799e155483aeade79573ae55cd758

View File

@ -0,0 +1,48 @@
$NetBSD$
Link against ncursesw and adapt install target for pkgsrc.
--- Makefile.orig 2018-03-29 09:26:02.000000000 +0000
+++ Makefile
@@ -18,7 +18,8 @@ endif
# PREFIX is the base directory under which to install the binary and man
# page; generally either /usr/local or /usr (or perhaps /opt...).
-PREFIX = /usr/local
+DESTDIR ?=
+PREFIX ?= /usr/local
#--------------------------------------------------------------
# Defaults are for the standard curses setup:
@@ -41,7 +42,7 @@ ifeq ($(OS),Windows_NT)
else
CURS_DIR = .
CURS_LIB = .
- LIBS = -lcurses
+ LIBS = -lncursesw
RM = rm -f
SEP = ;
E =
@@ -101,7 +102,7 @@ $(IOBJS) : %.o: $(isrc)/%.cc
$(CXX) $(CPPFLAGS) -c $<
mm$(E): $(MOBJS) $(IOBJS)
- $(CXX) -o mm$(E) $(MOBJS) $(IOBJS) -L$(CURS_LIB) $(LIBS)
+ $(CXX) -o mm$(E) $(MOBJS) $(IOBJS) -L$(CURS_LIB) $(LIBS) $(LDFLAGS)
$(POST)
dep:
@@ -113,9 +114,9 @@ clean:
$(RM) mm$(E)
install::
- install -c -s mm $(PREFIX)/bin
- install -c -m 644 mm.1 $(HELPDIR)
- $(RM) $(HELPDIR)/mmail.1
- ln $(HELPDIR)/mm.1 $(HELPDIR)/mmail.1
+ install -c -s mm $(DESTDIR)$(PREFIX)/bin
+ install -c -m 644 mm.1 $(DESTDIR)$(HELPDIR)
+ $(RM) $(DESTDIR)$(HELPDIR)/mmail.1
+ ln $(HELPDIR)/mm.1 $(DESTDIR)$(HELPDIR)/mmail.1
include depend