Add melonds.

TODO:

- Framerate limiting is broken
- Probably have to wait for this to become more stable
- Install .desktop and icon files
- Rename to melonDS...?

melonDS aims at providing fast and accurate Nintendo DS emulation. While it
is still a work in progress, it has a pretty solid set of features:

* Nearly complete core (CPU, video, audio, ...)
* OpenGL renderer, 3D upscaling
* RTC, microphone, lid close/open
* Joystick support
* Savestates
* Various display position/sizing/rotation modes
* (WIP) Wifi: local multiplayer, online connectivity
* and more are planned!
This commit is contained in:
nia 2019-08-09 11:41:17 +01:00
parent a42608a248
commit b5e46f0694
7 changed files with 82 additions and 0 deletions

View File

@ -2189,6 +2189,7 @@ SUBDIR+= meep-mpi
SUBDIR+= meep-openmpi
SUBDIR+= megaglest
SUBDIR+= meka-git
SUBDIR+= melonds
SUBDIR+= memdump
SUBDIR+= memgrep
SUBDIR+= menumaker

11
melonds/DESCR Normal file
View File

@ -0,0 +1,11 @@
melonDS aims at providing fast and accurate Nintendo DS emulation. While it
is still a work in progress, it has a pretty solid set of features:
* Nearly complete core (CPU, video, audio, ...)
* OpenGL renderer, 3D upscaling
* RTC, microphone, lid close/open
* Joystick support
* Savestates
* Various display position/sizing/rotation modes
* (WIP) Wifi: local multiplayer, online connectivity
* and more are planned!

24
melonds/Makefile Normal file
View File

@ -0,0 +1,24 @@
# $NetBSD$
DISTNAME= melonDS-0.8.2
PKGNAME= ${DISTNAME:S/DS/ds/}
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_GITHUB:=Arisotura/}
MAINTAINER= nia@NetBSD.org
HOMEPAGE= http://melonds.kuribo64.net/
COMMENT= Nintendo DS emulator, sorta
LICENSE= gnu-gpl-v3
USE_CMAKE= yes
USE_LANGUAGES= c c++11
# C++11
GCC_REQD+= 4.8
CMAKE_ARGS+= -DCMAKE_BUILD_TYPE="Release"
CMAKE_ARGS+= -DENABLE_LTO=OFF
.include "../../devel/SDL2/buildlink3.mk"
.include "../../x11/gtk3/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

2
melonds/PLIST Normal file
View File

@ -0,0 +1,2 @@
@comment $NetBSD$
bin/melonDS

4
melonds/TODO Normal file
View File

@ -0,0 +1,4 @@
- Framerate limiting is broken
- Probably have to wait for this to become more stable
- Install .desktop and icon files
- Rename to melonDS...?

7
melonds/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (melonDS-0.8.2.tar.gz) = 15451d8c6ffd6f060473782fc7b3fd89eebb2f03
RMD160 (melonDS-0.8.2.tar.gz) = 284f49cf100723302419e24b3a172763f9fb1411
SHA512 (melonDS-0.8.2.tar.gz) = 4c7e7bf2b78504b711235a8366a10e946a4c52d46e913ccf08dd7138adbda74a80af9dbc62645d4ba5b808861fbe3d30b32f9674a103a926410afb852c93ea34
Size (melonDS-0.8.2.tar.gz) = 964182 bytes
SHA1 (patch-src_libui__sdl_LAN__PCap.cpp) = 1fd806b6b446622e5d214091e96aac3d6eec8490

View File

@ -0,0 +1,33 @@
$NetBSD$
Support non-Linux.
--- src/libui_sdl/LAN_PCap.cpp.orig 2019-06-25 17:29:21.000000000 +0000
+++ src/libui_sdl/LAN_PCap.cpp
@@ -33,8 +33,10 @@
#include <sys/types.h>
#include <ifaddrs.h>
#include <netinet/in.h>
+#ifdef __linux__
#include <linux/if_packet.h>
#endif
+#endif
// welp
@@ -270,6 +272,7 @@ bool Init(bool open_adapter)
struct sockaddr_in* sa = (sockaddr_in*)curaddr->ifa_addr;
memcpy(adata->IP_v4, &sa->sin_addr, 4);
}
+#ifdef AF_PACKET
else if (af == AF_PACKET)
{
struct sockaddr_ll* sa = (sockaddr_ll*)curaddr->ifa_addr;
@@ -278,6 +281,7 @@ bool Init(bool open_adapter)
else
memcpy(adata->MAC, sa->sll_addr, 6);
}
+#endif
curaddr = curaddr->ifa_next;
}