wip/py-ioTPy: import py-ioTPy 1.1.0

This commit is contained in:
K.I.A.Derouiche 2020-10-25 11:31:49 +01:00
parent 11c5bd04c9
commit b950c23b4c
5 changed files with 261 additions and 0 deletions

2
py-ioTPy/DESCR Normal file
View File

@ -0,0 +1,2 @@
IoTPy is a Python package that helps you to build applications
that operate on streams of data.

19
py-ioTPy/Makefile Normal file
View File

@ -0,0 +1,19 @@
# $NetBSD$
VERS= 1.1.0
DISTNAME= IoTPy-${VERS}
PKGNAME= ${PYPKGPREFIX}-ioTPy-${VERS}
CATEGORIES= parallel python
MASTER_SITES= ${MASTER_SITE_PYPI:=I/${DISTNAME:S/${VERS}//}/}
MAINTAINER= kamelderouiche@yahoo.com
HOMEPAGE= https://github.com/AssembleSoftware/IoTPy
COMMENT= Helps you to build applications that operate on streams of data.
LICENSE= modified-bsd
PYTHON_VERSIONS_INCOMPATIBLE= 27
BUILDLINK_ABI_DEPENDS.py-numpy?= ${PYPKGPREFIX}-numpy>=1.19.2nb1
.include "../../math/py-numpy/buildlink3.mk"
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

212
py-ioTPy/PLIST Normal file
View File

@ -0,0 +1,212 @@
@comment $NetBSD$
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/IoTPy/__init__.py
${PYSITELIB}/IoTPy/__init__.pyc
${PYSITELIB}/IoTPy/__init__.pyo
${PYSITELIB}/IoTPy/_version.py
${PYSITELIB}/IoTPy/_version.pyc
${PYSITELIB}/IoTPy/_version.pyo
${PYSITELIB}/IoTPy/agent_types/__init__.py
${PYSITELIB}/IoTPy/agent_types/__init__.pyc
${PYSITELIB}/IoTPy/agent_types/__init__.pyo
${PYSITELIB}/IoTPy/agent_types/actuators_simple.py
${PYSITELIB}/IoTPy/agent_types/actuators_simple.pyc
${PYSITELIB}/IoTPy/agent_types/actuators_simple.pyo
${PYSITELIB}/IoTPy/agent_types/basics.py
${PYSITELIB}/IoTPy/agent_types/basics.pyc
${PYSITELIB}/IoTPy/agent_types/basics.pyo
${PYSITELIB}/IoTPy/agent_types/check_agent_parameter_types.py
${PYSITELIB}/IoTPy/agent_types/check_agent_parameter_types.pyc
${PYSITELIB}/IoTPy/agent_types/check_agent_parameter_types.pyo
${PYSITELIB}/IoTPy/agent_types/iot.py
${PYSITELIB}/IoTPy/agent_types/iot.pyc
${PYSITELIB}/IoTPy/agent_types/iot.pyo
${PYSITELIB}/IoTPy/agent_types/merge.py
${PYSITELIB}/IoTPy/agent_types/merge.pyc
${PYSITELIB}/IoTPy/agent_types/merge.pyo
${PYSITELIB}/IoTPy/agent_types/multi.py
${PYSITELIB}/IoTPy/agent_types/multi.pyc
${PYSITELIB}/IoTPy/agent_types/multi.pyo
${PYSITELIB}/IoTPy/agent_types/op.py
${PYSITELIB}/IoTPy/agent_types/op.pyc
${PYSITELIB}/IoTPy/agent_types/op.pyo
${PYSITELIB}/IoTPy/agent_types/sink.py
${PYSITELIB}/IoTPy/agent_types/sink.pyc
${PYSITELIB}/IoTPy/agent_types/sink.pyo
${PYSITELIB}/IoTPy/agent_types/sliding_window_with_startup.py
${PYSITELIB}/IoTPy/agent_types/sliding_window_with_startup.pyc
${PYSITELIB}/IoTPy/agent_types/sliding_window_with_startup.pyo
${PYSITELIB}/IoTPy/agent_types/source.py
${PYSITELIB}/IoTPy/agent_types/source.pyc
${PYSITELIB}/IoTPy/agent_types/source.pyo
${PYSITELIB}/IoTPy/agent_types/split.py
${PYSITELIB}/IoTPy/agent_types/split.pyc
${PYSITELIB}/IoTPy/agent_types/split.pyo
${PYSITELIB}/IoTPy/agent_types/timed_agent.py
${PYSITELIB}/IoTPy/agent_types/timed_agent.pyc
${PYSITELIB}/IoTPy/agent_types/timed_agent.pyo
${PYSITELIB}/IoTPy/concurrency/PikaPublisher.py
${PYSITELIB}/IoTPy/concurrency/PikaPublisher.pyc
${PYSITELIB}/IoTPy/concurrency/PikaPublisher.pyo
${PYSITELIB}/IoTPy/concurrency/PikaSubscriber.py
${PYSITELIB}/IoTPy/concurrency/PikaSubscriber.pyc
${PYSITELIB}/IoTPy/concurrency/PikaSubscriber.pyo
${PYSITELIB}/IoTPy/concurrency/__init__.py
${PYSITELIB}/IoTPy/concurrency/__init__.pyc
${PYSITELIB}/IoTPy/concurrency/__init__.pyo
${PYSITELIB}/IoTPy/concurrency/multicore.py
${PYSITELIB}/IoTPy/concurrency/multicore.pyc
${PYSITELIB}/IoTPy/concurrency/multicore.pyo
${PYSITELIB}/IoTPy/concurrency/multithread.py
${PYSITELIB}/IoTPy/concurrency/multithread.pyc
${PYSITELIB}/IoTPy/concurrency/multithread.pyo
${PYSITELIB}/IoTPy/concurrency/pika_publication_agent.py
${PYSITELIB}/IoTPy/concurrency/pika_publication_agent.pyc
${PYSITELIB}/IoTPy/concurrency/pika_publication_agent.pyo
${PYSITELIB}/IoTPy/concurrency/pika_subscribe_agent.py
${PYSITELIB}/IoTPy/concurrency/pika_subscribe_agent.pyc
${PYSITELIB}/IoTPy/concurrency/pika_subscribe_agent.pyo
${PYSITELIB}/IoTPy/concurrency/utils.py
${PYSITELIB}/IoTPy/concurrency/utils.pyc
${PYSITELIB}/IoTPy/concurrency/utils.pyo
${PYSITELIB}/IoTPy/core/__init__.py
${PYSITELIB}/IoTPy/core/__init__.pyc
${PYSITELIB}/IoTPy/core/__init__.pyo
${PYSITELIB}/IoTPy/core/agent.py
${PYSITELIB}/IoTPy/core/agent.pyc
${PYSITELIB}/IoTPy/core/agent.pyo
${PYSITELIB}/IoTPy/core/compute_engine.py
${PYSITELIB}/IoTPy/core/compute_engine.pyc
${PYSITELIB}/IoTPy/core/compute_engine.pyo
${PYSITELIB}/IoTPy/core/helper_control.py
${PYSITELIB}/IoTPy/core/helper_control.pyc
${PYSITELIB}/IoTPy/core/helper_control.pyo
${PYSITELIB}/IoTPy/core/stream.py
${PYSITELIB}/IoTPy/core/stream.pyc
${PYSITELIB}/IoTPy/core/stream.pyo
${PYSITELIB}/IoTPy/core/system_parameters.py
${PYSITELIB}/IoTPy/core/system_parameters.pyc
${PYSITELIB}/IoTPy/core/system_parameters.pyo
${PYSITELIB}/IoTPy/helper_functions/Buffer.py
${PYSITELIB}/IoTPy/helper_functions/Buffer.pyc
${PYSITELIB}/IoTPy/helper_functions/Buffer.pyo
${PYSITELIB}/IoTPy/helper_functions/__init__.py
${PYSITELIB}/IoTPy/helper_functions/__init__.pyc
${PYSITELIB}/IoTPy/helper_functions/__init__.pyo
${PYSITELIB}/IoTPy/helper_functions/incremental_buffer.py
${PYSITELIB}/IoTPy/helper_functions/incremental_buffer.pyc
${PYSITELIB}/IoTPy/helper_functions/incremental_buffer.pyo
${PYSITELIB}/IoTPy/helper_functions/json_to_csv.py
${PYSITELIB}/IoTPy/helper_functions/json_to_csv.pyc
${PYSITELIB}/IoTPy/helper_functions/json_to_csv.pyo
${PYSITELIB}/IoTPy/helper_functions/print_stream.py
${PYSITELIB}/IoTPy/helper_functions/print_stream.pyc
${PYSITELIB}/IoTPy/helper_functions/print_stream.pyo
${PYSITELIB}/IoTPy/helper_functions/recent_values.py
${PYSITELIB}/IoTPy/helper_functions/recent_values.pyc
${PYSITELIB}/IoTPy/helper_functions/recent_values.pyo
${PYSITELIB}/IoTPy/helper_functions/type.py
${PYSITELIB}/IoTPy/helper_functions/type.pyc
${PYSITELIB}/IoTPy/helper_functions/type.pyo
${PYSITELIB}/tests/__init__.py
${PYSITELIB}/tests/__init__.pyc
${PYSITELIB}/tests/__init__.pyo
${PYSITELIB}/tests/agent_types/__init__.py
${PYSITELIB}/tests/agent_types/__init__.pyc
${PYSITELIB}/tests/agent_types/__init__.pyo
${PYSITELIB}/tests/agent_types/agent_types_test.py
${PYSITELIB}/tests/agent_types/agent_types_test.pyc
${PYSITELIB}/tests/agent_types/agent_types_test.pyo
${PYSITELIB}/tests/agent_types/test_agent.py
${PYSITELIB}/tests/agent_types/test_agent.pyc
${PYSITELIB}/tests/agent_types/test_agent.pyo
${PYSITELIB}/tests/agent_types/test_basics.py
${PYSITELIB}/tests/agent_types/test_basics.pyc
${PYSITELIB}/tests/agent_types/test_basics.pyo
${PYSITELIB}/tests/agent_types/test_element.py
${PYSITELIB}/tests/agent_types/test_element.pyc
${PYSITELIB}/tests/agent_types/test_element.pyo
${PYSITELIB}/tests/agent_types/test_iot.py
${PYSITELIB}/tests/agent_types/test_iot.pyc
${PYSITELIB}/tests/agent_types/test_iot.pyo
${PYSITELIB}/tests/agent_types/test_list.py
${PYSITELIB}/tests/agent_types/test_list.pyc
${PYSITELIB}/tests/agent_types/test_list.pyo
${PYSITELIB}/tests/agent_types/test_merge.py
${PYSITELIB}/tests/agent_types/test_merge.pyc
${PYSITELIB}/tests/agent_types/test_merge.pyo
${PYSITELIB}/tests/agent_types/test_multi.py
${PYSITELIB}/tests/agent_types/test_multi.pyc
${PYSITELIB}/tests/agent_types/test_multi.pyo
${PYSITELIB}/tests/agent_types/test_shared_variables.py
${PYSITELIB}/tests/agent_types/test_shared_variables.pyc
${PYSITELIB}/tests/agent_types/test_shared_variables.pyo
${PYSITELIB}/tests/agent_types/test_sink.py
${PYSITELIB}/tests/agent_types/test_sink.pyc
${PYSITELIB}/tests/agent_types/test_sink.pyo
${PYSITELIB}/tests/agent_types/test_sliding_window_with_startup.py
${PYSITELIB}/tests/agent_types/test_sliding_window_with_startup.pyc
${PYSITELIB}/tests/agent_types/test_sliding_window_with_startup.pyo
${PYSITELIB}/tests/agent_types/test_split.py
${PYSITELIB}/tests/agent_types/test_split.pyc
${PYSITELIB}/tests/agent_types/test_split.pyo
${PYSITELIB}/tests/agent_types/test_timed_agent.py
${PYSITELIB}/tests/agent_types/test_timed_agent.pyc
${PYSITELIB}/tests/agent_types/test_timed_agent.pyo
${PYSITELIB}/tests/agent_types/test_window.py
${PYSITELIB}/tests/agent_types/test_window.pyc
${PYSITELIB}/tests/agent_types/test_window.pyo
${PYSITELIB}/tests/concurrency/__init__.py
${PYSITELIB}/tests/concurrency/__init__.pyc
${PYSITELIB}/tests/concurrency/__init__.pyo
${PYSITELIB}/tests/concurrency/test_lock.py
${PYSITELIB}/tests/concurrency/test_lock.pyc
${PYSITELIB}/tests/concurrency/test_lock.pyo
${PYSITELIB}/tests/concurrency/test_multicore.py
${PYSITELIB}/tests/concurrency/test_multicore.pyc
${PYSITELIB}/tests/concurrency/test_multicore.pyo
${PYSITELIB}/tests/concurrency/test_multicore37.py
${PYSITELIB}/tests/concurrency/test_multicore37.pyc
${PYSITELIB}/tests/concurrency/test_multicore37.pyo
${PYSITELIB}/tests/concurrency/test_multithread.py
${PYSITELIB}/tests/concurrency/test_multithread.pyc
${PYSITELIB}/tests/concurrency/test_multithread.pyo
${PYSITELIB}/tests/distributed/CloudAMQP_test.py
${PYSITELIB}/tests/distributed/CloudAMQP_test.pyc
${PYSITELIB}/tests/distributed/CloudAMQP_test.pyo
${PYSITELIB}/tests/distributed/__init__.py
${PYSITELIB}/tests/distributed/__init__.pyc
${PYSITELIB}/tests/distributed/__init__.pyo
${PYSITELIB}/tests/distributed/emit_log_direct.py
${PYSITELIB}/tests/distributed/emit_log_direct.pyc
${PYSITELIB}/tests/distributed/emit_log_direct.pyo
${PYSITELIB}/tests/distributed/pika_publisher_test.py
${PYSITELIB}/tests/distributed/pika_publisher_test.pyc
${PYSITELIB}/tests/distributed/pika_publisher_test.pyo
${PYSITELIB}/tests/distributed/pika_subscriber_test.py
${PYSITELIB}/tests/distributed/pika_subscriber_test.pyc
${PYSITELIB}/tests/distributed/pika_subscriber_test.pyo
${PYSITELIB}/tests/distributed/pika_test.py
${PYSITELIB}/tests/distributed/pika_test.pyc
${PYSITELIB}/tests/distributed/pika_test.pyo
${PYSITELIB}/tests/distributed/receive_log_direct.py
${PYSITELIB}/tests/distributed/receive_log_direct.pyc
${PYSITELIB}/tests/distributed/receive_log_direct.pyo
${PYSITELIB}/tests/distributed/socket_client.py
${PYSITELIB}/tests/distributed/socket_client.pyc
${PYSITELIB}/tests/distributed/socket_client.pyo
${PYSITELIB}/tests/distributed/socket_server.py
${PYSITELIB}/tests/distributed/socket_server.pyc
${PYSITELIB}/tests/distributed/socket_server.pyo
${PYSITELIB}/tests/stream/__init__.py
${PYSITELIB}/tests/stream/__init__.pyc
${PYSITELIB}/tests/stream/__init__.pyo
${PYSITELIB}/tests/stream/test_stream.py
${PYSITELIB}/tests/stream/test_stream.pyc
${PYSITELIB}/tests/stream/test_stream.pyo
${PYSITELIB}/tests/stream/test_stream_size.py
${PYSITELIB}/tests/stream/test_stream_size.pyc
${PYSITELIB}/tests/stream/test_stream_size.pyo

7
py-ioTPy/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (IoTPy-1.1.0.tar.gz) = 2a0e1b837de0450af2b4d9c663f728d1f251869f
RMD160 (IoTPy-1.1.0.tar.gz) = 538986b0230b4e551a41422dcdf9853882380372
SHA512 (IoTPy-1.1.0.tar.gz) = 99715b1631efe3508194d332cb96afd2d3c8c3404be0e19a4e99c7e6fa3a269f1a16bb70055cd54cd5071595fb68fea8ba17cf3449dbb0574831c365fb45a826
Size (IoTPy-1.1.0.tar.gz) = 111230 bytes
SHA1 (patch-setup.py) = 6357c6cbfb66ed041ea1ea01448d3ff10673ac8a

View File

@ -0,0 +1,21 @@
$NetBSD$
--- setup.py.orig 2020-07-11 20:59:04.000000000 +0000
+++ setup.py
@@ -4,9 +4,6 @@ import os
with open("README.md", "r") as fh:
long_description = fh.read()
-with open("requirements.txt") as f:
- REQ = f.read().splitlines()
-
# get __version__ from _version.py
ver_file = os.path.join('IoTPy', '_version.py')
with open(ver_file) as f:
@@ -40,6 +37,5 @@ setup(
url="https://github.com/AssembleSoftware/IoTPy",
classifiers= CLASSIFIERS,
packages = find_packages(),
- install_requires = REQ
)