gnome-shell: Fix wip/gnome-shell build on NetBSD

Disable extension app and tools
Remove usage of uselocale() - time string translation
This commit is contained in:
Dan Cîrnaț 2020-06-20 19:40:25 +02:00
parent f8ab5b0d33
commit bfc60f6ea2
4 changed files with 29 additions and 14 deletions

View File

@ -1,6 +1,7 @@
# $NetBSD$
DISTNAME= gnome-shell-3.36.3
PKGREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gnome-shell/3.36/}
EXTRACT_SUFX= .tar.xz
@ -18,6 +19,8 @@ USE_LANGUAGES= c
MESON_ARGS+= -Dnetworkmanager=false
MESON_ARGS+= -Dsystemd=false
MESON_ARGS+= -Dextensions_app=false
MESON_ARGS+= -Dextensions_tool=false
TOOL_DEPENDS+= sassc>=3.6:../../www/sassc
TOOL_DEPENDS+= asciidoc-[0-9]*:../../textproc/asciidoc
@ -25,6 +28,10 @@ TOOL_DEPENDS+= gdbus-codegen>=2.64:../../devel/gdbus-codegen
MAKE_ENV+= LD_LIBRARY_PATH=${WRKSRC}/output/subprojects/gvc
REPLACE_PYTHON+= meson/*.py
.include "../../graphics/librsvg/buildlink3.mk"
.include "../../lang/python/application.mk"
.include "../../textproc/json-glib/buildlink3.mk"
.include "../../devel/gobject-introspection/buildlink3.mk"
.include "../../wip/gnome-autoar/buildlink3.mk"

View File

@ -1,9 +1,6 @@
@comment $NetBSD$
bin/gnome-extensions
bin/gnome-extensions-app
bin/gnome-shell
bin/gnome-shell-extension-prefs
bin/gnome-shell-extension-tool
bin/gnome-shell-perf-tool
etc/xdg/autostart/gnome-shell-overrides-migration.desktop
lib/gnome-shell/Gvc-1.0.typelib
@ -19,11 +16,9 @@ libexec/gnome-shell-calendar-server
libexec/gnome-shell-hotplug-sniffer
libexec/gnome-shell-overrides-migration.sh
libexec/gnome-shell-perf-helper
man/man1/gnome-extensions.1
man/man1/gnome-shell.1
share/GConf/gsettings/gnome-shell-overrides.convert
share/applications/evolution-calendar.desktop
share/applications/org.gnome.Extensions.desktop
share/applications/org.gnome.Shell.Extensions.desktop
share/applications/org.gnome.Shell.desktop
share/dbus-1/interfaces/org.gnome.Shell.Extensions.xml
@ -33,7 +28,6 @@ share/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
share/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
share/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
share/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
share/dbus-1/services/org.gnome.Extensions.service
share/dbus-1/services/org.gnome.Shell.CalendarServer.service
share/dbus-1/services/org.gnome.Shell.Extensions.service
share/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
@ -48,18 +42,12 @@ share/gnome-shell/gir-1.0/Shew-0.gir
share/gnome-shell/gnome-shell-dbus-interfaces.gresource
share/gnome-shell/gnome-shell-osk-layouts.gresource
share/gnome-shell/gnome-shell-theme.gresource
share/gnome-shell/org.gnome.Extensions
share/gnome-shell/org.gnome.Extensions.data.gresource
share/gnome-shell/org.gnome.Extensions.src.gresource
share/gnome-shell/org.gnome.Shell.Extensions
share/gnome-shell/org.gnome.Shell.Extensions.src.gresource
share/gnome-shell/org.gnome.Shell.Notifications
share/gnome-shell/org.gnome.Shell.Notifications.src.gresource
share/gnome-shell/perf-background.xml
share/icons/hicolor/scalable/apps/org.gnome.Extensions.Devel.svg
share/icons/hicolor/scalable/apps/org.gnome.Extensions.svg
share/icons/hicolor/scalable/apps/org.gnome.Shell.Extensions.svg
share/icons/hicolor/symbolic/apps/org.gnome.Extensions-symbolic.svg
share/icons/hicolor/symbolic/apps/org.gnome.Shell.Extensions-symbolic.svg
share/locale/af/LC_MESSAGES/gnome-shell.mo
share/locale/an/LC_MESSAGES/gnome-shell.mo
@ -143,5 +131,4 @@ share/locale/vi/LC_MESSAGES/gnome-shell.mo
share/locale/zh_CN/LC_MESSAGES/gnome-shell.mo
share/locale/zh_HK/LC_MESSAGES/gnome-shell.mo
share/locale/zh_TW/LC_MESSAGES/gnome-shell.mo
share/metainfo/org.gnome.Extensions.metainfo.xml
share/xdg-desktop-portal/portals/gnome-shell.portal

View File

@ -4,4 +4,4 @@ SHA1 (gnome-shell-3.36.3.tar.xz) = 8b4447a3ab5a377d5e22991466ce1735bdb24e96
RMD160 (gnome-shell-3.36.3.tar.xz) = 5b70e47cb5b2b80266db480928796baa6e63c735
SHA512 (gnome-shell-3.36.3.tar.xz) = 3558ba9ac02148a064a25e498fb8e639edcc118639a10220d2c8f44cbe1975299c6e35e9f32703dfc5f9e27c9fc414915d1527c98d9800bd0ba66b5d7b53b78a
Size (gnome-shell-3.36.3.tar.xz) = 1771764 bytes
SHA1 (patch-meson.build) = 8ed1c13dd2764cc924d7f99f3ff4611153983343
SHA1 (patch-src_shell-util.c) = 830dd5dec94775b64aeaed1738da2384f19c6ec7

View File

@ -0,0 +1,21 @@
$NetBSD$
Quick ugly fix, breaks time string translation/format
--- src/shell-util.c.orig 2020-06-02 23:41:06.254288000 +0000
+++ src/shell-util.c
@@ -212,12 +212,12 @@ shell_util_translate_time_string (const
if (locale)
loc = newlocale (LC_MESSAGES_MASK, locale, (locale_t) 0);
- old_loc = uselocale (loc);
+ //old_loc = uselocale (loc);
sep = strchr (str, '\004');
res = g_dpgettext (NULL, str, sep ? sep - str + 1 : 0);
- uselocale (old_loc);
+ //uselocale (old_loc);
if (loc != (locale_t) 0)
freelocale (loc);