ruby-ghi: Import ruby-ghi-1.2.0 as wip/ruby-ghi

GitHub Issues on the command line. Use your $EDITOR, not your browser.
This commit is contained in:
Leonardo Taccari 2017-08-24 13:18:57 +02:00
parent 6db6d93039
commit c233de49cc
8 changed files with 74 additions and 0 deletions

View File

@ -3954,6 +3954,7 @@ SUBDIR+= ruby-chawan
SUBDIR+= ruby-delegate_it
SUBDIR+= ruby-diaspora
SUBDIR+= ruby-ditz
SUBDIR+= ruby-ghi
SUBDIR+= ruby-git
SUBDIR+= ruby-git_stats
SUBDIR+= ruby-iesd

1
ruby-ghi/ALTERNATIVES Normal file
View File

@ -0,0 +1 @@
bin/ghi @PREFIX@/bin/unicorn@RUBY_SUFFIX@

1
ruby-ghi/DESCR Normal file
View File

@ -0,0 +1 @@
GitHub Issues on the command line. Use your $EDITOR, not your browser.

19
ruby-ghi/Makefile Normal file
View File

@ -0,0 +1,19 @@
# $NetBSD$
#
DISTNAME= ghi-1.2.0
CATEGORIES= net ruby
MASTER_SITES= ${MASTER_SITE_RUBYGEMS}
EXTRACT_SUFX= .gem
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/stephencelis/ghi
COMMENT= GitHub Issues on the command line
LICENSE= mit
DEPENDS+= ${RUBY_PKGPREFIX}-pygments.rb-[0-9]*:../../www/ruby-pygments.rb
RUBYGEM_OPTIONS+= --format-executable
.include "../../lang/ruby/gem.mk"
.include "../../mk/bsd.pkg.mk"

29
ruby-ghi/PLIST Normal file
View File

@ -0,0 +1,29 @@
@comment $NetBSD$
bin/ghi${RUBY_SUFFIX}
${GEM_HOME}/cache/${GEM_NAME}.gem
${GEM_LIBDIR}/bin/ghi
${GEM_LIBDIR}/lib/ghi.rb
${GEM_LIBDIR}/lib/ghi/authorization.rb
${GEM_LIBDIR}/lib/ghi/client.rb
${GEM_LIBDIR}/lib/ghi/commands.rb
${GEM_LIBDIR}/lib/ghi/commands/assign.rb
${GEM_LIBDIR}/lib/ghi/commands/close.rb
${GEM_LIBDIR}/lib/ghi/commands/command.rb
${GEM_LIBDIR}/lib/ghi/commands/comment.rb
${GEM_LIBDIR}/lib/ghi/commands/config.rb
${GEM_LIBDIR}/lib/ghi/commands/disable.rb
${GEM_LIBDIR}/lib/ghi/commands/edit.rb
${GEM_LIBDIR}/lib/ghi/commands/enable.rb
${GEM_LIBDIR}/lib/ghi/commands/help.rb
${GEM_LIBDIR}/lib/ghi/commands/label.rb
${GEM_LIBDIR}/lib/ghi/commands/list.rb
${GEM_LIBDIR}/lib/ghi/commands/milestone.rb
${GEM_LIBDIR}/lib/ghi/commands/open.rb
${GEM_LIBDIR}/lib/ghi/commands/show.rb
${GEM_LIBDIR}/lib/ghi/commands/status.rb
${GEM_LIBDIR}/lib/ghi/commands/version.rb
${GEM_LIBDIR}/lib/ghi/editor.rb
${GEM_LIBDIR}/lib/ghi/formatting.rb
${GEM_LIBDIR}/lib/ghi/formatting/colors.rb
${GEM_LIBDIR}/lib/ghi/web.rb
${GEM_HOME}/specifications/${GEM_NAME}.gemspec

2
ruby-ghi/TODO Normal file
View File

@ -0,0 +1,2 @@
- Review that patches/patch-lib_ghi_client.rb actually DTRT (i.e. honor and
verify SSL certs instead of just ignoring them)

7
ruby-ghi/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (ghi-1.2.0.gem) = bf9b7ce75aad0597ba35f1a8baccd73dde50fed9
RMD160 (ghi-1.2.0.gem) = 361f42d6c3e211c496cc80c7c0a41d015a4daeb2
SHA512 (ghi-1.2.0.gem) = eac43e4fe5c7fc8c3f39ee621ebae53944ac021d7b2e1addac26fd9085384ede40d8daf14ccf9a8aea36ab3c5fb8861c3c49a34ac1008d0972f484eb6e9de9e5
Size (ghi-1.2.0.gem) = 27136 bytes
SHA1 (patch-lib_ghi_client.rb) = 2b596f815efa579c371dd2d596b292ac69f03da5

View File

@ -0,0 +1,14 @@
$NetBSD$
Verify SSL certificates.
--- lib/ghi/client.rb.orig 2017-08-21 21:04:43.607885825 +0000
+++ lib/ghi/client.rb
@@ -125,7 +125,6 @@ module GHI
end
http.use_ssl = true
- http.verify_mode = OpenSSL::SSL::VERIFY_NONE # FIXME 1.8.7
GHI.v? and puts "\r===> #{method.to_s.upcase} #{path} #{req.body}"
res = http.start { http.request req }