linphone: clean up

Update configure arguments a bit.
Remove empty patches.
Needs belle-sip instead of osip, but that doesn't build.
This commit is contained in:
Thomas Klausner 2020-04-15 10:15:55 +02:00
parent 8f559baade
commit c356f439f7
6 changed files with 39 additions and 25 deletions

View File

@ -15,11 +15,6 @@ USE_LANGUAGES= c c++
USE_LIBTOOL= YES
USE_PKGLOCALEDIR= yes
CONFIGURE_ARGS+= --with-osip=${BUILDLINK_PREFIX.libosip2}
CONFIGURE_ARGS+= --with-speex=${BUILDLINK_PREFIX.speex}
CONFIGURE_ARGS+= --with-html-dir=${PREFIX}/share/doc/linphone
CONFIGURE_ARGS+= --disable-manual --enable-glib
# don't treat warnings as errors, code is not portable enough (3.4.2)
BUILDLINK_TRANSFORM+= rm:-Werror
@ -31,13 +26,13 @@ BUILDLINK_TRANSFORM+= rm:-Werror
CONFIGURE_ARGS+= --enable-macsnd
. if !empty(PKGSRC_COMPILER:Mgcc*)
SUBST_CLASSES+= objective-c
SUBST_STAGE.objective-c= post-patch
SUBST_STAGE.objective-c= pre-configure
SUBST_MESSAGE.objective-c= adding "-x objective-c" for mediastreamer2 code
SUBST_FILES.objective-c= mediastreamer2/src/Makefile.in
SUBST_SED.objective-c= -e 's/^CC = @CC@/CC = @CC@ -x objective-c/g'
. endif
SUBST_CLASSES+= frameworks
SUBST_STAGE.frameworks= post-patch
SUBST_STAGE.frameworks= pre-configure
SUBST_MESSAGE.frameworks= adding Carbon and AudioUnit frameworks
SUBST_FILES.frameworks= mediastreamer2/configure
SUBST_SED.frameworks= -e 's/-framework CoreFoundation -framework AudioToolbox -framework CoreAudio/-framework Carbon -framework AudioToolbox -framework AudioUnit/g'
@ -51,9 +46,8 @@ CPPFLAGS+= -DDSP_NAME="\"${DEVOSSAUDIO}\""
.include "../../audio/speex/buildlink3.mk"
.include "../../audio/speexdsp/buildlink3.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/libosip/buildlink3.mk"
.include "../../devel/ncurses/buildlink3.mk"
.include "../../devel/readline/buildlink3.mk"
.include "../../wip/belle-sip/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../net/libexosip/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -6,6 +6,4 @@ SHA512 (linphone-3.9.1.tar.gz) = 1824ef0012995985788b2a14dc886c82a05a6ad547d60be
Size (linphone-3.9.1.tar.gz) = 13443595 bytes
SHA1 (patch-aa) = d27f9fe2c7f86fbf30e9a8a76b8c2c23f001b331
SHA1 (patch-ab) = fd1174da58b5610b6c92cae784f4623aaa03c71c
SHA1 (patch-ac) = adc83b19e793491b1c6ea0fd8b46cd9f32e592fc
SHA1 (patch-ae) = adc83b19e793491b1c6ea0fd8b46cd9f32e592fc
SHA1 (patch-configure) = b7513bb52da1e7ee7c2f9d70d4b377b3e162c776
SHA1 (patch-configure) = 47bdab8b59e2b0329963d552c45750cc8a46c9cb

View File

@ -10,15 +10,14 @@ PKG_SUGGESTED_OPTIONS= inet6 linphone-gui linphone-video gsm
CONFIGURE_ARGS+= --enable-alsa
.endif
.if empty(PKG_OPTIONS:Mlinphone-gui)
CONFIGURE_ARGS+= --enable-gnome_ui=no
.if !empty(PKG_OPTIONS:Mlinphone-gui)
PLIST_SUBST+= GUI=
CONFIGURE_ARGS+= --enable-gtk_ui=yes
.include "../../x11/gtk2/buildlink3.mk"
.include "../../devel/libglade/buildlink3.mk"
PLIST_SUBST+= GUI="@comment "
.else
PLIST_SUBST+= GUI=
CONFIGURE_ARGS+= --enable-gnome_ui=yes
.include "../../x11/gnome-panel/buildlink3.mk"
CONFIGURE_ARGS+= --enable-gtk_ui=no
.endif
.if empty(PKG_OPTIONS:Mlinphone-gui) || empty(PKG_OPTIONS:Mlinphone-video)
@ -31,10 +30,6 @@ CONFIGURE_ARGS+= --enable-video=yes
.if !empty(PKG_OPTIONS:Mgsm)
.include "../../audio/gsm/buildlink3.mk"
SUBST_CLASSES+= gsm
SUBST_STAGE.gsm= post-patch
SUBST_FILES.gsm= mediastreamer2/src/gsm.c mediastreamer2/configure
SUBST_SED.gsm= -e 's,gsm/gsm.h,gsm.h,g'
.endif
.if !empty(PKG_OPTIONS:Minet6)

View File

@ -1,2 +0,0 @@
$NetBSD: patch-ac,v 1.7 2012/04/13 20:02:17 gschwarz Exp $

View File

@ -1,2 +0,0 @@
$NetBSD: patch-ae,v 1.9 2012/04/13 20:02:17 gschwarz Exp $

View File

@ -0,0 +1,31 @@
$NetBSD$
--- configure.orig 2015-11-16 12:44:15.066306748 +0000
+++ configure
@@ -17316,7 +17316,7 @@ fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: Enable library dependencies linking: $enable_interlib_deps" >&5
$as_echo "$as_me: Enable library dependencies linking: $enable_interlib_deps" >&6;}
-if test "${enable_deplibs_linking}" == "yes"; then
+if test "${enable_deplibs_linking}" = "yes"; then
link_all_deplibs=yes
link_all_deplibs_CXX=yes
else
@@ -19609,7 +19609,7 @@ fi
# Put the nasty error message in config.log where it belongs
echo "$LIBUPNP_PKG_ERRORS" >&5
- if test "$build_upnp" == "true" ; then
+ if test "$build_upnp" = "true" ; then
as_fn_error $? "libupnp not found." "$LINENO" 5
else
build_upnp=false
@@ -19618,7 +19618,7 @@ fi
elif test $pkg_failed = untried; then
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
$as_echo "no" >&6; }
- if test "$build_upnp" == "true" ; then
+ if test "$build_upnp" = "true" ; then
as_fn_error $? "libupnp not found." "$LINENO" 5
else
build_upnp=false