Add scribus.

Scribus is a publishing layout program using a Qt interface.

It can be used to create stationery, small posters and brochures and to
layout newsletters and other documents. It can export in Postscript and PDF
formats; and the data is saved in XML format.

Scribus aims to be similar to Adobe PageMaker and Quark XPress.  It can do
typical tasks like kerning text and placing and rotating text and images.
This commit is contained in:
nia 2019-10-25 16:56:52 +01:00
parent f3fdbf6cdc
commit c3751d6a91
11 changed files with 3638 additions and 0 deletions

View File

@ -4430,6 +4430,7 @@ SUBDIR+= scourge
SUBDIR+= scr2png
SUBDIR+= scratchpad
SUBDIR+= scrc
SUBDIR+= scribus
SUBDIR+= scsh-install-lib
SUBDIR+= scummvm-bass
SUBDIR+= scummvm-fotaq

8
scribus/DESCR Normal file
View File

@ -0,0 +1,8 @@
Scribus is a publishing layout program using a Qt interface.
It can be used to create stationery, small posters and brochures and to
layout newsletters and other documents. It can export in Postscript and PDF
formats; and the data is saved in XML format.
Scribus aims to be similar to Adobe PageMaker and Quark XPress. It can do
typical tasks like kerning text and placing and rotating text and images.

62
scribus/Makefile Normal file
View File

@ -0,0 +1,62 @@
# $NetBSD$
DISTNAME= scribus-1.5.5
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=scribus/}
EXTRACT_SUFX= .tar.xz
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://www.scribus.net/
COMMENT= Desktop publishing software
LICENSE= gnu-gpl-v2
TOOL_DEPENDS+= qt5-qttools-[0-9]*:../../x11/qt5-qttools
USE_CMAKE= yes
USE_TOOLS+= pkg-config
USE_LANGUAGES= c c++11
# C++11
GCC_REQD+= 4.7
CMAKE_ARGS+= -Wno-dev
.for component in Core Widgets Gui Xml Network Xml OpenGL LinguistTools PrintSupport
CMAKE_ARGS+= -DQt5${component}_DIR=${QTDIR}/lib/cmake/Qt5${component}
.endfor
CMAKE_ARGS+= -DCAIRO_DIR=${WRKSRC}/cmake/modules
CMAKE_ARGS+= -DFONTCONFIG_DIR=${WRKSRC}/cmake/modules
REPLACE_PYTHON+= scribus/plugins/scriptplugin/samples/*.py
REPLACE_PYTHON+= scribus/plugins/scriptplugin/scripts/*.py
# Not ported yet?
PYTHON_VERSIONS_ACCEPTED= 27
.include "../../devel/boost-libs/buildlink3.mk"
.include "../../converters/libcdr/buildlink3.mk"
.include "../../converters/libfreehand/buildlink3.mk"
.include "../../converters/libmspub/buildlink3.mk"
.include "../../converters/libpagemaker/buildlink3.mk"
.include "../../converters/libqxp/buildlink3.mk"
.include "../../converters/libvisio/buildlink3.mk"
.include "../../converters/libzmf/buildlink3.mk"
.include "../../fonts/fontconfig/buildlink3.mk"
.include "../../graphics/cairo/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../graphics/lcms2/buildlink3.mk"
.include "../../graphics/osg/buildlink3.mk"
.include "../../lang/python/extension.mk"
.include "../../print/cups-base/buildlink3.mk"
.include "../../print/podofo/buildlink3.mk"
.include "../../print/poppler-cpp/buildlink3.mk"
.include "../../print/poppler-includes/buildlink3.mk"
.include "../../textproc/hunspell/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../x11/qt5-qtbase/buildlink3.mk"
.include "../../mk/dlopen.buildlink3.mk"
BUILDLINK_TRANSFORM+= opt:-ldl:${BUILDLINK_LDADD.dl:Q}
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3413
scribus/PLIST Normal file

File diff suppressed because it is too large Load Diff

1
scribus/TODO Normal file
View File

@ -0,0 +1 @@
Segfaults

11
scribus/distinfo Normal file
View File

@ -0,0 +1,11 @@
$NetBSD$
SHA1 (scribus-1.5.5.tar.xz) = 2f657d42df810bcf1a223cf4c38bf18278486907
RMD160 (scribus-1.5.5.tar.xz) = 9e7c15207c10d81c34ede88ecd4dd4cae36614bc
SHA512 (scribus-1.5.5.tar.xz) = 2d62424ad609296df33ced550940fceb4e15133a595a740cc4f4b4ffbc92aa31737336ac7716c2eed20d2866e37f5a9b780a44d86128daa6bbad3ccb58168b50
Size (scribus-1.5.5.tar.xz) = 73861836 bytes
SHA1 (patch-CMakeLists.txt) = 9b1bfb83831b42af9ab9c3321a31217b39a6893f
SHA1 (patch-scribus_CMakeLists.txt) = 1e7abcc99e0473abd642b9ba54217bdad101b28b
SHA1 (patch-scribus_scclocale.cpp) = 92218572b6b760b3c0759b99c4ff7c0bd93d09e5
SHA1 (patch-scribus_scclocale.h) = cc15dfa9d136fc7c7b996811b26e2da729b8d491
SHA1 (patch-scribus_util__debug.cpp) = 01e7bb51e1dc822c876a76e08b5de65e0311ea8d

View File

@ -0,0 +1,38 @@
$NetBSD$
Allow CAIRO_DIR and LCMS_DIR to be set from the Makefile
--- CMakeLists.txt.orig 2019-07-30 22:34:43.000000000 +0000
+++ CMakeLists.txt
@@ -883,7 +883,6 @@ if (RENDER_LIB)
endif()
endif()
-set(CAIRO_DIR ${CMAKE_MODULE_PATH})
find_package(CAIRO REQUIRED)
if(CAIRO_FOUND)
message("CAIRO Library Found OK")
@@ -915,7 +914,6 @@ endif()
#>>LibXML2
#<<LittleCMS
-set(LCMS_DIR ${CMAKE_MODULE_PATH})
find_package(LCMS2 REQUIRED)
if(LCMS2_FOUND)
set(HAVE_LCMS2 ON)
@@ -929,7 +927,6 @@ endif()
#<<FontConfig
if(NOT WIN32)
- set(FONTCONFIG_DIR ${CMAKE_MODULE_PATH})
find_package(FONTCONFIG)
if(FONTCONFIG_FOUND)
message("FontConfig Found OK")
@@ -982,7 +979,6 @@ endif()
#<< GraphicsMagick for image import
if (WANT_GRAPHICSMAGICK)
- set(GMAGICK_DIR ${CMAKE_MODULE_PATH})
pkg_check_modules(GMAGICK GraphicsMagick)
# find_package(GMAGICK)
if(GMAGICK_FOUND)

View File

@ -0,0 +1,24 @@
$NetBSD$
Support NetBSD.
--- scribus/CMakeLists.txt.orig 2019-07-30 22:34:51.000000000 +0000
+++ scribus/CMakeLists.txt
@@ -1246,7 +1246,7 @@ else()
endif()
##TEST FIX FOR 6897
-if (CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" OR CMAKE_SYSTEM_NAME STREQUAL "OpenBSD")
+if (CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" OR CMAKE_SYSTEM_NAME STREQUAL "NetBSD" OR CMAKE_SYSTEM_NAME STREQUAL "OpenBSD")
# Use the -E / --export-dynamic flag to ensure that symbols in the Scribus
# binary are in the public symbol table for plugins. The symbols must also
# be set as SCRIBUS_API if we're building with -fvisibility=hidden .
@@ -1302,7 +1302,7 @@ endif ()
# required to resolve symbols from libdl when ld is called with --no-add-needed
# #9310 for the OpenBSD addition
-if(UNIX AND NOT CMAKE_SYSTEM_NAME STREQUAL "OpenBSD" AND NOT CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" AND NOT HAIKU)
+if(UNIX AND NOT CMAKE_SYSTEM_NAME STREQUAL "OpenBSD" AND NOT CMAKE_SYSTEM_NAME STREQUAL "NetBSD" AND NOT CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" AND NOT HAIKU)
target_link_libraries(${EXE_NAME} dl)
endif()

View File

@ -0,0 +1,33 @@
$NetBSD$
Support NetBSD.
--- scribus/scclocale.cpp.orig 2019-07-30 22:35:07.000000000 +0000
+++ scribus/scclocale.cpp
@@ -27,7 +27,7 @@ ScCLocale::ScCLocale()
#if defined(Q_OS_WIN)
cLocale = _create_locale(LC_ALL, "C");
#else
- #if not defined(Q_OS_SOLARIS) and not defined(Q_OS_OPENBSD) and not defined(Q_OS_FREEBSD) and not defined(Q_OS_HAIKU)
+ #if not defined(Q_OS_SOLARIS) and not defined(Q_OS_OPENBSD) and not defined(Q_OS_FREEBSD) and not defined(Q_OS_NETBSD) and not defined(Q_OS_HAIKU)
cLocale = newlocale(LC_ALL_MASK, "C", nullptr);
#endif
#endif
@@ -38,7 +38,7 @@ ScCLocale::~ScCLocale()
#if defined(Q_OS_WIN)
_free_locale(cLocale);
#else
- #if not defined(Q_OS_SOLARIS) and not defined(Q_OS_OPENBSD) and not defined(Q_OS_FREEBSD) and not defined(Q_OS_HAIKU)
+ #if not defined(Q_OS_SOLARIS) and not defined(Q_OS_OPENBSD) and not defined(Q_OS_FREEBSD) and not defined(Q_OS_NETBSD) and not defined(Q_OS_HAIKU)
freelocale(cLocale);
#endif
#endif
@@ -190,7 +190,7 @@ double ScCLocale::strtod(const char * st
return result;
}
-#if defined(Q_OS_SOLARIS) || defined (Q_OS_OPENBSD) || defined(Q_OS_FREEBSD) || defined(Q_OS_HAIKU)
+#if defined(Q_OS_SOLARIS) || defined (Q_OS_OPENBSD) || defined(Q_OS_FREEBSD) || defined(Q_OS_NETBSD) || defined(Q_OS_HAIKU)
double result(0.0);
std::streamoff bytesRead;
std::istringstream sstream(str);

View File

@ -0,0 +1,23 @@
$NetBSD$
Support NetBSD.
--- scribus/scclocale.h.orig 2019-07-30 22:35:07.000000000 +0000
+++ scribus/scclocale.h
@@ -21,14 +21,14 @@
#include <xlocale.h>
#endif
-#if defined(Q_OS_SOLARIS) || defined (Q_OS_OPENBSD) || defined(Q_OS_FREEBSD) || defined(Q_OS_HAIKU)
+#if defined(Q_OS_SOLARIS) || defined (Q_OS_OPENBSD) || defined(Q_OS_FREEBSD) || defined(Q_OS_NETBSD) || defined(Q_OS_HAIKU)
#include <locale.h>
#endif
#if defined(Q_OS_WIN)
#define XLocaleType _locale_t
#else
- #if defined (Q_OS_SOLARIS) || defined (Q_OS_OPENBSD) || defined(Q_OS_FREEBSD) || defined(Q_OS_HAIKU)
+ #if defined (Q_OS_SOLARIS) || defined (Q_OS_OPENBSD) || defined(Q_OS_FREEBSD) || defined(Q_OS_NETBSD) || defined(Q_OS_HAIKU)
#define XLocaleType char* //dummy?
#else
#define XLocaleType locale_t

View File

@ -0,0 +1,24 @@
$NetBSD$
Support NetBSD.
--- scribus/util_debug.cpp.orig 2019-07-30 22:35:07.000000000 +0000
+++ scribus/util_debug.cpp
@@ -24,7 +24,7 @@ for which a new license (GPL+exception)
#include <QDateTime>
#include <QtGlobal>
-#if !defined(_WIN32) && !defined(Q_OS_MAC)
+#if !defined(_WIN32) && !defined(Q_OS_MAC) && !defined(Q_OS_NETBSD)
#include <execinfo.h>
#include <cxxabi.h>
#endif
@@ -54,7 +54,7 @@ void tDebug(const QString& message)
*/
void printBacktrace ( int nFrames )
{
-#if !defined(_WIN32) && !defined(Q_OS_MAC) && !defined(Q_OS_OPENBSD) && !defined(Q_OS_FREEBSD)
+#if !defined(_WIN32) && !defined(Q_OS_MAC) && !defined(Q_OS_OPENBSD) && !defined(Q_OS_FREEBSD) && !defined(Q_OS_NETBSD)
void ** trace = new void*[nFrames + 1];
char **messages = ( char ** ) nullptr;
int i, trace_size = 0;