pan2-git: fix build on NetBSD, fix pkglint

This commit is contained in:
Thomas Klausner 2020-04-15 10:56:04 +02:00
parent 725a202c79
commit c4c418c572
4 changed files with 23 additions and 2 deletions

View File

@ -2,7 +2,7 @@
DISTNAME= pan2-2
CATEGORIES= news
MASTER_SITES= https://gitlab.gnome.org/GNOME/pan
MASTER_SITES= https://gitlab.gnome.org/GNOME/pan/
GIT_REPO= https://gitlab.gnome.org/GNOME/pan.git
MAINTAINER= rhialto@falu.nl

View File

@ -1,5 +1,6 @@
$NetBSD$
SHA1 (patch-configure.ac) = e71544a02c6c3fa09fe79f78eb39ebd31e0d8a3c
SHA1 (patch-filenames) = e68d7cd688a5b80a515cbe8e93e5bc4f5204033c
SHA1 (patch-filenames) = bd7c49c59be49ba899b1c426aa69968c2443a12c
SHA1 (patch-pan-general-e-util.cc) = c252f074b139b100f3f879261b1ba894b5f3350c
SHA1 (patch-pan_usenet-utils_mime-utils.cc) = 072d8ccd5b92af252fd4a1b7d1ef121b0b517f85

View File

@ -1,3 +1,5 @@
$NetBSD$
diff --git a/pan/tasks/decoder.cc b/pan/tasks/decoder.cc
index b4c21ae..04ea40a 100644
--- pan/tasks/decoder.cc

View File

@ -0,0 +1,18 @@
$NetBSD$
iconv prototype was changed to what non-NetBSD has.
--- pan/usenet-utils/mime-utils.cc.orig 2020-04-15 08:49:36.084023027 +0000
+++ pan/usenet-utils/mime-utils.cc
@@ -77,11 +77,7 @@ namespace pan
outbuf = out + converted;
outleft = outlen - converted;
-#if defined(__NetBSD__)
- converted = iconv (cd, &inbuf, &inleft, &outbuf, &outleft);
-#else
converted = iconv (cd, (char **) &inbuf, &inleft, &outbuf, &outleft);
-#endif
if (converted != (size_t) -1 && errno == 0) {
/*