f2bgl: import f2bgl-0.2.7 as wip/f2bgl

f2bgl is a re-implementation of the engine used in the game Fade To Black
made by Delphine Software and released in 1995.

You will need the original files of the PC release or PC demo.
This commit is contained in:
Yorick Hardy 2019-12-18 08:56:23 +02:00
parent 5555f5ed5d
commit c68a143c2e
6 changed files with 62 additions and 0 deletions

View File

@ -772,6 +772,7 @@ SUBDIR+= exult-snapshot
SUBDIR+= ez-pine-gpg
SUBDIR+= ezbounce
SUBDIR+= f1spirit
SUBDIR+= f2bgl
SUBDIR+= f3
SUBDIR+= faast
SUBDIR+= facedetect

4
f2bgl/DESCR Normal file
View File

@ -0,0 +1,4 @@
f2bgl is a re-implementation of the engine used in the game Fade To Black
made by Delphine Software and released in 1995.
You will need the original files of the PC release or PC demo.

32
f2bgl/Makefile Normal file
View File

@ -0,0 +1,32 @@
# $NetBSD$
GITHUB_PROJECT= f2bgl
GITHUB_TAG= 0.2.7
DISTNAME= 0.2.7
PKGNAME= ${GITHUB_PROJECT}-${DISTNAME}
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GITHUB:=cyxx/}
DIST_SUBDIR= ${GITHUB_PROJECT}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://cyxdown.free.fr/f2b/
COMMENT= Re-implementation of the engine used in the game Fade To Black
#LICENSE= # TODO: (see mk/license.mk)
WRKSRC= ${WRKDIR}/f2bgl-0.2.7
USE_LANGUAGES= c++
BUILD_TARGET= f2bgl
INSTALLATION_DIRS= bin share/doc/f2bgl
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/f2bgl ${DESTDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/README.txt \
${DESTDIR}${PREFIX}/share/doc/f2bgl
.include "../../audio/fluidsynth/buildlink3.mk"
.include "../../audio/libwildmidi/buildlink3.mk"
.include "../../devel/SDL2/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3
f2bgl/PLIST Normal file
View File

@ -0,0 +1,3 @@
@comment $NetBSD$
bin/f2bgl
share/doc/f2bgl/README.txt

7
f2bgl/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (f2bgl/0.2.7.tar.gz) = 914b2c08e71873006e50f00cb848ca2cf134a139
RMD160 (f2bgl/0.2.7.tar.gz) = 8fbe3539ebfccc7f41c54da5ba4bae8bb8c713c3
SHA512 (f2bgl/0.2.7.tar.gz) = d4d94e448282ad936b86e64a830ada41f61fabe36e857f356373fb4c5a4bd70cdd6c0be5d32c54fe4edd744bbb5a1a4507f63812d40b28363e5e6b09e318a28a
Size (f2bgl/0.2.7.tar.gz) = 123720 bytes
SHA1 (patch-Makefile) = 2f2c13781847c6a4a0e292f6090566069b028aad

View File

@ -0,0 +1,15 @@
$NetBSD$
Avoid having to use gmake.
--- Makefile.orig 2018-03-13 23:38:13.000000000 +0000
+++ Makefile
@@ -20,7 +20,7 @@ DEPS = $(SRCS:.cpp=.d)
CXXFLAGS += -MMD $(DEFINES) $(SDL_CFLAGS)
f2bgl: $(OBJS)
- $(CXX) -o $@ $^ $(LIBS)
+ $(CXX) -o $@ $(OBJS) $(LIBS)
clean:
rm -f *.o *.d