Fix build with recent OpenSSL

This commit is contained in:
Ryo ONODERA 2019-01-29 21:50:34 +09:00
parent 89e0e2683b
commit c7c2bb3703
2 changed files with 14 additions and 0 deletions

View File

@ -5,3 +5,4 @@ RMD160 (libimobiledevice-1.2.0.tar.bz2) = 0d1ec5a088abd73ac85c0c708524069cb22daf
SHA512 (libimobiledevice-1.2.0.tar.bz2) = 0de5f768aeb5d62445892855d84ceaff776f6667733c351ed6c34bf9d500802762d1a06e5efdf57f33cafc9ee788041cd9b6748fb9bad6c2e4ae2f9b9aa93589
Size (libimobiledevice-1.2.0.tar.bz2) = 631495 bytes
SHA1 (patch-configure.ac) = 946788d4ad269457b7593b3de5e504b4d330c1bd
SHA1 (patch-src_idevice.c) = d40da0ba0d15f65aa7140df68e476a7173cac047

View File

@ -0,0 +1,13 @@
$NetBSD$
--- src/idevice.c.orig 2015-01-28 01:10:32.000000000 +0000
+++ src/idevice.c
@@ -678,7 +678,7 @@ LIBIMOBILEDEVICE_API idevice_error_t ide
}
BIO_set_fd(ssl_bio, (int)(long)connection->data, BIO_NOCLOSE);
- SSL_CTX *ssl_ctx = SSL_CTX_new(SSLv3_method());
+ SSL_CTX *ssl_ctx = SSL_CTX_new(SSLv23_method());
if (ssl_ctx == NULL) {
debug_info("ERROR: Could not create SSL context.");
BIO_free(ssl_bio);