emacs-git: remove patches that were merged upstream

This commit is contained in:
Thomas Klausner 2020-02-18 23:00:11 +01:00
parent 17459e830c
commit d0b041a7d6
3 changed files with 1 additions and 53 deletions

View File

@ -1,4 +1,3 @@
$NetBSD$
SHA1 (patch-configure.ac) = ac5f320cdb3c195b742321ab7c3ef48b5e50f811
SHA1 (patch-src_systhread.c) = 1fed745b40101d96fb22114f7629595afdd15fe6
SHA1 (patch-configure.ac) = f54d1d1428e25c5320bf166606cd2808d3e4797e

View File

@ -1,13 +1,8 @@
$NetBSD$
1. chunk:
Do not inject X11 LDFLAGS, pkgsrc handles that.
Fixes PR pkg/53688.
2. chunk:
Adapt pthread_setname_np calling convention for NetBSD.
http://debbugs.gnu.org/cgi/bugreport.cgi?bug=39363
--- configure.ac.orig 2020-01-31 17:00:50.659618322 +0000
+++ configure.ac
@@ -1549,7 +1549,8 @@ ac_link="$ac_link $LD_SWITCH_SYSTEM"
@ -20,25 +15,3 @@ http://debbugs.gnu.org/cgi/bugreport.cgi?bug=39363
esac
C_SWITCH_MACHINE=
@@ -4192,6 +4193,21 @@ if test "$ac_cv_func_pthread_setname_np"
AC_DEFINE(
HAVE_PTHREAD_SETNAME_NP_1ARG, 1,
[Define to 1 if pthread_setname_np takes a single argument.])
+ else
+ AC_CACHE_CHECK(
+ [whether pthread_setname_np takes three arguments],
+ [emacs_cv_pthread_setname_np_3arg],
+ [AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM(
+ [[#include <pthread.h>]],
+ [[pthread_setname_np (0, "%s", "a");]])],
+ [emacs_cv_pthread_setname_np_3arg=yes],
+ [emacs_cv_pthread_setname_np_3arg=no])])
+ if test "$emacs_cv_pthread_setname_np_3arg" = "yes"; then
+ AC_DEFINE(
+ HAVE_PTHREAD_SETNAME_NP_3ARG, 1,
+ [Define to 1 if pthread_setname_np takes three arguments.])
+ fi
fi
fi

View File

@ -1,24 +0,0 @@
$NetBSD$
Adapt pthread_setname_np calling convention for NetBSD.
http://debbugs.gnu.org/cgi/bugreport.cgi?bug=39363
--- src/systhread.c.orig 2020-01-31 17:00:50.894938840 +0000
+++ src/systhread.c
@@ -214,11 +214,13 @@ sys_thread_set_name (const char *name)
char p_name[TASK_COMM_LEN];
strncpy (p_name, name, TASK_COMM_LEN - 1);
p_name[TASK_COMM_LEN - 1] = '\0';
- #ifdef HAVE_PTHREAD_SETNAME_NP_1ARG
+# ifdef HAVE_PTHREAD_SETNAME_NP_1ARG
pthread_setname_np (p_name);
- #else
+# elif defined HAVE_PTHREAD_SETNAME_NP_3ARG
+ pthread_setname_np (pthread_self (), "%s", p_name);
+# else
pthread_setname_np (pthread_self (), p_name);
- #endif
+# endif
#endif
}