Add canu: Single molecule sequence assembler for genomes large and small

This commit is contained in:
Jason Bacon 2018-05-24 12:31:28 -05:00
parent 043032fc8b
commit d669ea0c88
7 changed files with 204 additions and 0 deletions

View File

@ -320,6 +320,7 @@ SUBDIR+= canna-lib
SUBDIR+= canna-server
SUBDIR+= canto-curses
SUBDIR+= canto-daemon
SUBDIR+= canu
SUBDIR+= capicxx-core-runtime
SUBDIR+= cardpeek
SUBDIR+= cargo

1
canu/DESCR Normal file
View File

@ -0,0 +1 @@
A single molecule sequence assembler for genomes large and small.

85
canu/Makefile Normal file
View File

@ -0,0 +1,85 @@
# $NetBSD$
#
###########################################################
# Generated by fbsd2pkg #
# Thu Jul 20 18:34:44 CDT 2017 #
###########################################################
DISTNAME= canu-${PV}
CATEGORIES= biology java
MASTER_SITES= ${MASTER_SITE_GITHUB:=marbl/}
GITHUB_PROJECT= canu
GITHUB_TAG= v${PV}
MAINTAINER= bacon@NetBSD.org
HOMEPAGE= http://canu.readthedocs.io/
COMMENT= Single molecule sequence assembler for genomes large and small
LICENSE= gnu-gpl-v2
DEPENDS+= gnuplot>0:../../graphics/gnuplot
# Screwy Makefile compiles directly into ${DESTDIR}${PREFIX}
SUBST_CLASSES+= optimize
SUBST_STAGE.optimize= post-patch
SUBST_SED.optimize+= -e 's|-O4|-O2|g'
SUBST_SED.optimize+= -e 's|-funroll-loops||g'
SUBST_SED.optimize+= -e 's|-fexpensive-optimizations||g'
SUBST_FILES.optimize+= ${WRKSRC}/Makefile
SUBST_CLASSES+= jar
SUBST_STAGE.jar= post-patch
SUBST_SED.jar= -e 's|\\$$bin/mhap-|${PREFIX}/${JAVAJARDIR}/mhap-|g'
SUBST_FILES.jar= ${WRKSRC}/pipelines/canu/OverlapMhap.pm
SUBST_CLASSES+= perl
SUBST_STAGE.perl= post-patch
SUBST_SED.perl= -e 's|RealBin/lib|RealBin/../${SITE_PERL_REL}|g'
SUBST_FILES.perl= ${WRKSRC}/pipelines/canu.pl
REPLACE_PERL+= bogart/*.pl \
pipelines/*.pl \
bogus/*.pl \
bogart-analysis/*.pl \
overlapBasedTrimming/*.pl \
overlapInCore-analysis/*.pl \
merTrim/*.pl \
erateEstimate/*.pl \
meryl/.pl \
fastq-utilities/*.pl \
*.pl
# May work on other 64-bit processors, but untested
ONLY_FOR_PLATFORM= *-*-x86_64
USE_LANGUAGES= c c++
USE_JAVA= run
USE_JAVA2= 8
USE_TOOLS+= gmake pax perl
GCC_REQD+= 4.8
WRKSRC= ${WRKDIR}/canu-${PV}/src
MAKE_ENV+= DESTDIR=${WRKSRC}
PV= 1.7
TMP_INST= ${WRKSRC}${PREFIX}/${OPSYS}-${MACHINE_ARCH:S/x86_64/amd64/}
SITE_PERL_REL= lib/perl5/site_perl
JAVAJARDIR= share/java/classes
INSTALLATION_DIRS= bin ${JAVAJARDIR}
post-extract:
${CHMOD} -R g-w ${WRKDIR}
post-build:
${MKDIR} ${TMP_INST}/lib/perl5
${MV} ${TMP_INST}/lib/site_perl ${TMP_INST}/lib/perl5
do-install:
cd ${TMP_INST}/bin && ${PAX} -wr * ${DESTDIR}${PREFIX}/bin
cd ${TMP_INST}/lib && ${PAX} -wr * ${DESTDIR}${PREFIX}/lib
cd ${TMP_INST}/share && ${PAX} -wr * ${DESTDIR}${PREFIX}/share
.include "../../devel/boost-libs/buildlink3.mk"
.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"

93
canu/PLIST Normal file
View File

@ -0,0 +1,93 @@
@comment $NetBSD$
bin/alignGFA
bin/bogart
bin/bogus
bin/canu
bin/canu.defaults
bin/correctOverlaps
bin/createFalconSenseInputs
bin/dumpBlob
bin/edalign
bin/erateEstimate
bin/errorEstimate
bin/estimate-mer-threshold
bin/existDB
bin/falcon_sense
bin/falconsense
bin/fastqAnalyze
bin/fastqSample
bin/fastqSimulate
bin/fastqSimulate-sort
bin/filterCorrectionLayouts
bin/filterCorrectionOverlaps
bin/findErrors
bin/findErrors-Dump
bin/gatekeeperCreate
bin/gatekeeperDumpFASTQ
bin/gatekeeperDumpMetaData
bin/gatekeeperPartition
bin/generateCorrectionLayouts
bin/leaff
bin/loadCorrectedReads
bin/loadTrimmedReads
bin/maskMers
bin/merTrim
bin/meryl
bin/mhapConvert
bin/mmapConvert
bin/ovStoreBucketizer
bin/ovStoreBuild
bin/ovStoreDump
bin/ovStoreIndexer
bin/ovStoreSorter
bin/ovStoreStats
bin/overlapConvert
bin/overlapImport
bin/overlapInCore
bin/overlapInCorePartition
bin/overlapPair
bin/positionDB
bin/prefixEditDistance-matchLimitGenerate
bin/readConsensus
bin/sequence
bin/simple
bin/simple-dump
bin/splitHaplotype
bin/splitReads
bin/tgStoreCompress
bin/tgStoreCoverageStat
bin/tgStoreDump
bin/tgStoreFilter
bin/tgStoreLoad
bin/tgTigDisplay
bin/trimReads
bin/trioCanu
bin/utgcns
lib/libcanu.a
lib/libleaff.a
lib/perl5/site_perl/canu/Configure.pm
lib/perl5/site_perl/canu/Consensus.pm
lib/perl5/site_perl/canu/CorrectReads.pm
lib/perl5/site_perl/canu/Defaults.pm
lib/perl5/site_perl/canu/ErrorEstimate.pm
lib/perl5/site_perl/canu/Execution.pm
lib/perl5/site_perl/canu/Gatekeeper.pm
lib/perl5/site_perl/canu/Grid.pm
lib/perl5/site_perl/canu/Grid_Cloud.pm
lib/perl5/site_perl/canu/Grid_DNANexus.pm
lib/perl5/site_perl/canu/Grid_LSF.pm
lib/perl5/site_perl/canu/Grid_PBSTorque.pm
lib/perl5/site_perl/canu/Grid_SGE.pm
lib/perl5/site_perl/canu/Grid_Slurm.pm
lib/perl5/site_perl/canu/HaplotypeReads.pm
lib/perl5/site_perl/canu/Meryl.pm
lib/perl5/site_perl/canu/Output.pm
lib/perl5/site_perl/canu/OverlapBasedTrimming.pm
lib/perl5/site_perl/canu/OverlapErrorAdjustment.pm
lib/perl5/site_perl/canu/OverlapInCore.pm
lib/perl5/site_perl/canu/OverlapMMap.pm
lib/perl5/site_perl/canu/OverlapMhap.pm
lib/perl5/site_perl/canu/OverlapStore.pm
lib/perl5/site_perl/canu/Report.pm
lib/perl5/site_perl/canu/Unitig.pm
share/java/classes/mhap-2.1.3.jar

1
canu/TODO Normal file
View File

@ -0,0 +1 @@
Clean up and test

7
canu/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (canu-1.7.tar.gz) = aaaafd8516be5e4d725af407bc84b3c6f178b2ac
RMD160 (canu-1.7.tar.gz) = bd394bb6dcebd43d2793ca1aa9bd60ec6be75beb
SHA512 (canu-1.7.tar.gz) = dbc1dca4df4117521143843bb781227f4dfde5ba7068e47b51ccf9e9dba45eb2629b5773531e4f362f1df05eab3f1a62088c5fa231d3624af23f11d97e7a4edf
Size (canu-1.7.tar.gz) = 2533016 bytes
SHA1 (patch-pipelines_canu_Execution.pm) = 4f9d343e03cc802b90616844cb331b78793bd368

View File

@ -0,0 +1,16 @@
$NetBSD$
# Eliminate assumptions about install dir name
--- pipelines/canu/Execution.pm.orig 2017-04-17 19:32:38.000000000 +0000
+++ pipelines/canu/Execution.pm
@@ -293,10 +293,6 @@ sub skipStage ($$@) {
sub getInstallDirectory () {
my $installDir = $FindBin::RealBin;
- if ($installDir =~ m!^(.*)/\w+-\w+/bin$!) {
- $installDir = $1;
- }
-
return($installDir);
}