New pkg, xdo

Small X utility to perform elementary actions on windows.
Apply the given action to the given windows.
If no window IDs and no options are given, the action applies
to the focused window.
This commit is contained in:
pin 2020-06-27 16:32:28 +02:00
parent fed8fe7683
commit df3e76e513
6 changed files with 57 additions and 0 deletions

View File

@ -4992,6 +4992,7 @@ SUBDIR+= xbsql
SUBDIR+= xcb-util-xrm-git
SUBDIR+= xchat2-tcl
SUBDIR+= xdiskusage
SUBDIR+= xdo
SUBDIR+= xebece
SUBDIR+= xentools48
SUBDIR+= xerces-c-2.8.0

4
xdo/DESCR Normal file
View File

@ -0,0 +1,4 @@
Small X utility to perform elementary actions on windows.
Apply the given action to the given windows.
If no window IDs and no options are given, the action applies
to the focused window.

20
xdo/Makefile Normal file
View File

@ -0,0 +1,20 @@
# $NetBSD$
DISTNAME= xdo-0.5.7
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_GITHUB:=baskerville/}
GITHUB_TAG= ${PKGVERSION_NOREV}
MAINTAINER= pin@NetBSD.org
HOMEPAGE= https://github.com/baskerville/xdo/
COMMENT= Small X utility to perform elementary actions on windows
LICENSE= 2-clause-bsd
USE_TOOLS+= gmake
WRKSRC= ${WRKDIR}/xdo-0.5.7
.include "../../x11/libxcb/buildlink3.mk"
.include "../../x11/xcb-util-wm/buildlink3.mk"
.include "../../x11/xcb-util/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3
xdo/PLIST Normal file
View File

@ -0,0 +1,3 @@
@comment $NetBSD$
bin/xdo
man/man1/xdo.1

7
xdo/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (xdo-0.5.7.tar.gz) = 9daa84c47dd213fb3de6ac5ebec5ec4fc1be61a3
RMD160 (xdo-0.5.7.tar.gz) = 4b0b661f00013d7b6154e88230f9e72bae72f298
SHA512 (xdo-0.5.7.tar.gz) = 0978a8571a35899c916495c9d38458adb6c766db4d498dfacf2f0a46e373f7caa3c3e227096b3e60e03c67b972777cf7519e5b6eee7ebb91f82d4450ac0ff98d
Size (xdo-0.5.7.tar.gz) = 7453 bytes
SHA1 (patch-Makefile) = fe24912205b6bf3064c4753ac0c668dd872391b7

View File

@ -0,0 +1,22 @@
$NetBSD$
Allow build and re-direct man to proper location
--- Makefile.orig 2017-09-18 12:00:07.000000000 +0000
+++ Makefile
@@ -2,13 +2,13 @@ NAME := xdo
VERCMD ?= git describe 2> /dev/null
VERSION := $(shell $(VERCMD) || cat VERSION)
-CPPFLAGS += -D_POSIX_C_SOURCE=200809L -DVERSION=\"$(VERSION)\"
+CPPFLAGS += -DVERSION=\"$(VERSION)\"
CFLAGS += -std=c99 -pedantic -Wall -Wextra
LDLIBS := -lxcb -lxcb-util -lxcb-icccm -lxcb-ewmh -lxcb-xtest
PREFIX ?= /usr/local
BINPREFIX ?= $(PREFIX)/bin
-MANPREFIX ?= $(PREFIX)/share/man
+MANPREFIX ?= $(PREFIX)/man
SRC := $(wildcard *.c)
OBJ := $(SRC:.c=.o)