(mail/wl-git) Fix broken patches and blk3 path. Not packaged yet

This commit is contained in:
Makoto Fujiwara (CF-SX3) 2020-10-17 14:42:43 +09:00
parent 046ac2ad6b
commit dfee0ef1b4
5 changed files with 28 additions and 24 deletions

View File

@ -23,7 +23,7 @@ MAKE_FLAGS+= PIXMAPDIR=${DESTDIR:Q}${PREFIX:Q}/share/wl
INFO_FILES= YES INFO_FILES= YES
# Change default wl-icon-directory for PIXMAP. # Change default wl-icon-directory for PIXMAP.
# Why not just use patch-ab ? $PREFIX is to be embedded. # Why not just use patch-ab ? ${PREFIX} is to be embedded.
SUBST_CLASSES+= icon_directory SUBST_CLASSES+= icon_directory
SUBST_STAGE.icon_directory= pre-configure SUBST_STAGE.icon_directory= pre-configure

View File

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.10 2015/01/29 07:15:12 jgoamakf Exp $ $NetBSD: distinfo,v 1.10 2015/01/29 07:15:12 jgoamakf Exp $
SHA1 (patch-aa) = 5c27e70a747e4ace03991e7d361c83aa844d4d13 SHA1 (patch-aa) = 5c27e70a747e4ace03991e7d361c83aa844d4d13
SHA1 (patch-ab) = f86e07bd6737541ee2f1d6a9fd239c752b3303de SHA1 (patch-ab) = 94d52fa4a3adef42d89bc32e1ea5252483ad6637
SHA1 (patch-wl_wl-summary_el) = 1b5003dc2cfccafeca01258e824f50bdacc7acd8 SHA1 (patch-wl_wl-summary_el) = 940a7632c6e417cde24e2a0ca84f33f7e4ad5eaf

View File

@ -9,6 +9,6 @@ PKG_SUPPORTED_OPTIONS= emacs-w3m-current
PLIST_VARS+= emacs-w3m-current PLIST_VARS+= emacs-w3m-current
.if !empty(PKG_OPTIONS:Memacs-w3m-current) .if !empty(PKG_OPTIONS:Memacs-w3m-current)
.include "../../wip/emacs-w3m-current/buildlink3.mk" .include "../../wip/emacs-w3m-cvs/buildlink3.mk"
PLIST.emacs-w3m-current= yes PLIST.emacs-w3m-current= yes
.endif .endif

View File

@ -3,16 +3,21 @@ $NetBSD: patch-ab,v 1.3 2015/01/29 07:15:12 jgoamakf Exp $
Without this patch, user needs to say where the icons installed, Without this patch, user needs to say where the icons installed,
and the icons won't be displayed such setup. and the icons won't be displayed such setup.
--- wl/wl-vars.el.orig 2015-01-29 15:47:43.000000000 +0900 --- wl/wl-vars.el.orig 2020-10-16 12:33:17.000000000 +0000
+++ wl/wl-vars.el 2015-01-29 15:48:32.000000000 +0900 +++ wl/wl-vars.el
@@ -173,8 +173,8 @@ @@ -162,9 +162,13 @@ Supersede `wl-user-mail-address-list'."
(defcustom wl-icon-directory (or :type 'directory
(and (fboundp 'locate-data-directory) :group 'wl)
(locate-data-directory "wl"))
- (let ((icons (expand-file-name "wl/icons/" +
- data-directory))) (defcustom wl-icon-directory
+ (let ((icons (expand-file-name "share/wl" - (or (let ((icons (expand-file-name "wl/icons/"
+ "%%PREFIX%%"))) - data-directory)))
(if (file-directory-p icons) +
icons)) + +
(if load-file-name +
+ (or (let ((icons (expand-file-name "share/wl"
+ "%%PREFIX%%")))
(if (file-directory-p icons)
icons))
(if load-file-name

View File

@ -14,17 +14,17 @@ your setup, for example, in ~/.wl.
;(setq wl-summary-line-format "%n%T%P%@%M/%D(%W)%h:%m %t%[%17(%c %f%) %] %#%~%s") ;(setq wl-summary-line-format "%n%T%P%@%M/%D(%W)%h:%m %t%[%17(%c %f%) %] %#%~%s")
(setq wl-summary-line-format "%n%T%P%@%M/%D(%W)%h:%m %t%[%17(%c %f%) %] %~%s") (setq wl-summary-line-format "%n%T%P%@%M/%D(%W)%h:%m %t%[%17(%c %f%) %] %~%s")
--- wl/wl-summary.el.orig 2013-01-25 11:39:09.000000000 +0900 --- wl/wl-summary.el.orig 2020-10-16 12:33:17.000000000 +0000
+++ wl/wl-summary.el 2013-01-25 12:26:38.000000000 +0900 +++ wl/wl-summary.el
@@ -38,6 +38,7 @@ @@ -39,6 +39,7 @@
(require 'timezone nil t)
(require 'elmo) (require 'elmo)
(require 'elmo-multi) (require 'elmo-date)
(eval-when-compile (require 'elmo-filter))
+(eval-when-compile (require 'wl-folder)) +(eval-when-compile (require 'wl-folder))
(require 'wl-message) (require 'wl-message)
(require 'wl-vars) (require 'wl-vars)
(require 'wl-highlight) (require 'wl-highlight)
@@ -3541,11 +3542,15 @@ Return non-nil if the mark is updated" @@ -3535,11 +3536,15 @@ Return non-nil if the mark is updated"
(let ((content-type (elmo-message-entity-field (let ((content-type (elmo-message-entity-field
wl-message-entity 'content-type)) wl-message-entity 'content-type))
(case-fold-search t)) (case-fold-search t))
@ -45,4 +45,3 @@ your setup, for example, in ~/.wl.
;;; For future use. ;;; For future use.
;;;(defun wl-summary-line-cached () ;;;(defun wl-summary-line-cached ()
;;; (if (elmo-message-cached-p wl-summary-buffer-elmo-folder ;;; (if (elmo-message-cached-p wl-summary-buffer-elmo-folder