commandergenius: update to Commander-Genius-2.4.5.2

Changelog:

v2.4.5:
-------
- QED Fixes
- Improved Savegame menu style and overall functionality
- Minor GUI improvements

v2.4.4:
-------
- Boost libraries are now optional, thanks to TinyXML2 code
- Added compatibility to the osxcross toolchain so MacOS in future will receive
  updates
- AutoGun working in Keen 4-6
- Better Analog controls handling in Keen 4-6
- Created a nice create bundle script

v2.4.3:
-------
- Finally, loading the game list is much faster. Enjoy!
- Integer scaling improvements
- Fixes to the load of high-res tiles in keen5 and 6
- Some bug fixes

v2.4.2:
-------
- SDL_Cursor now should work as intended
- Finally added some scroll arrows to list views
- More loading feedback especially for galaxy audio
- Adding some emscripten code so GsKit is compatible with WASM
- Some resolution and rendering improvements
- Keen dreams freezes less especially when using cheat codes
- Fixed broken Messie to Player interaction
- Added Quicksave (F6) and Quickload (F9) so dying is less tedious
- Added Integer scaling of video resoltion
- Added 640x360 game resolution which scales nice to 1920x1080

v2.4.1:
-------
- Added achievements feature. Special thanks to XRackProject for her assets
This commit is contained in:
Yorick Hardy 2020-06-29 07:04:37 +02:00
parent e9400bd8af
commit e3a13789ca
4 changed files with 10 additions and 52 deletions

View File

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.2 2015/09/06 20:10:45 yhardy Exp $
DISTNAME= Commander-Genius-v${PKGVERSION_NOREV}
PKGNAME= Commander-Genius-2.4.0
PKGNAME= Commander-Genius-2.4.5.2
CATEGORIES= games
MASTER_SITES= https://gitlab.com/Dringgstein/Commander-Genius/-/archive/v${PKGVERSION_NOREV}/
EXTRACT_SUFX= .tar.bz2

View File

@ -2,6 +2,8 @@
bin/CGeniusExe
share/applications/cgenius.desktop
share/commandergenius/CGLogo.svg
share/commandergenius/CGLogoInkscape.svg
share/commandergenius/CGLogoOptimized.svg
share/commandergenius/cache/K6DEMO.png
share/commandergenius/cache/eightacc.png
share/commandergenius/cache/kdreams.png
@ -19,6 +21,9 @@ share/commandergenius/global/2.png
share/commandergenius/global/3.png
share/commandergenius/global/4.png
share/commandergenius/global/HELPTEXT.CKP
share/commandergenius/global/TrophyMsg.png
share/commandergenius/global/Trophy_Sound.ogg
share/commandergenius/global/achievements.txt
share/commandergenius/global/bckgrnd.png
share/commandergenius/global/confirm.png
share/commandergenius/global/dpad.png

View File

@ -1,10 +1,9 @@
$NetBSD: distinfo,v 1.1 2015/08/19 21:21:53 yhardy Exp $
SHA1 (Commander-Genius-v2.4.0.tar.bz2) = 71338093f215d8efcf2a26700061f58b7264859c
RMD160 (Commander-Genius-v2.4.0.tar.bz2) = ecb0a622b2958848932fc7b2ae3f62704cb7eab6
SHA512 (Commander-Genius-v2.4.0.tar.bz2) = 76eda96fade00d164d3ea5b95acadfb28a3b24864a5ce3f2c9317837a1027cd8d0282a474b8d25bacc26008a26a6adc5062ee655f9abd350d44db58aa70d3b3b
Size (Commander-Genius-v2.4.0.tar.bz2) = 62351265 bytes
SHA1 (Commander-Genius-v2.4.5.2.tar.bz2) = 167428ac0dc0e40f85277839045969f9a7613eb8
RMD160 (Commander-Genius-v2.4.5.2.tar.bz2) = 8942991abaf3de4376469759bd186a08c74b7b98
SHA512 (Commander-Genius-v2.4.5.2.tar.bz2) = bb68f968c8bf4f99827f623d977db4e1944dcad5294bbc38af8bf0fb59c4b1d40563289b9790029465341a45785bddafac7e69818cc394debf35ffc092cf3915
Size (Commander-Genius-v2.4.5.2.tar.bz2) = 55257282 bytes
SHA1 (patch-GsKit_base_video_scaler_scalebit.cpp) = 390a892f4bdece12bcb6b36f84dee5ac2cec0c90
SHA1 (patch-src_engine_unzip_ioapi.h) = 80366fc999aae516da6ce0279e8049532c3df247
SHA1 (patch-src_engine_unzip_miniunz.c) = 8c83c6e2e927e587533d248cb478797c3e15eae7
SHA1 (patch-src_install.cmake) = d40e5bf407429eb54c6cb6970a5b23963e55d2a3

View File

@ -1,46 +0,0 @@
$NetBSD$
Need sys/stat.h for mkdir.
Use the unix methods for !WIN32
--- src/engine/unzip/miniunz.c.orig 2018-04-14 07:26:16.000000000 +0000
+++ src/engine/unzip/miniunz.c
@@ -45,6 +45,7 @@
#include <time.h>
#include <errno.h>
#include <fcntl.h>
+#include <sys/stat.h>
#ifdef _WIN32
# include <direct.h>
@@ -97,7 +98,6 @@ void change_file_date(filename,dosdate,t
SetFileTime(hFile,&ftm,&ftLastAcc,&ftm);
CloseHandle(hFile);
#else
-#if defined(linux) || defined(__APPLE__)
struct utimbuf ut;
struct tm newdate;
newdate.tm_sec = tmu_date.tm_sec;
@@ -114,7 +114,6 @@ void change_file_date(filename,dosdate,t
ut.actime=ut.modtime=mktime(&newdate);
utime(filename,&ut);
#endif
-#endif
}
@@ -127,13 +126,7 @@ int mymkdir(dirname)
int ret=0;
#if defined(WIN32) || defined(_WIN32)
ret = _mkdir(dirname);
-#endif
-
-#if defined(__linux__) || __linux__
- ret = mkdir (dirname,0775);
-#endif
-
-#if defined(__APPLE__)
+#else
ret = mkdir (dirname,0775);
#endif
return ret;