Import coma 1.0 as wip/coma.

Coma is a minimalistic X11 Window Manager.

It has 2 framing modes: default, large. Only one can be active at a given
time and is specified at startup time:

- Default means it will split up your screen into columns just large enough
to fit 80 column xterms.

- Large means it will calculate the frames based on 161 column xterms (so
one can use tmux and split it to get 80 columns in each pane).
This commit is contained in:
Frederic Cambus 2019-01-24 22:23:32 +01:00
parent aa7ebd76ef
commit e5968950b2
5 changed files with 65 additions and 0 deletions

10
coma/DESCR Normal file
View File

@ -0,0 +1,10 @@
Coma is a minimalistic X11 Window Manager.
It has 2 framing modes: default, large. Only one can be active at a given
time and is specified at startup time:
- Default means it will split up your screen into columns just large enough
to fit 80 column xterms.
- Large means it will calculate the frames based on 161 column xterms (so
one can use tmux and split it to get 80 columns in each pane).

14
coma/Makefile Normal file
View File

@ -0,0 +1,14 @@
# $NetBSD$
DISTNAME= coma-1.0
CATEGORIES= wm
MASTER_SITES= https://coma.one/releases/
MAINTAINER= fred@statdns.com
HOMEPAGE= https://coma.one/releases/
COMMENT= Keyboard driven tiling window manager
LICENSE= isc
.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXft/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3
coma/PLIST Normal file
View File

@ -0,0 +1,3 @@
@comment $NetBSD$
bin/coma
man/man1/coma.1

7
coma/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (coma-1.0.tar.gz) = e830786675e4f8542337363f8835e195e8f58593
RMD160 (coma-1.0.tar.gz) = 672f1202d92b0ba324f97d28c5c0185d59c1f106
SHA512 (coma-1.0.tar.gz) = 3df8fd17d269b3888fd931b5126f8e63c9aac63451be14fa8a20be09e945056cd7a45b062a6810a9bba0146fbd4b81791e8c0d9bbad1c18f26d1d3b222251e52
Size (coma-1.0.tar.gz) = 13487 bytes
SHA1 (patch-Makefile) = 939c2ee550abccc39967fb59fdff4a524c7cd30a

View File

@ -0,0 +1,31 @@
$NetBSD$
Adapt install target for pkgsrc.
--- Makefile.orig 2019-01-17 20:01:53.000000000 +0000
+++ Makefile
@@ -2,9 +2,10 @@
CC?=cc
COMA=coma
+DESTDIR?=
PREFIX?=/usr/local
INSTALL_DIR=$(PREFIX)/bin
-MAN_DIR=$(PREFIX)/share/man
+MAN_DIR=$(PREFIX)/man
SRC= coma.c client.c config.c frame.c wm.c
OBJS= $(SRC:%.c=%.o)
@@ -27,8 +28,10 @@ LDFLAGS+=`pkg-config --libs x11 xft`
all: $(COMA)
install: $(COMA)
- install -m 555 $(COMA) $(INSTALL_DIR)/$(COMA)
- install -m 644 coma.1 $(MAN_DIR)/man1/coma.1
+ mkdir -p $(DESTDIR)$(INSTALL_DIR)
+ mkdir -p $(DESTDIR)$(MAN_DIR)/man1
+ install -m 555 $(COMA) $(DESTDIR)$(INSTALL_DIR)/$(COMA)
+ install -m 644 coma.1 $(DESTDIR)$(MAN_DIR)/man1/coma.1
$(COMA): $(OBJS)
$(CC) $(OBJS) $(LDFLAGS) -o $(COMA)