Import kore 3.2.2 as wip/kore.

Kore is an easy to use web application framework for writing scalable
web APIs in C.

Its main goals are security, scalability and allowing rapid development
and deployment of such APIs. Because of this Kore is an ideal candidate
for building robust, scalable and secure web things.
This commit is contained in:
Frederic Cambus 2019-01-28 15:06:57 +01:00
parent 0a00df4bb5
commit e862d3301f
6 changed files with 113 additions and 0 deletions

6
kore/DESCR Normal file
View File

@ -0,0 +1,6 @@
Kore is an easy to use web application framework for writing scalable
web APIs in C.
Its main goals are security, scalability and allowing rapid development
and deployment of such APIs. Because of this Kore is an ideal candidate
for building robust, scalable and secure web things.

17
kore/Makefile Normal file
View File

@ -0,0 +1,17 @@
# $NetBSD$
DISTNAME= kore-3.2.2
CATEGORIES= www
MASTER_SITES= https://kore.io/releases/
MAINTAINER= fred@statdns.com
HOMEPAGE= https://kore.io/
COMMENT= Web application framework for writing scalable web APIs in C
LICENSE= isc
USE_LANGUAGES= c c++
USE_TOOLS+= gmake
MAKE_FLAGS+= TASKS=1
.include "../../mk/bsd.pkg.mk"

12
kore/PLIST Normal file
View File

@ -0,0 +1,12 @@
@comment $NetBSD$
bin/kodev
bin/kore
include/kore/http.h
include/kore/jsonrpc.h
include/kore/kore.h
include/kore/pgsql.h
include/kore/python_api.h
include/kore/python_methods.h
include/kore/tasks.h
man/man1/kodev.1
share/kore/features

8
kore/distinfo Normal file
View File

@ -0,0 +1,8 @@
$NetBSD$
SHA1 (kore-3.2.2.tar.gz) = fbe938c5617cdacc22410320e619fe1083ada3a8
RMD160 (kore-3.2.2.tar.gz) = 9f84c590fd9b8345b467383677d2906b377048ca
SHA512 (kore-3.2.2.tar.gz) = c1c8d16a694c25b55e4a8bc82d0fbc9f3477bcfd9ffe5b3f6e420ba51afebb2b9ff7e974d7e0088195ba88c8f54f5d0fb6a0beaf9c9dfb91a1b2e339e69c50bb
Size (kore-3.2.2.tar.gz) = 1000711 bytes
SHA1 (patch-Makefile) = aff05cd0cce01cbb63481b3b4229f165e06765f1
SHA1 (patch-kodev_Makefile) = 74aadccd5db6fb739242a9356538fd63a9eaebf0

View File

@ -0,0 +1,45 @@
$NetBSD$
Adapt install target for pkgsrc.
--- Makefile.orig 2019-01-21 09:58:12.000000000 +0000
+++ Makefile
@@ -1,13 +1,14 @@
# Kore Makefile
CC?=cc
+DESTDIR?=
PREFIX?=/usr/local
OBJDIR?=obj
KORE=kore
KODEV=kodev/kodev
KORE_CRYPTO?=crypto
INSTALL_DIR=$(PREFIX)/bin
-MAN_DIR=$(PREFIX)/share/man
+MAN_DIR=$(PREFIX)/man
SHARE_DIR=$(PREFIX)/share/kore
INCLUDE_DIR=$(PREFIX)/include/kore
@@ -161,14 +162,14 @@ $(OBJDIR):
@mkdir -p $(OBJDIR)
install:
- mkdir -p $(SHARE_DIR)
- mkdir -p $(INCLUDE_DIR)
- mkdir -p $(INSTALL_DIR)
- mkdir -p $(MAN_DIR)/man1
- install -m 644 share/man/kodev.1 $(MAN_DIR)/man1/kodev.1
- install -m 555 $(KORE) $(INSTALL_DIR)/$(KORE)
- install -m 644 kore.features $(SHARE_DIR)/features
- install -m 644 include/kore/*.h $(INCLUDE_DIR)
+ mkdir -p $(DESTDIR)$(SHARE_DIR)
+ mkdir -p $(DESTDIR)$(INCLUDE_DIR)
+ mkdir -p $(DESTDIR)$(INSTALL_DIR)
+ mkdir -p $(DESTDIR)$(MAN_DIR)/man1
+ install -m 644 share/man/kodev.1 $(DESTDIR)$(MAN_DIR)/man1/kodev.1
+ install -m 555 $(KORE) $(DESTDIR)$(INSTALL_DIR)/$(KORE)
+ install -m 644 kore.features $(DESTDIR)$(SHARE_DIR)/features
+ install -m 644 include/kore/*.h $(DESTDIR)$(INCLUDE_DIR)
$(MAKE) -C kodev install
uninstall:

View File

@ -0,0 +1,25 @@
$NetBSD$
Adapt install target for pkgsrc.
--- kodev/Makefile.orig 2019-01-21 09:58:12.000000000 +0000
+++ kodev/Makefile
@@ -4,6 +4,7 @@ CC?=cc
PREFIX?=/usr/local
OBJDIR?=obj
KODEV=kodev
+DESTDIR?=
INSTALL_DIR=$(PREFIX)/bin
S_SRC= ../src/cli.c
@@ -37,8 +38,8 @@ $(OBJDIR):
@mkdir -p $(OBJDIR)
install: $(KODEV)
- mkdir -p $(INSTALL_DIR)
- install -m 555 $(KODEV) $(INSTALL_DIR)/$(KODEV)
+ mkdir -p $(DESTDIR)$(INSTALL_DIR)
+ install -m 555 $(KODEV) $(DESTDIR)$(INSTALL_DIR)/$(KODEV)
uninstall:
rm -f $(INSTALL_DIR)/$(KODEV)