doomlegacy: Undefine DEBUG, Silence warnings

This commit is contained in:
Michael Baeuerle 2019-06-14 17:31:18 +02:00
parent 857302fa48
commit e8f2242331
4 changed files with 34 additions and 8 deletions

View File

@ -34,7 +34,7 @@ MAKE_FLAGS+= OS=MAC
# Other Unix (should work for GNU/Linux, OpenBSD and SunOS)
MAKE_FLAGS+= OS=LINUX
.endif
MAKE_FLAGS+= HAVE_MIXER=1 DEBUG=0
MAKE_FLAGS+= HAVE_MIXER=1
.if ${MACHINE_ENDIAN} == "big"
# Some compilers define this themselves (but maybe not all)

View File

@ -1,12 +1,12 @@
[X] Patch to support NetBSD
FreeBSD codepath does not work for NetBSD
=> Use statvfs()
[X] Disable parallel make jobs
Build system seems to not support that
[X] Build system seems to not support that
=> Disable parallel make jobs
[X] Test on GNU/Linux
[X] Check that Big Endian platforms work too
Seems to work out-of-the-box with GCC
=> Nevertheless ensure that __BIG_ENDIAN__ is always defined if required
[X] Test on GNU/Linux
[X] Configure for pkgsrc DOOMWADDIR: ${PREFIX}/share/doom
Add Message for DOOMWADDIR location
=> Set LEGACYWADDIR to DOOMWADDIR and install legacy.wad there
@ -16,8 +16,12 @@
[X] Honor CFLAGS/LDFLAGS/LIBS
[X] Check MKPIE/RELRO/USE_STACK_CHECK hardening flags on NetBSD/amd64
[X] Check for reproducible build (PKGSRC_MKREPRO)
[ ] Check build with clang
Dependency generation fails
[X] Check build with clang
(Dependency generation fails)
Problem was with clang installation, not related to package
(DEBUG creates GCC specific options)
Undefine DEBUG
=> Works now
[ ] Analyze why MIDI music doesn't work
[X] Check OpenGL renderer
GNU/Linux: Looks nice
@ -29,10 +33,12 @@
[X] Check Ultimate Doom Episode 4 (Thy Flesh Consumed)
[X] Check Romero's 25th anniversary Episode 5 (Sigil)
SIGIL_COMPAT.wad works with doom.wad as IWAD
SIGIL.wad works with doomu.wad as IWAD (menu entry for Episode 5 is missing)
[X] Check Doom II (Hell on Earth)
[X] Check Final Doom Part 1 (TNT: Evilution)
[X] Check Final Doom Part 2 (The Plutonia Experiment)
[X] Check Heretic
[ ] man page with examples how to specify WADs and game type on commandline
EOF

View File

@ -9,7 +9,7 @@ RMD160 (doomlegacy_1.47.2_source.tar.bz2) = 661f0fa2bdc58a2f5f9582f36817ddd9d48d
SHA512 (doomlegacy_1.47.2_source.tar.bz2) = e2e182c18dd24c14e954f791c58e44119457bb74af4bb079c16219406176536f9fd414afd6c9fa0e956a6062b5a346bbf19ebf4c0d2d300e2e66b2eb01cf53fd
Size (doomlegacy_1.47.2_source.tar.bz2) = 2276199 bytes
SHA1 (patch-Makefile) = 03fc2f70c4a91ab6e7e3611f594eeaee4ac78b6b
SHA1 (patch-src_Makefile) = 1604ba5ede46c8e19db10c094155d0413652f420
SHA1 (patch-src_Makefile) = 15cb6daa92f0d00eaf3b6956ef2813fa8358742c
SHA1 (patch-src_d__main.c) = 89188e534d486d9cfbf2ad92f63b4eb7ab6c50f8
SHA1 (patch-src_doomtype.h) = fefe08ca5fbe8d11325e32ca833a73d3acb36ea1
SHA1 (patch-src_i__tcp.c) = 1c0c6017d24640217e29ed238e210850329d0e75

View File

@ -1,7 +1,8 @@
$NetBSD$
Add NetBSD to OS list.
Honor environment variables CFLAGS, LDFLAGS and LIBS
Honor environment variables CFLAGS, LDFLAGS and LIBS.
Silence warnings about common symbol merging.
--- src/Makefile.orig 2018-07-16 09:17:06.000000000 +0000
+++ src/Makefile
@ -113,3 +114,22 @@ Honor environment variables CFLAGS, LDFLAGS and LIBS
endif
SDL_CONFIG:=1
@@ -1010,12 +1023,12 @@ CFLAGS+=-ffast-math -fno-strict-aliasing
LCFLAGS:=$(CFLAGS)
CFLAGS+=$(OPTS) $(OPTINC)
-ifdef MAC
- # MAC linker does not accept these flags.
-else
- # Flags to the linker.
- LDFLAGS+=-Xlinker --warn-common
-endif
+#ifdef MAC
+# # MAC linker does not accept these flags.
+#else
+# # Flags to the linker.
+# # LDFLAGS+=-Xlinker --warn-common
+#endif
SNDSERV_EXTRAFLAGS:=
ifdef HAVE_ESD