OpenTESArena: update to OpenTESArena-0.11.0

This engine is still a work in progress, and freezes after a short while:

  https://github.com/afritz1/OpenTESArena/issues/145

which will hopefully be fixed in a later release.

OpenTESArena 0.11.0

New features and changes in version 0.11.0:

  * Original entity loading (static NPCs, creatures, trees, furniture, palace rulers, etc.)
  * Lights
  * Water and lava rendering
  * Translucent entity rendering
  * Ray cast selection with pixel-perfect option (@faha223)
  * 3D positional audio (@Plettro)
  * Initial work on chunk system for game world
  * Periodic creature sounds
  * Fading voxels
  * Streetlights turn on and off automatically
  * Changed in-game day/night clock speed to match original game (R hotkey to fast-forward time)
  * Initial work on texture filtering in pixel shaders (nearest/linear mode)
  * Fixed incorrect cloud pixels (now using partial transparency)
  * Fixed starting dungeon fast travel onVoxelEnter bug

Known issues:

  * Some streetlights don't receive on/off signal
  * Translucent entities exhibit vertical line artifacts (related to multi-threading)
  * The renderer may deadlock and freeze the game. If so, reduce render thread count to very low
  * Position of moons is not correct
  * Tavern names in Imperial City are incorrect
  * Diagonal walls have same collision as walls

OpenTESArena 0.10.0

New features and changes in version 0.10.0:

  * Wilderness generation
  * Wilderness automap
  * City <-> wilderness transitions via city gate
  * City placeholder in wilderness
  * Player position in wilderness displayed with F2
  * CD version support
  * Initial work on inventory slots (@MinganMuon)

Notes:

  * Original sprites are not being loaded yet

Known issues:

  * Position of moons is not correct
  * Tavern names in Imperial City are incorrect
  * Diagonal walls have same collision as walls

OpenTESArena 0.9.0

New features and changes in version 0.9.0:

  * Distant land, sky, and space rendering. Space rendering takes player latitude into account
  * Sky gradient
  * Palace entrances and gate graphics
  * Improved multi-threading in renderer
  * Improved thread sleeping on frames that took less than the target frame time
  * Improved text wrapping and new line distribution
  * Fixed morning star weapon negative height given to renderer

Notes:

  * Wilderness is not implemented yet
  * Original sprites are not being loaded yet

Known issues:

  * Position of moons is not correct
  * Tavern names in Imperial City are incorrect
  * Diagonal walls have same collision as walls
This commit is contained in:
Yorick Hardy 2020-04-04 23:49:54 +02:00
parent 049bacfef1
commit ea820f205b
5 changed files with 45 additions and 5 deletions

View File

@ -2,7 +2,7 @@
GITHUB_PROJECT= OpenTESArena
DISTNAME= ${GITHUB_TAG}
PKGNAME= ${GITHUB_PROJECT}-0.8.0
PKGNAME= ${GITHUB_PROJECT}-0.11.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GITHUB:=afritz1/}
DIST_SUBDIR= ${GITHUB_PROJECT}

View File

@ -2,5 +2,6 @@
bin/TESArena
share/OpenTESArena/data/icon.bmp
share/OpenTESArena/data/text/aExeStrings.txt
share/OpenTESArena/data/text/acdExeStrings.txt
share/OpenTESArena/options/options-default.txt
share/doc/OpenTESArena/README.md

View File

@ -1,9 +1,11 @@
$NetBSD$
SHA1 (OpenTESArena/opentesarena-0.8.0.tar.gz) = 6f74e8ae44de41bf50597ef230258eb22d96ce90
RMD160 (OpenTESArena/opentesarena-0.8.0.tar.gz) = 5db4c46fd5ed683b49549ebb7b6c0b85771e13fb
SHA512 (OpenTESArena/opentesarena-0.8.0.tar.gz) = c81f27e88fb44ac481bf5d34a49a0d841d51b97c51206a3b374b852dd2e5a76d542bf1899e767b9ab7ae93ceceb82a2c3e21220ed4ff6800c08e1f3421d582fd
Size (OpenTESArena/opentesarena-0.8.0.tar.gz) = 3874829 bytes
SHA1 (OpenTESArena/opentesarena-0.11.0.tar.gz) = 957eb3e4457287f8791ee1e0025afc3bef98c214
RMD160 (OpenTESArena/opentesarena-0.11.0.tar.gz) = 4b7bb771d6f2c6c597d5f399a8850fe2c79e23e3
SHA512 (OpenTESArena/opentesarena-0.11.0.tar.gz) = 535d151bdc7d384be0a974b0661e623826460d414ea7de0f44159f5f4b2e710830b9b503bd3b8009fced402b121c41913852fd7ee1e133a6b7cf68976517619c
Size (OpenTESArena/opentesarena-0.11.0.tar.gz) = 4669368 bytes
SHA1 (patch-CMakeLists.txt) = 970fe3afa9416ec0f886754665544df93e038b44
SHA1 (patch-OpenTESArena_src_Interface_ProvinceMapPanel.cpp) = 175f7e2527d90e65414d56d2ed886d025947e386
SHA1 (patch-OpenTESArena_src_Interface_TextCinematicPanel.cpp) = 40598c6f15038bcaf785a4ab3fe6c187bd6361c8
SHA1 (patch-OpenTESArena_src_Rendering_SoftwareRenderer.cpp) = fa8fbb9edf260d3c8a1d110c4ca2470d54316b2f
SHA1 (patch-OpenTESArena_src_Utilities_Platform.cpp) = ca299fe19539227e19cdc4285a841c0dcc24739e

View File

@ -0,0 +1,15 @@
$NetBSD$
Disable the SSE4 code so that older CPU's are supported.
--- CMakeLists.txt.orig 2020-04-04 20:30:08.638946764 +0000
+++ CMakeLists.txt
@@ -24,7 +24,7 @@ IF (CMAKE_COMPILER_IS_GNUCXX OR CMAKE_CX
ENDIF ()
# Optimizations.
- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse4.1")
+ # SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse4.1")
ENDIF ()
# We want RelWithDebInfo to actually include debug stuff (define _DEBUG

View File

@ -0,0 +1,22 @@
$NetBSD$
Disable the SSE4 code so that older CPU's are supported.
--- OpenTESArena/src/Rendering/SoftwareRenderer.cpp.orig 2020-03-27 01:34:48.000000000 +0000
+++ OpenTESArena/src/Rendering/SoftwareRenderer.cpp
@@ -4397,6 +4397,7 @@ void SoftwareRenderer::drawDistantPixels
double vStart, double vEnd, const SkyTexture &texture, bool emissive,
const ShadingInfo &shadingInfo, const FrameView &frame)
{
+#if 0
// @todo: fix. this is now out of sync with the non-SSE version.
// Draw range values.
@@ -4537,6 +4538,7 @@ void SoftwareRenderer::drawDistantPixels
}
}
}
+#endif
}
/*void SoftwareRenderer::drawDistantPixelsAVX(int x, const DrawRange &drawRange, double u,