dlt-daemon: updated to 2.18.3, conf files are installed correctly now.

This commit is contained in:
Aleksej Lebedev 2019-07-23 10:38:35 +02:00
parent e2bc8da2db
commit ef1743160d
4 changed files with 37 additions and 35 deletions

View File

@ -1,7 +1,7 @@
# $NetBSD$
GITHUB_PROJECT= dlt-daemon
VERSION= 2.16.0
VERSION= 2.18.3
PKGNAME= ${GITHUB_PROJECT}-${VERSION}
DISTNAME= v${VERSION}
CATEGORIES= sysutils
@ -14,7 +14,7 @@ HOMEPAGE= https://github.com/GENIVI/dlt-daemon/
COMMENT= GENIVI Diagnostic Log and Trace
LICENSE= mpl-2.0
WRKSRC= ${WRKDIR}/dlt-daemon-2.16.0
WRKSRC= ${WRKDIR}/dlt-daemon-${VERSION}
USE_CMAKE= yes
USE_TOOLS+= pkg-config
USE_LANGUAGES= c c++
@ -24,5 +24,22 @@ PKGCONFIG_OVERRIDE+= automotive-dlt.pc.in
ONLY_FOR_PLATFORM= Linux-*-*
EGDIR= ${PREFIX}/share/examples/${PKGBASE}
CONFS= dlt.conf dlt_gateway.conf
.for f in ${CONFS}
CONF_FILES+= ${EGDIR}/${f} ${PKG_SYSCONFDIR}/${f}
.endfor
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1 ${PKGMANDIR}/man5 share/examples/${PKGBASE}
OWN_DIRS+= ${PKG_SYSCONFDIR}/xbps.d
post-install:
${MKDIR} ${DESTDIR}${EGDIR} &&\
for f in ${CONFS}; do \
${MV} ${DESTDIR}${PREFIX}/etc/$${f} ${DESTDIR}${EGDIR}; \
done
.include "../../sysutils/dbus/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,19 +1,15 @@
@comment $NetBSD$
bin/dlt-adaptor-stdin
bin/dlt-adaptor-udp
bin/dlt-control
bin/dlt-convert
bin/dlt-daemon
bin/dlt-dbus
bin/dlt-example-filetransfer
bin/dlt-example-user
bin/dlt-example-user-common-api
bin/dlt-example-user-func
bin/dlt-kpi
bin/dlt-logstorage-ctrl
bin/dlt-passive-node-ctrl
bin/dlt-receive
bin/dlt-system
bin/dlt-sortbytimestamp
bin/dlt-test-client
bin/dlt-test-filetransfer
bin/dlt-test-fork-handler
@ -24,11 +20,8 @@ bin/dlt-test-stress
bin/dlt-test-stress-client
bin/dlt-test-stress-user
bin/dlt-test-user
etc/dlt-dbus.conf
etc/dlt-kpi.conf
etc/dlt-system.conf
etc/dlt.conf
etc/dlt_gateway.conf
share/examples/dlt-daemon/dlt.conf
share/examples/dlt-daemon/dlt_gateway.conf
include/dlt/dlt.h
include/dlt/dlt_client.h
include/dlt/dlt_common.h
@ -45,13 +38,5 @@ lib/libdlt.so
lib/libdlt.so.2
lib/libdlt.so.${PKGVERSION}
lib/pkgconfig/automotive-dlt.pc
man/man1/dlt-convert.1
man/man1/dlt-daemon.1
man/man1/dlt-logstorage-ctrl.1
man/man1/dlt-passive-node-ctrl.1
man/man1/dlt-receive.1
man/man1/dlt-system.1
man/man5/dlt-system.conf.5
man/man5/dlt.conf.5
share/dlt-filetransfer/dlt-test-filetransfer-file
share/dlt-filetransfer/dlt-test-filetransfer-image.png

View File

@ -1,7 +1,7 @@
$NetBSD$
SHA1 (dlt-daemon/v2.16.0.tar.gz) = 417454c1ab01a8460706fa91d378908ee3fe95e9
RMD160 (dlt-daemon/v2.16.0.tar.gz) = 299c79bafb91cad08c67788cfff2b608b84b9bb9
SHA512 (dlt-daemon/v2.16.0.tar.gz) = a0e131008db3a07ab01e00cfaf7e36fc310f9165f98b3dbc5258e47d3dfe2698d8d28d8f23df076554475f428ca4aa90a722835bccbb1330a3075a78060e6444
Size (dlt-daemon/v2.16.0.tar.gz) = 6158969 bytes
SHA1 (patch-doc_CMakeLists.txt) = 24efaf33a37b3d9cfc8a2da272337083f79fd7c5
SHA1 (dlt-daemon/v2.18.3.tar.gz) = c405d1081014052862ef87d94d2164008d0bfbe3
RMD160 (dlt-daemon/v2.18.3.tar.gz) = e778cda9d9ac553c1825aba3b204e43e19dc25fd
SHA512 (dlt-daemon/v2.18.3.tar.gz) = d0fc43f81255c990fe0510b6b874fe6c5ef7419538f53aeff2a78cb992ae0e57bbb26ec99c5f636ce1755836c7877c5fa61d977b438ef31b54b7fcdb8ef55e86
Size (dlt-daemon/v2.18.3.tar.gz) = 6252773 bytes
SHA1 (patch-doc_CMakeLists.txt) = 89335c90ea885385184c48fc2771f55ef99bb492

View File

@ -1,13 +1,13 @@
$NetBSD$
--- doc/CMakeLists.txt.orig 2016-10-24 07:32:49.000000000 +0000
--- doc/CMakeLists.txt.orig 2019-06-11 04:35:08.000000000 +0000
+++ doc/CMakeLists.txt
@@ -124,7 +124,7 @@ if(WITH_MAN)
COMMAND ${GZIP_TOOL} -c ${MAN_BUILD_DIR}/dlt-passive-node-ctrl.1 > ${MAN_BUILD_DIR}/dlt-passive-node-ctrl.1.gz)
# If user has not set the base dir for man pages, use a default location
- set(MAN_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/share/man)
+ set(MAN_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/man)
install(FILES
${MAN_BUILD_DIR}/dlt.conf.5.gz
@@ -141,7 +141,7 @@ if(WITH_MAN)
COMMAND ${GZIP_TOOL} -c ${MAN_BUILD_DIR}/dlt-passive-node-ctrl.1 > ${MAN_BUILD_DIR}/dlt-passive-node-ctrl.1.gz)
# If user has not set the base dir for man pages, use a default location
- set(MAN_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/share/man)
+ set(MAN_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/man)
install(FILES
${MAN_BUILD_DIR}/dlt.conf.5.gz