Update to 0.6.3:

GemRB V0.6.3 (2010-11-21)
  New features:
    - IWD:HoW is now completable!
    - casting sounds and footsteps
    - autodetection of secret doors, detect illusions
    - basic bardsong support and selective magic resistance (bg2-style)
    - proper store economics, ergonomics and dragging
    - custom blood color (creature-dependant)
    - new actions, iwd effects and triggers
    - Importing a SoA game into ToB

  Improved features:
    - actor selection and action bar (for summons and illusions too!)
    - door bashing and traps
    - loading screens, ambushes, worldmap
    - sparkles, panic and other effects
    - actions, dialogs, object matching
    - personal items support (swap/equip/remove)
    - bugfixes

  Applied patches:
	iwd regression fix from Eggert Jón Magnússon

GemRB V0.6.2 (2010-08-21):
  New features:
    - a basic SDL_mixer plugin for faster, but lower-quality audio
    - dualclassing for bg1 and iwd
    - new triggers, actions, infravision
    - feet circle flickering on portrait hover, coloration in dialog
    - wisdom xp bonus (pst)

  Improved features:
    - actions, triggers, object matching
    - item loading and ability selection, inventory
    - projectiles, effects, subtitles, verbal constants
    - the core and guiscript design was cleaned up in many places
    - bugfixes

  Applied patches:
    backslash check patch from anthiste
    bg1 character generation patch from Maighstir
    a crosscompiling fix from F.Fischer

GemRB V0.6.1 (2010-06-16):
  New features:
    - a minimal dataset
    - reputation penalties on death or injury
    - casting level bonus/malus (wild mages, clerics)
    - tinting for different times of the day and weather effects
    - a BI(n)K player plugin for the IWD2 movies
    - new actions, turn undead

  Improved features:
    - the internal design was cleaned up in many places
    - game saving, modal actions, combat, effects, spawns
    - magic missiles are now drawn properly
    - various guiscripts (no more flickering!)
    - bugfixes

  Applied patches:
    two patches from Brendan Molloy
This commit is contained in:
Thomas Klausner 2011-01-24 14:26:24 +00:00
parent 9a380537cd
commit f17e2709f9
8 changed files with 845 additions and 442 deletions

View File

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.2 2010/06/13 22:47:04 thomasklausner Exp $
# $NetBSD: Makefile,v 1.3 2011/01/24 14:26:24 thomasklausner Exp $
#
DISTNAME= gemrb-0.6.0
PKGREVISION= 1
DISTNAME= gemrb-0.6.3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=gemrb/}
@ -13,19 +12,21 @@ LICENSE= gnu-gpl-v2
PKG_DESTDIR_SUPPORT= user-destdir
GNU_CONFIGURE= yes
USE_CMAKE= yes
USE_LIBTOOL= yes
USE_LANGUAGES= c c++
USE_TOOLS+= gmake
USE_TOOLS+= gmake pkg-config
BUILDLINK_TRANSFORM+= rm:-Werror
INSTALL_MAKE_FLAGS+= sysconfdir=${PREFIX}/share/examples/gemrb
.include "../../audio/freealut/buildlink3.mk"
#.include "../../audio/freealut/buildlink3.mk"
.include "../../audio/openal/buildlink3.mk"
.include "../../audio/SDL_mixer/buildlink3.mk"
.include "../../audio/libvorbis/buildlink3.mk"
.include "../../devel/SDL/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../lang/python/application.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../mk/bsd.pkg.mk"

File diff suppressed because it is too large Load Diff

View File

@ -1,8 +1,10 @@
$NetBSD: distinfo,v 1.3 2011/01/24 14:02:40 thomasklausner Exp $
$NetBSD: distinfo,v 1.4 2011/01/24 14:26:24 thomasklausner Exp $
SHA1 (gemrb-0.6.0.tar.gz) = bc59f6111bb40a4a9b9c78ab9b7521d8e2da35f7
RMD160 (gemrb-0.6.0.tar.gz) = 5c5d04a62453abae02a270eaa56676419fa5dbb3
Size (gemrb-0.6.0.tar.gz) = 2227197 bytes
SHA1 (patch-aa) = 1a52f0070e55353bfab61808c849c8b774cac855
SHA1 (patch-ab) = 314174073b087e259783704bd7dd274c0fac4b72
SHA1 (patch-ac) = 34c219131dc8828d03271f84994dc9a38b89d604
SHA1 (gemrb-0.6.3.tar.gz) = c849490d6669be92b982ff8cb4bfc050cc24e818
RMD160 (gemrb-0.6.3.tar.gz) = 0dcf3672d719a62972a558644528973587ba5fe2
Size (gemrb-0.6.3.tar.gz) = 1731131 bytes
SHA1 (patch-aa) = 33a8fb98d3bf703fe538bad3ed84a5e7fe3eda18
SHA1 (patch-ab) = c912a4f134ed3b26a1ad782b694dc910612ab4ee
SHA1 (patch-ac) = 549ae2cd7c030e590c4c8cfa69533b7aa5272572
SHA1 (patch-ad) = 3d716b7b14a5e801732ec090ce7854f99f77e3be
SHA1 (patch-ae) = 8589c5c99ede5330afc468acb98084648ec5e475

View File

@ -1,26 +1,15 @@
$NetBSD: patch-aa,v 1.1.1.1 2009/12/08 22:38:46 thomasklausner Exp $
$NetBSD: patch-aa,v 1.2 2011/01/24 14:26:24 thomasklausner Exp $
Compilation on NetBSD-4.99.7/amd64 fails if these are not
commented out. Better solution happily accepted...
Unportable test(1) construct.
--- gemrb/plugins/ACMImporter/general.h.orig 2005-02-23 22:20:52.000000000 +0000
+++ gemrb/plugins/ACMImporter/general.h
@@ -25,7 +25,9 @@
// Interplay ACM signature
#define IP_ACM_SIG 0x01032897
+#if 0
#pragma pack (push, 1)
+#endif
struct ACM_Header {
unsigned int signature;
unsigned int samples;
@@ -34,6 +36,8 @@ struct ACM_Header {
unsigned short levels : 4;
unsigned short subblocks : 12;
};
+#if 0
#pragma pack (pop)
+#endif
#endif
--- autogen.sh.orig 2010-11-20 22:45:02.000000000 +0000
+++ autogen.sh
@@ -19,7 +19,7 @@ future versions! Please switch to using
if [ "$1" = "" ]; then
dest=$HOME/GemRB
else
- if [ "${1:0:1}" == "/" ]; then
+ if [ "${1:0:1}" = "/" ]; then
dest=$1
else
dest=$PWD/$1

View File

@ -1,10 +1,12 @@
$NetBSD: patch-ab,v 1.1.1.1 2009/12/08 22:38:46 thomasklausner Exp $
$NetBSD: patch-ab,v 1.2 2011/01/24 14:26:24 thomasklausner Exp $
--- gemrb/CMakeLists.txt.orig 2009-08-18 15:23:48.000000000 +0000
Install sample config into share/examples.
--- gemrb/CMakeLists.txt.orig 2010-11-20 22:45:02.000000000 +0000
+++ gemrb/CMakeLists.txt
@@ -15,4 +15,4 @@ ELSE(WIN32)
ENDIF(WIN32)
@@ -31,4 +30,4 @@ CONFIGURE_FILE(
)
INSTALL( TARGETS gemrb DESTINATION ${CMAKE_INSTALL_PREFIX})
-INSTALL( FILES GemRB.cfg.sample GemRB.cfg.subdir.sample DESTINATION ${CMAKE_INSTALL_PREFIX} )
+INSTALL( FILES GemRB.cfg.sample GemRB.cfg.subdir.sample DESTINATION ${CMAKE_INSTALL_PREFIX}/share/examples/gemrb )
INSTALL( TARGETS gemrb DESTINATION ${BIN_DIR} )
-INSTALL( FILES "${CMAKE_CURRENT_BINARY_DIR}/GemRB.cfg.sample" GemRB.cfg.noinstall.sample DESTINATION ${SYSCONF_DIR} )
+INSTALL( FILES "${CMAKE_CURRENT_BINARY_DIR}/GemRB.cfg.sample" GemRB.cfg.noinstall.sample DESTINATION ${CMAKE_INSTALL_PREFIX}/share/examples/gemrb )

View File

@ -1,11 +1,10 @@
$NetBSD: patch-ac,v 1.2 2011/01/24 14:02:41 thomasklausner Exp $
$NetBSD: patch-ac,v 1.3 2011/01/24 14:26:24 thomasklausner Exp $
Fix build with png-1.5.
https://sourceforge.net/tracker/?func=detail&atid=110122&aid=3164742&group_id=10122
--- gemrb/plugins/PNGImporter/PNGImp.cpp.orig 2009-06-18 21:59:16.000000000 +0000
+++ gemrb/plugins/PNGImporter/PNGImp.cpp
@@ -32,7 +32,7 @@
--- gemrb/plugins/PNGImporter/PNGImporter.cpp.orig 2010-11-20 22:45:02.000000000 +0000
+++ gemrb/plugins/PNGImporter/PNGImporter.cpp
@@ -33,7 +33,7 @@
static void DataStream_png_read_data(png_structp png_ptr,
png_bytep data, png_size_t length)
{

24
gemrb/patches/patch-ad Normal file
View File

@ -0,0 +1,24 @@
$NetBSD: patch-ad,v 1.1 2011/01/24 14:26:24 thomasklausner Exp $
Only check for libdl on Linux. Untested.
--- CMakeLists.txt.orig 2010-11-20 22:45:02.000000000 +0000
+++ CMakeLists.txt
@@ -140,14 +140,16 @@ ELSE()
MESSAGE(FATAL_ERROR "Please install the Zlib library and headers first!")
ENDIF()
-IF(UNIX)
+IF(LINUX)
FIND_LIBRARY(DLD_LIBRARY_PATH dl dld)
IF(DLD_LIBRARY_PATH)
MESSAGE(STATUS "Looking for dl library: found")
ELSE(DLD_LIBRARY_PATH)
MESSAGE(FATAL_ERROR "Looking for dl library: not found!")
ENDIF(DLD_LIBRARY_PATH)
+ENDIF(LINUX)
+IF(UNIX)
SET(CMAKE_THREAD_PREFER_PTHREAD true)
FIND_PACKAGE(Threads REQUIRED)
ENDIF(UNIX)

13
gemrb/patches/patch-ae Normal file
View File

@ -0,0 +1,13 @@
$NetBSD: patch-ae,v 1.1 2011/01/24 14:26:24 thomasklausner Exp $
Don't link against libdl, it's not needed on NetBSD.
XXX: should be fixed better for other opsys.
--- gemrb/plugins/GUIScript/CMakeLists.txt.orig 2010-11-20 22:45:02.000000000 +0000
+++ gemrb/plugins/GUIScript/CMakeLists.txt
@@ -2,4 +2,4 @@ INCLUDE(FindPythonLibs)
INCLUDE_DIRECTORIES(${PYTHON_INCLUDE_PATH})
ADD_GEMRB_PLUGIN (GUIScript GUIScript.cpp PythonHelpers.cpp)
-TARGET_LINK_LIBRARIES( GUIScript ${PYTHON_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} -ldl)
+TARGET_LINK_LIBRARIES( GUIScript ${PYTHON_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})